Voice VLAN and VMPS...

Unanswered Question
Jun 27th, 2008

Hi all,

Anyone had any experience with this?

We use Ericsson 4422 IP Phones running on an MD110 PBX. We have 2 switches that use the phones. We also run VMPS for dynamic vlan allocation for PCs.

One switch is a Cisco 3750. each port is configured as follows:

interface FastEthernet1/0/7

switchport access vlan dynamic

switchport mode access

switchport voice vlan 102

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

spanning-tree portfast

We can plug a phone into this port and it works no problem, we can also piggyback a PC off of the phone.

next, is the Cisco 3560, each interface is:

interface FastEthernet0/7

switchport access vlan dynamic

switchport mode access

switchport voice vlan 104

srr-queue bandwidth share 1 70 25 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

mls qos trust dscp

spanning-tree portfast

Now, on this switch, a phone plugged in on its own doesn't work. A PC piggybacked off of the phone does work and a PC on its own is fine.

Only the PCs are in VMPS in all of the examples.

When i plug a phone into the Cisco 3560, i reveive a VQP-2-DENY message for the phones Mac, so it doesn;t seem like the 3560 is adding it to the Voice VLAN, even though i have statically configured this on the interface.

Any ideas?

Many thanks

Jonathan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
alig.norbert Sat, 06/28/2008 - 13:38

Hi Jonathan,

VMPS check only the first MAC-Address entering the switch port.

I'm not sure, but the "switchport voice vlan xx" command only works, when a trunk is build up between ip-phone<->switch. And the VMPS doesn't support trunk ports.

Greets,

Norbert

jonathanaxford Sun, 06/29/2008 - 05:27

Hi Norbert,

Thanks for the response. I am not sure that our VMPS functions in exactly that way - the configuration for the 3750 switch works fine. A PC can be run off the back of an IP phone and only the PC needs to be in VMPS. The phone is obviously detected on the port first as this is plugged directly into the switch. Also, putting the phones MAC address into VMPS still doesn't work.

My understanding was that the port to the phone had to be trunked, but as far as i know, the Cisco switchport voice vlan command makes this unnecessary.

Is an odd one, i can't quite figure out what is different between the two switches!

Cheers

Jonathan

Giuseppe Larosa Sun, 06/29/2008 - 05:33

Hello Jonathan,

>>Is an odd one, i can't quite figure out >>what is different between the two switches!

What is different are the two switches models and their IOS image !

If you can, try to upgrade the IOS image on the c3560 to the latest image in the same train.

hope to help

Giuseppe

jonathanaxford Sun, 06/29/2008 - 06:45

Yep! that is kinda obvious!!!

I was thinking more in terms of configuration guidelines etc!

Pretty sure the 3560 is running one of the latest versions of code, will double check this when i get back to the office, if not, i'll upgrade it.

The 3750 is definitely not up to date, the switch has been in commission for a long time and has never been updated as far as i know.

Thanks for the help,

Jonathan

alig.norbert Wed, 07/02/2008 - 01:34

Hi Jonathan,

Do the IP-Phones support CDP?

When the IP-phone is plugged in, which vlan will be associate to the port (show interface status)?

Have you tried once without dynamic-vlan?

Greets,

Norbert

jonathanaxford Wed, 07/02/2008 - 03:08

Hi Norbert,

As far as i know, the phones do not support CDP, that is a guess though, they are Ericsson 4422IP and i can't find a great deal of info on them!

When the IP Phone is plugged into the switchoprt, the VMPS system immediately denies it. If a computer is patched into the back of the phone, the PC works fine and VMPS correctly allocates a VLAN.

If i hardcode the switchport to the Voice VLAN using Switchport access VLAN 104, the phone works straight away... so the problem lies in getting the phone to be recognised in the Switchport Voice VLAN setting.

I am going to see if there is an option to hardcode the Voice VLAN on the phone and see if this allows it through...

Cheers

Jonathan

alig.norbert Wed, 07/02/2008 - 10:58

Jonathan,

I suppose the PC (connected to the ip-phone) authenticates to the VMPS and "opens" the switchport.

After that, the VMPS doesn't care anymore, which client (in your case the ip-phone) is connected to the port.

The same as you would put a hub on the switchport. Only the first MAC-address will be checked agains the VMPS.

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/25sg/configuration/guide/vlans.html#wp1053389

Greets,

Norbert

jonathanaxford Wed, 07/02/2008 - 23:55

Agreed, but once the switchport is up, due to the PC coming online, the Phone still doesn't come up!

So, it must be a problem with the phones connection to the voice VLAN... Going to spend a bit of time on this today...

Also, if we place the phones MAC address in the VMPS list, it still won't work - which also sort of makes sense, as VMPS should ignore trunked ports and as far as i understand it, the IP phone should make a trunked connection to the Switchport?

Cheers

Jonathan

jonathanaxford Thu, 07/03/2008 - 06:44

Having done a great deal of digging on the Ericsson IP phones and how the history of them on the site, it is definitely an issue with the configruation of the phone and not the switch!

Actions

This Discussion