NAC - "The attempt to connect to the server failed. [12029]"

Unanswered Question
Jun 27th, 2008

Hi all,

I have got a problem as below:

I have a NAC in-band model. It was working normally, but when I changed IP (CAS, CAM) to a new assignment, I got a problem: I couldn't use Cisco Clean Access Agent to log into my network, there was an error message "The attempt to connect to the server failed. [12029]" when I tried to log in by Clean Access Agent.

Anyone have got the same problem, pls give me some advices.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
etms Tue, 07/01/2008 - 05:29

You may need to regenerate SSL certificates.

namnt2604 Tue, 07/01/2008 - 17:37


Of course, that was the first action I have done after regenerating the certs.

- Step 1: Regenerate the certs in "service perfigo config"

- Step 2: Type "service perfigo restart"

- Step 3: Finally, type "reboot"

But it seems the problem has not been solved.

Do you have any other idea?



etms Wed, 07/02/2008 - 04:54

Sorry, I'm out of ideas. The only thing I've seen that message from was invalid certificates or just plain old connectivity issues (no IP route between CAM & CAS). Keep in mind I'm no expert on this product, we are still in the process of deploying ours and we ran into a number of these problems.

ciscoforumuser Thu, 07/03/2008 - 10:58

I had same issue which was resolved by un-installing and re-installing the agent. I think it has to with certificate, the Vista did not think the certificate was valid even after we installed Entrust cert. on cam and cas.

namnt2604 Wed, 07/16/2008 - 20:17

At the first time, I had used IP of DNS server to generate my cert, this had made the above problem. Then I had regenerated the cert by ethernet interface of CAM, this had solved my problem. I didn't know why, anyone could explained that?


This Discussion