Frame-rely troubleshooting

Unanswered Question
Jun 27th, 2008

I have been trying to configure frame relay for the past two days, my protocol will not stay up. Below is my running config on both routers:

R1

sh run

Building configuration...

Current configuration : 1132 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$uHaf$uhnNzXlrRKb2jSD7F1IFt/

!

username R2 password 0 cisco

memory-size iomem 10

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.128

duplex auto

speed auto

!

interface Serial0/0

ip address 172.16.0.1 255.255.255.252

encapsulation ppp

clockrate 64000

no fair-queue

ppp authentication chap

!

interface BRI0/0

no ip address

shutdown

!

interface Serial0/1

ip address 172.16.0.9 255.255.255.252

encapsulation frame-relay

frame-relay map ip 172.16.0.10 101 broadcast

frame-relay lmi-type ansi

!

router rip

version 2

network 10.0.0.0

network 172.16.0.0

!

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

!

!

!

banner motd ^CHELP!!!^C

!

line con 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

password cisco

login

!

!

end

and here is R3:

sh run

Building configuration...

Current configuration : 1156 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$Xi9C$K2BeD99qLoFVfZlMprcIk0

!

memory-size iomem 10

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

bandwidth 64

ip address 172.16.0.10 255.255.255.252

encapsulation frame-relay

no fair-queue

frame-relay map ip 172.16.0.9 102 broadcast

frame-relay lmi-type ansi

!

interface BRI0/0

no ip address

shutdown

!

interface FastEthernet0/1

ip address 10.0.0.129 255.255.255.128

duplex auto

speed auto

!

interface Serial0/1

ip address 172.16.0.6 255.255.255.252

!

router rip

version 2

network 10.0.0.0

network 172.16.0.0

!

ip http server

no ip http secure-server

ip classless

!

!

!

!

!

!

!

!

!

banner motd ^CLast Lab!!!^C

!

line con 0

password cisco

logging synchronous

login

line aux 0

line vty 0 4

password cisco

login

!

!

end

Can someone tell me what I did wrong?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (5 ratings)
Loading.
bathory0110 Sat, 06/28/2008 - 02:25

R1

int s0/0

frame-relay interface-dlci 101

R3

int s0/0

frame-relay interface-dlci 102

sdoremus33 Sat, 06/28/2008 - 13:10

When you are configuring FR are you adding a Point-to-Point setup, MUlti-Point setup or Physical setup between routers.

Ex rtr1 --> Point-to-Point ---> rtr2

What I mean here is depending on the physical setup you need to take some things into consideration

Step1. If you are using P-to-P, if you do not add inverse arp whcih dynamically asscoiates ip to dlci mapping, then you would need to do the following

Ex:

Int serial0/0

encap frame relay

no arp frame

Int serial0/0.100 Point-to-Point

encap frame-relay

frame-relay interface dlci /* This is how Frame Relay maps IP to DLCI

If you are using Point-to-Multipoint, or a Physical interface Thdne do this

Ex:

int serial0/0

encap frame-relay

no arp frame

int serial0/0.100 multipoint

encap frame-relay ietf

ip address

frame-relay map ip DLCI# broadcast

Rem: it is very important to use the broadcast keyword

or

int serial0/0

encap frame

ip address

frame-relay map ip DLCI# broadcast

In summary

1).For PtoP networks

Use the interface dlci command for Layer2-DLCI to Layer-3 IP

2). For P-to-MP, or Physical networks

Use the Frame-relay map broadcast command.HTH

Hi,

DLCI is needed to be configured on the router for local identification or may be Global identification at Data Link layer. After entering the DLCI user "show frame-relay pvc" and check value should be shown at at least one under local - Active. Also, "show frame-relay map" will show concerned serial interface with DLCI configured on state Active.

I guess this commnad will not help as the DLCI value is already given in command ..

frame-relay map ip 172.16.0.9 102 broadcast

AND

frame-relay map ip 172.16.0.10 101 broadcast

If entering the command does not help. Please get the output of debug frame-relay lmi and enable after enabling ter mon.

Thanks,

-Deepak

sdoremus33 Sat, 06/28/2008 - 17:23

Another thing to look at is the clock rate associated with each DCE end of the serial cable

Ex:

On DCE facing cables

interface serial#

frame-relay intf-type DCE

clock rate 64000

Also look at the following

sh frame-relay map

sh frame-relay route

debug frame-relay packet

Richard Burts Sat, 06/28/2008 - 18:44

Christopher

The suggestion that you need to configure the frame-relay interface-dlci is not correct if you are configuring Frame Relay on the physical interface and if the interface is connected to a frame relay switch. If you were configuring subinterfaces you might need the interface-dlci command. But on the physical interface the DLCI will be announced to your router by the Frame Relay switch (assuming that you are connected to a Frame Relay switch or to a router that is emulating a Frame Relay switch).

I like the direction that Steven is going in wondering how these routers are connected. Perhaps you can clarify your topology and how these routers are connected. Your config looks pretty reasonable if you are connected to a Frame Relay switch. If there is not a Frame Relay switch then several things in the config will need to be added.

There is a fairly simple test that you could do that would help us to understand the issue. Try removing the encapsulation frame-relay from both of the serial interfaces and let them default to HDLC. If the link comes up as an HDLC link then we will know that the problem is related to the Frame Relay part. If the link does not come up then we will know that it is not a problem with Frame Relay but is a problem with basic connectivity.

HTH

Rick

chrisblaze Sat, 06/28/2008 - 19:10
Giuseppe Larosa Sun, 06/29/2008 - 02:07

Hello Chris,

when you connect two routers back to back with their serial interfaces you need to provide the following

OSI L1: the side with the DCE cable (you can check with sh controller serial) has to provide the physical layer clock with the clock rate command in interface mode

OSI L2 FR : one side has to behave as a FR DCE (like a FR switch port) using the interface command

frame-relay intf-type dce

the effect is that the FR DCE side will act as a frame-relay switch port regards LMI and the two sides will agree that the dlci(s) are active.

or you can disable the FR keepalive on both sides and you can get a working link (but this is less educative)

hope to help

Giuseppe

purohit_810 Sat, 06/28/2008 - 20:02

Do you have back to back routers connected? If yes then put clock rate command.

Check keepalive both end.

Thanks,

Dharmesh Purohit

chrisblaze Sat, 06/28/2008 - 20:54

Wont the keep alive command give me a false state? Especially if the line is still down? I will try setting the clock rate.

Richard Burts Mon, 06/30/2008 - 09:59

Christopher

I think that there is a significant clue about the problem in your response that if you remove the encapsulation frame-relay and let the interface default that the interface comes up. That would indicate that the routers are connected to each other and not to a frame relay switch. Can you tell us a bit more about how the routers are connected?

The keepalive command would not give you a false state. If the line is down then keepalives will fail and will show the line as down. Configuring the interface with "no keepalilve" is more likely to give you a false state since no keepalive will show the interface as protocol up whether it can pass traffic or not.

HTH

Rick

Wilson Samuel Mon, 06/30/2008 - 10:44

Hi,

Could you please elaborate the term point-to-point?

Do you mean that they are connected back-to-back i.e. the first router connected to the second router with a cross-cable over the Serial Interface or WIC?

Or you have a telc in between who is your FR privder?

Please help us to understand this situation

Regards,

Wilson Samuel

chrisblaze Mon, 06/30/2008 - 10:54

The routers are directly connected to each other via serial cable. They are not connected to a frame-rely switch.

R3 is the DCE so I have the clockrate set on that in.

When I do the command sh frame-rely map, it states that my status is active but yet my protocol is still down.

R3 S0/0/0:

interface Serial0/0/0

ip address 172.16.0.10 255.255.255.252

encapsulation frame-relay

frame-relay map ip 172.16.0.9 100 broadcast cisco

frame-relay interface-dlci 101

clock rate 64000

R1 s0/0/1:

interface Serial0/0/1

ip address 172.16.0.9 255.255.255.252

encapsulation frame-relay

frame-relay map ip 172.16.0.10 101 broadcast cisco

frame-relay interface-dlci 100

Richard Burts Mon, 06/30/2008 - 11:42

Christopher

If the router are connected back to back then there are 2 things that you must change.

- configure both serial interfaces with "no keepalive". Since the keepalive in Frame Relay is provided by LMI and since there is no LMI without a device operating as a frame relay switch, then you need to configure the interfaces to not use keepalives.

- the DLCI on both interfaces must be the same. They can be DLCI 100 or they can be DLCI 101. But you can not have 100 on one end and 101 on the other end if they are connected back to back with no frame relay switch. Having different DLCIs on the interface works fine if there is a frame relay switch. But with no frame relay switch both interfaces must have the same DLCI.

I am not sure that the frame relay map is correct (the way you have configured it the map on one router is pointing to the DLCI of the other router, but the map should point to the DLCI of the local router). But that is less important than fixing the keepalive and DLCI values. And when both interfaces are using the same DLCI then it will be obvious that both maps should have the same DLCI.

HTH

Rick

chrisblaze Mon, 06/30/2008 - 16:28

Thanks for all the help, the problem was because I had to different DLCIs on the same serial connections, also Rick hit it on the head, when I added the "no keeplive" to both ends along with matching DLCIs, the protocol came up.

Thanks!!!!

Actions

This Discussion