Multicast RPF failure

Unanswered Question
Jun 28th, 2008

Hello all,

I was playing around with multicast and I've run into a situation I would like your comments :)

I have 4 routers connected like this:


-R3 is a static configured RP.

-all interfaces except R1 are running PIM-SM.

From R1, I'm sending a ping to a multicast address using Loopback0 IP as source and sending it out via the interface to R2 (using an extended ping to be sure the exit interface and source addr).

Making no ip mroute-cache and debugging ip mpacket I see that R2 is giving a RPF check error. I've checked R2 with "show ip rpf R1-Lo0" and it shows the correct interface, also correct exit interface in the routing table and CEF.

If I source the multicast ping using the interface (physical) address then everything works fine.

Can someone give me a hint why I can't source it from the loopback? Shouldn't it be possible?



00:06:46: IP(0): s= (FastEthernet0/0) d= id=17, ttl=254, prot=1, len=114(100), not RPF interface

R2#sh ip route

Routing entry for

Known via "ospf 1", distance 110, metric 2, type intra area

Last update from on FastEthernet0/0, 00:15:04 ago

Routing Descriptor Blocks:

*, from, 00:15:04 ago, via FastEthernet0/0

Route metric is 2, traffic share count is 1

R2#sh ip rpf

RPF information for ? (

RPF interface: FastEthernet0/0

RPF neighbor: ? (

RPF route/mask:

RPF type: unicast (ospf 1)

RPF recursion count: 0

Doing distance-preferred lookups across tables

----- now using interface IP (at the moment nobody joined the group)


00:05:18: IP(0): s= (FastEthernet0/0) d= id=5, ttl=254, prot=1, len=114(100), mroute olist null



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Giuseppe Larosa Sun, 06/29/2008 - 05:26


when you use the physical interface source R1 is behaving like a host connected to R2's LAN interface.

When you use the loopback interface you are trying to do something different R1 isn't an host connected to R2 anymore.

In this case if PIM is enabled on R1's interfaces you should see a change because now R1 is a legal PIM neighbor of R2 and your traffic should pass the RPF check.

hope to help


Seifeddine-Tlili Fri, 10/23/2009 - 05:49

Hi Giuseppe,

regarding your explanation i don`t think if that`s the correct answer or not :) since R1 is not the client but the server and R2 now is receiving a source (,MLTIADD) and for him it have to listen to this stream only from the RP since or from a connected source and the loop0 isn`t a connected interface.

Since you are using sparse mode so it will perform and RPF check on the RP ignoring the add and it will see that the interface from where it`s receiving the stream isn`t the one for the RP


This Discussion