eigrp auto-summary

Answered Question
Jun 30th, 2008

i have a 2 routers connected as the attached picture, with the following configuration for R1 and R2,

----------------------------------

R1:

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

ip address 12.1.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address 12.0.0.1 255.255.0.0

duplex auto

speed auto

!

router eigrp 1

network 0.0.0.0

auto-summary

R2:

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Loopback1

ip address 12.2.2.2 255.255.255.0

!

interface FastEthernet0/0

ip address 12.0.0.2 255.255.0.0

duplex auto

speed auto

!

router eigrp 1

network 2.2.2.2 0.0.0.0

network 12.0.0.0 0.0.255.255

network 12.2.2.0 0.0.0.255

auto-summary

-----------------------------------

when I did "show ip route eigrp": I saw some routes been auto-summaried while others not:

---------------

R1#sh ip ro eigrp

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 1.0.0.0/8 is a summary, 00:11:39, Null0

D 2.0.0.0/8 [90/156160] via 12.0.0.2, 00:06:57, FastEthernet0/0

12.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

D 12.2.2.0/24 [90/156160] via 12.0.0.2, 00:06:57, FastEthernet0/0

D 12.0.0.0/8 is a summary, 00:11:39, Null0

R2#sh ip ro eigrp

D 1.0.0.0/8 [90/156160] via 12.0.0.1, 00:07:16, FastEthernet0/0

2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 2.0.0.0/8 is a summary, 00:07:32, Null0

12.0.0.0/8 is variably subnetted, 4 subnets, 3 masks

D 12.1.1.0/24 [90/156160] via 12.0.0.1, 00:07:16, FastEthernet0/0

D 12.0.0.0/8 is a summary, 00:07:18, Null0

my question is: why network 1.1.1.1 & 2.2.2.2 been auto-summarized while 12.1.1.0 and 12.2.2.0 not?

thanks in advance.

Attachment: 
I have this problem too.
0 votes
Correct Answer by mohammedmahmoud about 8 years 5 months ago

Hi Bindong,

Rick has explained it perfectly indeed, the whole point is that the other loopbacks that you are talking about (12.2.2.0/24 and 12.1.1.0/24) are sharing the same Class A with the FastEthernet interface and thats why they are not summarized, which is not the case for the other loopbacks which don't share the same Class A with the FastEthernet interface and thus are summarized.

BR,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Richard Burts Mon, 06/30/2008 - 18:18

bindong

The operation of auto summary in EIGRP is fairly simple and explains your issue. With auto summary enabled EIGRP looks at every interface on which it will send routing updates and for that interface it advertised individual subnets of the network of the interface and for subnets of other networks it automatically summarizes. So the loopback interfaces of 1.1.1.1 and 2.2.2.2 it does not send updates on those interfaces and therefore those subnets are summarized. On the FastEthernet interfaces EIGRP will send updates (and the network on those interfaces is 12.0.0.0) so EIGRP does not summarize 12.0.0.0 but advertises individual subnets.

HTH

Rick

shibindong Mon, 06/30/2008 - 18:22

thanks for reply! can you segment your word"With auto summary enabled EIGRP looks at every interface on which it will send routing updates and for that interface it advertised individual subnets of the network of the interface and for subnets of other networks it automatically summarizes."? It's too long and I read many times to understand it.

Richard Burts Mon, 06/30/2008 - 18:51

bindong

Let me try to explain it in this way: on router 1 there are 3 interfaces (2 loopback interfaces and a FastEthernet). EIGRP does not actually send updates out the loopback interfaces, so summarization is not an issue on them. So focus our attention on the FastEthernet interface. It is a subnet of network 12.0.0.0. So out the FastEthernet interface it will advertise subnets of 12.0.0.0 without summarization. But network 1.1.1.1 is summarized since it is in a different class A network.

Similarly on router 2 the FastEthernet interface is in network 12.0.0.0 so there is no summarization of 12.0.0.0 on that interface. But the loopback 2.2.2.2 is summarized since it is in a separate class A network.

HTH

Rick

HTH

Rick

shibindong Mon, 06/30/2008 - 18:58

rick:

please take a look at my configuration about loopback1 interface on both routers, they are both class A address and I can see exact route (without summarizion) on the routing table, that is the question I am referring to.

thanks again!

bvsnarayana03 Mon, 06/30/2008 - 23:17

Rick has explained it in best possible way. Your 1st question asked "why loopbacks are summarised while interface subnets are not".

Your last question contradicts the 1st one, & i dont see loopbacks as /24 in routing table. They are /8 & are working the way they are expected to, or as explained by rick.

shibindong Mon, 06/30/2008 - 23:21

thanks for your reply, please look at the part of "show ip route eigrp" in the following, you also found it from my pre post.

"D 12.2.2.0/24 [90/156160] via 12.0.0.2, 00:06:57, FastEthernet0/0" from R1 and

"D 12.1.1.0/24 [90/156160]" from R2

they are also loopback interface

Correct Answer
mohammedmahmoud Mon, 06/30/2008 - 23:50

Hi Bindong,

Rick has explained it perfectly indeed, the whole point is that the other loopbacks that you are talking about (12.2.2.0/24 and 12.1.1.0/24) are sharing the same Class A with the FastEthernet interface and thats why they are not summarized, which is not the case for the other loopbacks which don't share the same Class A with the FastEthernet interface and thus are summarized.

BR,

Mohammed Mahmoud.

ruwhite Tue, 07/01/2008 - 05:10

I think the simplest way to say it is: When building an update for a given interface, EIGRP will only send updates with subnets which are within the same major network as the interface itself is in. That's the theory, anyway.... And it's a good way to think about it. But here's an experiment to try.

Set this up:

A--B--C

o A has two interfaces, 10.1.1.0/24 and 172.16.1.0/24. It connects to B on the 172.16 interface, and has autosummary disabled, and has any set of network statements you would like to configure.

o B has two interfaces, 172.16.1.0/24 (towards A) and 172.17.1.0/24 (towards C). B has autosummary enabled, and only has network statements specifically covering the 172.16 and 172.17 ranges (not 0.0.0.0 0.0.0.0).

o C has one interface, 172.17.1.0/24, on which it connects to B.

I think, if the code still works the same way, C will have the more specific 10 route, and changing the network statements on B will change the behavior. It's been a while since I've looked at this code, so it could have changed, but.... The autosummary code relies on the locally configured network statements to do its work, not the locally connected interfaces.

:-)

Russ

mohammedmahmoud Tue, 07/01/2008 - 13:09

Hi Russ,

Always a pleasure having you around :), i've tried your experiment, and however i changed the network statement on B the behavior didn't change, do you confirm that the code logic has changed. To confirm with you my thought in this experiment, router A is the boundary for the 10/8 network and accordingly as long as auto-summary is disabled on router A, the more specific routes of 10/8 will be advertised.

BR,

Mohammed Mahmoud.

ruwhite Tue, 07/01/2008 - 16:05

So, the code has not changed in one respect--B still relies on the network statements configured to determine what to autosummarize. What has changed is B looks at the locally connected interfaces, as well as the network statements. I'm pretty certain it wasn't always this way, but I don't know when it changed.

Thanks for setting this up--I need about ten more sets of hands to get things done, and another set of eyes to look at the code while my first set is doing other things.... :-)

:-)

Russ

Actions

This Discussion