Web Authentication Bundle on a Catalyst 3750 Integrated WLAN Controller

Answered Question

We've implemented a wifi area based on a few 1131AG access points and a couple of Cisco 3750 Integrated WLAN Controllers. We're now trying to use web authentication for our guest area. No problem in defining a GUEST WLAN and the associated VLAN. We've also succeded in dowloading a custom web authentication page on the controller.

However, when I try to display the custom page, both controllers show me the Internal default page (as a preview and during the real authentication phase).

Global web authentication settings are as follows: Security --> Web Auth --> Web Login Page --> Customized (dowloaded).

Software Version on the controller is 4.2.112.0 and the page is an HTML page.

Any help wuold be appreciated.

Regards,

Sonia

I have this problem too.
0 votes
Correct Answer by Scott Fella about 8 years 5 months ago

What you need to do is set it back to internal (default) and hit apply, then set it back to customized and hit apply. You still will see the defaul if you use the preview, but if you associate to the ssid and open your web browser, you should get the webauth page. Hope this helps.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Scott Fella Tue, 07/01/2008 - 18:34

What you need to do is set it back to internal (default) and hit apply, then set it back to customized and hit apply. You still will see the defaul if you use the preview, but if you associate to the ssid and open your web browser, you should get the webauth page. Hope this helps.

Thank you very much; your suggestion solved the issue :-) I suppose that it's a little bug of this software release ...

Just one more question: we observed that at the end of the authentication process the "Web Authentication Successful" page containing the link for the logout procedure is displayed only on Windows Vista PCs, while on XP machines the windows disappears as soon as the user completes the login procedure and is redirected to web site he/she's requested.

It's not an issue for our deployment, but we were wondering what's the reason of this behaviour ...

Thanks again and Regards,

Sonia

Scott Fella Wed, 07/02/2008 - 03:26

I know that IE7 doesn't show the box, maybe due to the pop-up blocker or the tabs. IE6 shows it and so does Firefox. I haven't played with it trying to make it work with IE7, since I kind of like that it doesn't show up.

Actions

This Discussion

 

 

Trending Topics - Security & Network