IPMA Problem - DivAll cannot be disabled

Unanswered Question
Jul 1st, 2008

Hi,


I have an IPMA setup that has had a lot of problems. Currently, there are problems again with disabling/enabling the DivAll function to divert all calls to an assistant.


CallManager version is 4.1.3sr3a, IPMA is configured using proxy line and is running on 2 servers.


Sometimes, all functions well. However, last week there have been a lot of problems (error messages once and a while like "Call Filtering down" and afterwards Call Filtering works fine again, managers disappearing from IPMA Assistant Consoles and reappearing afterwards,...). Today, I restarted IPMA, but without succes. Managers appear correctly now, but Call Filtering is down and stays down now...


I restarted all Tomcat-services, but still no change...


Is there anyone who has experienced the same problem and what was the solution/cause?


Thanks,

Angelique

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
sivakumar.kvp Thu, 07/03/2008 - 21:41

Angelique,

Do you want to disable the Imm.Divert softkey on the IPMA phones.?If so,you need to edit the softkey template on the device settings option.Call control must be up always,if not just restart your services and ensure that you have given the CCM IP address in IPMA service under enterprise service option.


Thanks

Siva

angelique.devos Fri, 07/04/2008 - 02:50

Siva,


Softkey is obviously present, with disable I mean we cannot deactivate it. If we push the softkey, it doesn't do anything. If we do the same thing on the IPMA Assistant Console, we get "Failed to set DivAll".


Already opened a TAC case and hoping they provide a solution soon.


Angelique

anatsira Fri, 07/10/2009 - 08:24

Hello,


Did you find the reason why you got error message "Failed to set DivAll" when you tried to enable/disable DivAll (or Filter) from the IPMA Assistant Console?


Thanks

angelique.devos Mon, 07/13/2009 - 00:39

Hi,


IPMA was failing.


It was a CCM 4.1.3 environment with IPMA and Mobile Managers.

In that case, the Extension Mobility service needs to be enabled on all IPMA servers.


Best regards,

Angelique

anatsira Mon, 07/13/2009 - 04:27

hi,


was it a bug?

if yes, could you give me the bug id please?


Thanks

angelique.devos Mon, 07/13/2009 - 04:33

Hi,


No it was not, it was "works as designed".


Here the notes from the Cisco TAC engineer:

"Design consideration:

================

Two design considerations we should have in place are IPMA/EM should be running on the same node for IPMA Divert All to function properly.Note one thing that complicates here is that IPMA user actually has EM profile here. Hence conditions complicate with IPMA/EM service restarts, threads and DB dependencies.

Failover conditions for EM App/Service and IPMA/EM Divert all and Pub DB overload needs to be looked into in details. We could not find an 4.x SRND which documents above. However including URL which similar flavour discussions:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/apps.html#wp1043​795​

Hope this answers all your questions."


I hope this can solve your issue!


Best regards,

Angelique

Actions

This Discussion