Cisco 2511-RJ configuration help needed please!

Unanswered Question
Jul 1st, 2008
User Badges:

Hi,


I have a Cisco 2511-RJ with 16 async RJ-45 built in ports. I can't seem to get the thing to work.


I want to connect the rj-45 ports to the console ports of Cisco 6500 sup2s and sup720 routers.


A) what type of cable is needed? Roll over? or Straight Through? or Crossover?


B) My configuration below: I've tried multiple cables, configurations etc, with no luck. Please let me know if I'm missing something.


Thanks,


termserver#sh run

Building configuration...


Current configuration : 1027 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname termserver

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxx

!

no aaa new-model

ip subnet-zero

no ip domain lookup

ip host r1 2001 10.10.100.1

ip host r2 2002 10.10.100.1

ip host r3 2003 10.10.100.1

ip host r4 2016 10.10.100.1

!

!

!

!

interface Loopback0

ip address 10.10.100.1 255.255.255.0

!

interface Ethernet0

ip address 10.5.5.2 255.255.255.128

no ip mroute-cache

!

interface Serial0

no ip address

shutdown

!

ip default-gateway 10.5.5.1

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.5.5.1

!

!

!

!

line con 0

line 1 16

session-timeout 20

exec-timeout 0 0

transport preferred telnet

transport input all

transport output none

line aux 0

transport preferred telnet

transport input all

speed 38400

flowcontrol hardware

line vty 0 4

exec-timeout 0 0

password xxx

login

transport input all

!

end



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gskhanna Tue, 07/01/2008 - 20:45
User Badges:

More information:


termserver# sh line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

0 CTY - - - - - 0 1 0/0 -

1 TTY 9600/9600 - - - - - 4 0 0/0 -

2 TTY 9600/9600 - - - - - 7 0 0/0 -

3 TTY 9600/9600 - - - - - 4 0 0/0 -

4 TTY 9600/9600 - - - - - 0 0 0/0 -

5 TTY 9600/9600 - - - - - 0 0 0/0 -

6 TTY 9600/9600 - - - - - 0 0 0/0 -

7 TTY 9600/9600 - - - - - 0 0 0/0 -

8 TTY 9600/9600 - - - - - 0 0 0/0 -

9 TTY 9600/9600 - - - - - 0 0 0/0 -

10 TTY 9600/9600 - - - - - 0 0 0/0 -

11 TTY 9600/9600 - - - - - 0 0 0/0 -

12 TTY 9600/9600 - - - - - 0 0 0/0 -

13 TTY 9600/9600 - - - - - 0 0 0/0 -

14 TTY 9600/9600 - - - - - 0 0 0/0 -

15 TTY 9600/9600 - - - - - 0 0 0/0 -

16 TTY 9600/9600 - - - - - 1 0 0/0 -

17 AUX 38400/38400 - - - - - 0 0 0/0 -

* 18 VTY - - - - - 11 0 0/0 -

* 19 VTY - - - - - 17 0 0/0 -

20 VTY - - - - - 8 0 0/0 -

21 VTY - - - - - 4 0 0/0 -

22 VTY - - - - - 0 0 0/0 -




Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-IS-L), Version 12.3(13a), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Tue 26-Apr-05 12:52 by ssearch

Image text-base: 0x0307D3B0, data-base: 0x00001000


ROM: System Bootstrap, Version 11.0(10c)XB1, PLATFORM SPECIFIC RELEASE SOFTWARE (fc1)

BOOTLDR: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c)XB1, PLATFORM SPECIFIC RELEASE SOFTWARE (fc1)


termserver uptime is 4 weeks, 7 hours, 52 minutes

System returned to ROM by power-on

System image file is "flash:c2500-is-l.123-13a.bin"


cisco AS2511-RJ (68030) processor (revision I) with 14336K/2048K bytes of memory.

Processor board ID 09295958, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

16 terminal line(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read ONLY)


Configuration register is 0x2102




when reverse telneting to the point either closes the session right away, or just sits there.


I tried the

int async 1

async dedicated command but to no avail also.


I've never used the 2511-rj version before.


Thanks for any help.


scottmac Tue, 07/01/2008 - 20:55
User Badges:
  • Green, 3000 points or more

The cables from the 2511 can plug directly into the RJ console ports of Cisco equipment.


For devices that have 25 Pin or 9 pin RS232, the adapter headshells are properly pinned and should work with any changes.


You can extend the length to "reasonable" distances with straight-through UTP (like plug it into a panel and using structured cabling infrastructure to get to the console port).

Make sure you have the 'Transport Input' (i.e., Transport Input Telnet) command to set the type of traffic you expect to see (and want to accept) for the port.


You also want to make sure the flow control parameters are properly set (generally disabled / off / inactive).


Good Luck

Scott

gskhanna Tue, 07/01/2008 - 21:03
User Badges:

I'll give it a shot tomarrow. 1 thing to note, that this is a 2511-RJ and as such their are only RJ-45 ports physically on the device, and no 'cables' such as the octal cable that is normally with a 2511.


I'll check with the transport settings to see if it helps.


Richard Burts Wed, 07/02/2008 - 08:09
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

GURPREET


I would suggest that you add this to the configuration of the lines used for reverse telnet:

no exec


Give it a try and tell us if it hellps.


HTH


Rick

jmohlmaster Fri, 07/04/2008 - 14:39
User Badges:

You will need to use standard rollover cables to go from the 2511-RJ to the supervisors, just as you would on a PC with a null-modem adapter.


HTH


Jarod

Actions

This Discussion