Local PRI's full - LD rollover not working....

Unanswered Question
Jul 2nd, 2008

Hi Everyone,

Got a problem - we exhausted both of our local PRI's this morning. Our configuration is setup so that new calls (when the local PRI's are full) will roll over to the LD PRI.

What we found this morning was that when this scenario presents itself, the new rollover calls can't successfully be made. It appears that since we dialed a local number w/o an area code we could not complete the call, but when the PRI's were full and we dialed a local number w/ the area code calls were successful!

Need some quick help on this. How can we resolve this one? We run CM 4.1.

Thank you!

scott

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
thisisshanky Wed, 07/02/2008 - 07:30

This can be a little tricky if you want to get this fully automated and transparent to the user. So normally does users dial only 7 digits for local calls ? Over the LD PRi the telco is expecting full 10 digits for the way they have provisioned the trunk.

I assume there is only local area code ? In that case you can do the following.

9.[2-9]XXXXXX is the router pattern pointing to Route list RL1

RL1 has two route groups.

RG1 - Points to local pri

RG2 - points to ld pri.

Under RG2 settings (you would do this at the RL1 configuration page), go ahead and set the prefix called number settings to say for example 972 if that is the area code. Discard digits can be set to predot in case you are using MGCP gateway.

Under RG1 there should not be any prefixing. Just Predot discard digits should be fine (assuming your gateway uses MGCP)

When RG1 is busy/fully loaded, RL1 will route calls through RG2 and then automatically prefix 972 area code to the 7 digits that users dial. This will be transparent to the end user.

HTH

Sankar.

scottlivingston Wed, 07/02/2008 - 07:45

Sankar, that's exactly what we were looking for! I'll take a look at that!

We haven't manipulated anything yet. We have a debug that shows us what happened. You can see that the “Called Party Number” doesn't have an area code in front. The call has rolled over to our LD PRI Se0/0/1:23 as a result of the local PRI's being full. You can also see the error - “Invalid number format (incomplete number)”

Calling Party Number i = 0x0081, '913XXX3128'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '3081221'

Plan:Unknown, Type:Unknown

Jul 2 09:55:41.426: ISDN Se0/0/1:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x8 B22

Channel ID i = 0xA9838F

Exclusive, Channel 15

Jul 2 09:55:41.430: ISDN Se0/0/1:23 Q931: RX <- PROGRESS pd = 8 callref = 0x8B 22

Cause i = 0x819C - Invalid number format (incomplete number)

Progress Ind i = 0x8188 - In-band info or appropriate now available

Jul 2 09:55:41.430: ISDN Se0/0/1:23 Q931: RX <- PROGRESS pd = 8 callref = 0x8B 22

Cause i = 0x819C - Invalid number format (incomplete number)

Thank you,

scott

thisisshanky Wed, 07/02/2008 - 08:07

Scott, that sounds like the exact problem i described in my post. Try the prefix on RG2 and see if it works.

scottlivingston Wed, 07/02/2008 - 08:21

So, our local is setup as you mentioned. What do I need to do to this LD one? Can you type it out for me so I understand? Sorry - I'm more of an R/S guy.

Our local area code is 913

9.[2-9]XXXXXX <--Current Local

9.1[2-9]XX[2-9]XXXXXX <--Current LD

thank you,

scott

thisisshanky Wed, 07/02/2008 - 08:46

You dont need to modify any thing on the LD patterns. 9.[2-9]XXXXXX pattern points to a Route list. In this route list you have two route groups. One is for local trunk and one is for LD trunk. You will need to prefix 913 area code on to the route group that has the LD trunk.

Makes sense ?

scottlivingston Wed, 07/02/2008 - 08:57

I see. So under the LD-RG I have a section named “Calling Party Transformations” and in that section there is an option called “Calling Party Transform Mask” and it is set to 913667XXXX.

On that same page there is another section named “Called Party Transformations” and it has a few options to….. Dial Plan, Discard Digits, Called Party Transform Mask, Prefix Digits (Outgoing Calls).

So I wan to do something inside that “Called Party Transformations” correct? And what exactly do I need to do?

I think you have me almost there! :)

THANK YOU!

scott

scottlivingston Wed, 07/02/2008 - 09:04

Oh, but you told me to do this under the Local list not the LD. So under “Called Party Transformations” I need to put something in the box for "Prefix Digits (Outgoing Calls)" correct?

thank you,

scott

thisisshanky Wed, 07/02/2008 - 09:16

i assume you have the following.

Local RG

LD RG

and two route lists...

Local-RL with

a. Local RG at top

b. LD RG at the bottom.

LD-RL with

a. LD-RG at the top

b. Local RG at the bottom

The change i asked you to make should be done under Local-RL-> LD-RG. You would go to the called party transformations and set the prefix digits to 913. Discard digits to predot.

scottlivingston Wed, 07/02/2008 - 09:42

You have made the correct assumption - you are awesome!

So now I know where to put the digits. I'm sure I'm the only one in this VOIP forum that doesn't know what you mean by, "Discard digits to predot" so I'll do some readying. :) Unless you want to tell me exactly what I should put in that box - it will make my reading make more sense I'm sure.

Thank you much!!!

scott

thisisshanky Wed, 07/02/2008 - 09:46

Predot is not always required. If you have a pattern 9.[2-9]XXXXXX and when you send the digits to the gateway you dont want to send the 9 as its not reqd to send it to the telco. So that why you have a dot in the pattern so that you can tell at route pattern or route list level whether you want to discard all digits before the dot or not. So if you have an mgcp gateway you simply need to set the discard digits to predot so that the leading 9 (trunk access code) is rejected before sent to the voice gateway.

scottlivingston Wed, 07/02/2008 - 10:07

Thank you for that explanation - in that context I did actually know what predot means believe it or not. :) But in my scenario I have no idea what to put in that box. What would the string look like since I want 913 area code in there?

9.913[2-9]XXXXXX <--is this what I want to do?

Yes, it's an mgcp gateway.

Sorry man, our primary VOIP guy is out of town.

thank you,

scott

thisisshanky Wed, 07/02/2008 - 14:08

YOur pattern should still be

9.[2-9]XXXXXX - no changes there

the route list should be where you will set Discard digits to Predot and prefix digits under called party transformations to 913.

scottlivingston Tue, 07/08/2008 - 12:02

I told everyone I'd letchya know the solution when we were done.

As already stated, we have two RG's under the Local-RL - a Local RG and a LD RG. We created a new RG just for rollover in the event we exhaust all our PRI's.

What it was

--------------

Local-RL with

Local RG at top

LD RG at the bottom

What it is now

------------------

Local-RL with

Local RG at top

LD Rollover RG at the bottom

If I had done it as suggested (I was told by another engineer and Cisco TAC - did not test this out) in this forum, ALL my LD calls would have been tagged w/ a 913 area code.

Things work great now - yes it has been tested.

Thx again everyone!

scott

Actions

This Discussion