WAAS and WCCP Traffic Redirection: No optimzation taking place

Unanswered Question
Jul 2nd, 2008

Hi,

Anyone tried to do traffic redirection with WCCP successfully?

I am do a demo using WCCP and I cant get to redirect the traffic propoerly to the WAE devices.

I can see connection forming under "Connection Summary" but no proper optimization seems to take place. My WCCP setting is as follows;

Core WAE at HQ

- LAN interface: 62-in

- WAN interface: 61-in

Edge WAE at branch

- LAN interface: 61-in

- WAN interface: 62-in

WAAS version 4.0.13.

All connections (http, etc) seem to be TFO optimized only whereas I have enabled LZ & DRE.

Regards,

Edward W.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dstolt Wed, 07/02/2008 - 10:32

Edward,

I would go into the AllDeviceGroup and verify that you have applied the Application Policies there (I usually start by applying the defaults and then adding policies as needed). Ensure the settings get forced down to all the WAEs.

Hope that helps,

Dan

Gregory Scarlett Wed, 07/02/2008 - 22:21

Hi Edward,

It seems you have the redirection around the wrong way at the Core side. It should be '62 in' on the WAN side always.

As mentioned as well, make sure the default policies are applied via the AllDevicesGroup.

Regards,

Greg Scarlett

APAC TAC Engineer

edwardwaithaka Thu, 07/03/2008 - 01:07

Hi,

Seems the remote Edge WAE can't contact the CM. I get the following error when I try to re-register the edge wae with the CM.

Failed to contact CM(Unmarshaled: 9001)

I can ping the CM from the edge. I have ensured no access-lists are blocking the traffic.

Strange thing is that the edge could previously see the CM.

edwardwaithaka Thu, 07/03/2008 - 03:05

Seems the edge wae loses connectivity with the CM even though it is ping-able. Is this a bug with WCCP?

The CM shows the edge status as "offline". I have reinstalled all devices but the edge goes offline after a while.

Any pointers??

dstolt Thu, 07/03/2008 - 05:09

Is you WAE is sitting on a dedicated network that is not getting intercepted by WCCP? You have two options for the edges:

1. It should be either hanging off the router on a dedicated interface or a subinterface that WCCP isn't applied to.

2. Use wccp negotiated return (GRE Egress) so that the return traffic isn't re-intercepted by WCCP on the router. This option allows you to put your WAE on the client interfaces.

Dan

dstolt Thu, 07/03/2008 - 05:18

I would leave your core wccp settings as is. 61 on the WAN and 62 on the LAN gives you client IP based load balancing. With a single core WAE, it doesn't matter, but with multiple WAEs, it's better to have similar traffic from a single edge site be directed to one of the cores rather then distributed across all of them.

Dan

Actions

This Discussion