PPP Multilink Issue on 7206

Answered Question
Jul 2nd, 2008
User Badges:

We have 6 new T1's coming in on a T1 card on a 7206. We are having a problem with PPP multilink on this card. Here is the configuration for the multilink and each of the T1s:


interface Multilink1

ip address 10.105.255.174 255.255.255.252

ppp multilink

multilink-group 1


interface Serial1/0:0

bandwidth 1536

no ip address

ip load-sharing per-packet

encapsulation ppp

fair-queue

ppp multilink

multilink-group 1

!


Here is the ppp debugs out of the log:


00:14:17: Se1/0:0 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]

00:14:17: Se1/0:0 LCP: State is Listen

00:14:17: Se1/0:0 LCP: I CONFREQ [Listen] id 199 len 23

00:14:17: Se1/0:0 LCP: MagicNumber 0x8526341E (0x05068526341E)

00:14:17: Se1/0:0 LCP: MRRU 1500 (0x110405DC)

00:14:17: Se1/0:0 LCP: EndpointDisc 1 Core-1 (0x130901436F72652D31)

00:14:17: Se1/0:0 LCP: O CONFREQ [Listen] id 111 len 22

00:14:17: Se1/0:0 LCP: MagicNumber 0x90BF199B (0x050690BF199B)

00:14:17: Se1/0:0 LCP: MRRU 1524 (0x110405F4)

00:14:17: Se1/0:0 LCP: EndpointDisc 1 ABRHQ (0x1308014142524851)

00:14:17: Se1/0:0 LCP: O CONFACK [Listen] id 199 len 23

00:14:17: Se1/0:0 LCP: MagicNumber 0x8526341E (0x05068526341E)

00:14:17: Se1/0:0 LCP: MRRU 1500 (0x110405DC)

00:14:17: Se1/0:0 LCP: EndpointDisc 1 Core-1 (0x130901436F72652D31)

00:14:17: Se1/0:0 LCP: I CONFACK [ACKsent] id 111 len 22

00:14:17: Se1/0:0 LCP: MagicNumber 0x90BF199B (0x050690BF199B)

00:14:17: Se1/0:0 LCP: MRRU 1524 (0x110405F4)

00:14:17: Se1/0:0 LCP: EndpointDisc 1 ABRHQ (0x1308014142524851)

00:14:17: Se1/0:0 LCP: State is Open

00:14:17: Se1/0:0 MLP: Request add link to bundle

00:14:17: Se1/0:0 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

00:14:17: Se1/0:0 MLP: Adding link to bundle

00:14:17: Mu1 MLP: Added first link Se1/0:0 to bundle Core-1

00:14:17: Se1/0:0 LCP: I TERMREQ [Open] id 200 len 4

00:14:17: Mu1 MLP: No previous member for idle link in 'Core-1'

00:14:17: Se1/0:0 LCP: O TERMACK [Open] id 200 len 4

00:14:17: Se1/0:0 MLP: Request drop link from bundle Mu1

00:14:17: Se1/0:0 PPP: Phase is TERMINATING [0 sess, 1 load]

00:14:17: Mu1 MLP: Removing link Se1/0:0 from bundle Core-1

00:14:17: Mu1 MLP: Dropped link Se1/0:0 from bundle Core-1

00:14:17: Mu1 MLP: Dropped last link, removing bundle Core-1

00:14:17: Mu1 MLP: Removing bundle 'Core-1'

00:14:17: Mu1 LCP: State is Closed

00:14:17: Se1/1:0 LCP: TIMEout: State TERMsent

00:14:17: Se1/1:0 LCP: State is Closed

00:14:17: Se1/1:0 PPP: Phase is DOWN [0 sess, 1 load]


When setting up the link as an HDLC link or even PPP without multilink, the connection is fine. Only when the link is changed to a multilink do we see this. The multilink will bounce (coming up for less than a second then going back down.) We see the interfaces in the multilink as up/down.


Any recommendations?


Greg

Correct Answer by paolo bevilacqua about 8 years 10 months ago

Hi, since the termination request is received by the router you sent debug and config, I think the same info would be needed about the other router.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Wed, 07/02/2008 - 13:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Greg


I am curious about what appears to be 2 names for multilink that show up in the output that you posted:

00:14:17: Se1/0:0 MLP: Request add link to bundle

00:14:17: Se1/0:0 PPP: Phase is VIRTUALIZED [0 sess, 1 load]

00:14:17: Se1/0:0 MLP: Adding link to bundle

00:14:17: Mu1 MLP: Added first link Se1/0:0 to bundle Core-1

00:14:17: Se1/0:0 LCP: I TERMREQ [Open] id 200 len 4

00:14:17: Mu1 MLP: No previous member for idle link in 'Core-1'

00:14:17: Se1/0:0 LCP: O TERMACK [Open] id 200 len 4

00:14:17: Se1/0:0 MLP: Request drop link from bundle Mu1


Perhaps a more full view of the router config might shed a bit more light on the issue.


HTH


Rick

gregwoodson Wed, 07/02/2008 - 13:17
User Badges:

Building configuration...


Current configuration : 4276 bytes

!

! Last configuration change at 09:12:55 CST Wed Jun 25 2008

! NVRAM config last updated at 09:16:04 CST Wed Jun 25 2008

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

clock timezone CST -6

ip subnet-zero

no ip source-route

ip flow-cache timeout active 1

ip cef

!

!

!

no mpls traffic-eng auto-bw timers frequency 0

call rsvp-sync

!

!

!

!

!

!

controller T1 1/0

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/1

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/2

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/3

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/4

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/5

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/6

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

controller T1 1/7

framing esf

clock source internal

linecode b8zs

channel-group 0 timeslots 1-24

!

!

class-map match-all video1

match access-group 102

class-map match-all voice1

match access-group 101

!

!

policy-map video-police

class voice1

bandwidth 384

class video1

bandwidth 384

class class-default

fair-queue 64

queue-limit 20

!

!

!

interface Loopback0

ip address 10.253.0.65 255.255.255.255

no clns route-cache

!

interface Multilink1

description 3MB to Colo4Dallas

ip address 10.105.255.174 255.255.255.252

ip flow ingress

ip nbar protocol-discovery

service-policy output video-police

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/0:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/1:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/2:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/3:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/4:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/5:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/6:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface Serial1/7:0

bandwidth 1536

no ip address

ip flow ingress

encapsulation ppp

ppp multilink

multilink-group 1

no clns route-cache

!

interface FastEthernet2/0

bandwidth 100000

ip address 10.105.50.1 255.255.255.0

ip flow ingress

no ip route-cache cef

no ip route-cache

shutdown

duplex full

no clns route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.105.255.173

ip route 10.253.0.2 255.255.255.255 10.105.255.173

ip flow-export source FastEthernet2/0

ip flow-export version 5

ip flow-export destination 10.50.66.218 9996

!

ip http server

!

!

!

logging trap debugging

logging 10.50.66.218

access-list 101 permit ip any any precedence critical

access-list 102 permit ip any any precedence flash-override

!

snmp-server community publ1c RW

snmp-server community public RO

snmp-server enable traps tty

snmp-server enable traps sonet

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

!

end




I took a couple things out- but this is the config.

Correct Answer
paolo bevilacqua Wed, 07/02/2008 - 15:13
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, since the termination request is received by the router you sent debug and config, I think the same info would be needed about the other router.

Actions

This Discussion