ISDN back up...please check

Answered Question
Jul 3rd, 2008
User Badges:

We have an ISDN link between 2 locations.

but when we tried to ping doesn't go thru

with each other...

Can please someone check if there7s a problem on the config??

We're not sure yet if it will work or not

if it happens that the main line is down.


Here's the config.i hope this is enough


***Site A****

interface BRI0/0

description ISDN_Call back_server

ip address 192.168.121.245 255.255.255.252

ip access-group 140 out

encapsulation ppp

load-interval 30

dialer idle-timeout 0

dialer map ip 192.168.121.246 name p***** class dial1 *********46756098

dialer hold-queue 100

dialer load-threshold 3 outbound

dialer callback-secure

isdn switch-type ***

no keepalive

no cdp enable

ppp callback accept



***Site B***


interface BRI0/3/0

description Backup_From _B

ip address 192.168.121.246 255.255.255.252

ip access-group 130 out

encapsulation ppp

load-interval 30

dialer idle-timeout 30 either

dialer map ip 192.168.121.245 name p***** *******163506

dialer hold-queue 100

dialer load-threshold 1 outbound

dialer-group 1

isdn switch-type basic-net3

isdn fast-rollover-delay 5

no keepalive

no fair-queue

no cdp enable

ppp callback request

ppp authentication chap

ppp multilink


Thanks

Correct Answer by Richard Burts about 8 years 8 months ago

Jayson


I thought that I had already explained it. But let me try it again in a slightly different way. The router will only activate the ISDN when a packet matches the dialer list (which uses an access list to identify the traffic). Since there is no permit in the access list for a packet whose source address is the BRI, then a ping from the BRI to the other BRI does not match and the BRI will not activate. If you want to be able to test by ping from BRI to BRI then you need to add a statement in the access list to permit that host to host traffic.


HTH


Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Richard Burts Thu, 07/03/2008 - 07:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


It would be helpful if we had more of the router config. The title of the post indicates ISDN back up and it would be helpful to know if the ISDN is configured as a backup interface for some primary interface or is configured with dialer watch for its activation, or is configured with floating static routes for its activation. If you provide more config detail we might understand the problem better and be able to give you a better suggestion.


If the ISDN is configured as a backup-interface for some primary interface then this may be normal behavior. The backup interface will be in standby state and will not make a call or answer a call unless there is a failure on the primary interface (and an interface shutdown will not start the backup interface). The output of show isdn status would help us see whether this is the issue or not.


I do see a couple of things in the config to comment about. I see ppp authentication chap on Site B but no ppp authentication on Site A. I believe that both sites need ppp authentication.


I see that Site B has ppp multilink but I do not see multilink on Site A. I believe that there should be consistency between the sites about this.


I see that Site B is configured with a dialer-group but that Site A is not. Dialer-group is essential to initiating a call. On that basis I have seen some people configured dialer-group on the router to initiate the call and not configure dialer-group on a router that they want to be an "answer only" (not initiate). But dialer-group is also important in resetting the inactivity timeout and avoiding dropping calls before it should. If a router does not have dialer-group it will never reset the inactivity timer and when that timer expires it will drop the call. A much better way to make a router be answer only is to not put a phone number into its dialer map.


The callback functionality can be difficult. If you remove the callback parts of the config on both sites (temporarily for testing purposes), does the router then be able to place the call?


HTH


Rick

jsheriony Thu, 07/03/2008 - 08:00
User Badges:

Hi Rick...

Thank you very much for the attention.

I have the config for both sides.


*******Site A******

class-map match-all Data

match ip precedence 2

class-map match-all Voice

match ip precedence 5

class-map match-all Maintenance

match ip precedence 6

!

!

policy-map LLQ24ch

class Voice

priority 624

class Data

bandwidth 832

class Maintenance

bandwidth 48

class class-default

bandwidth 200

random-detect

policy-map FE_Precedence

class class-default

shape average 4000000

service-policy LLQ24ch

!

!

!

!

interface Loopback0

description For_voice_session_target_********

ip address 192.168.121.241 255.255.255.255

!

interface FastEthernet0/0

description to LAN

ip address 192.168.120.252 255.255.255.0

ip policy route-map Precedence

duplex auto

speed auto

no cdp enable

!

interface BRI0/0

description ISDN_Call back_server

ip address 192.168.121.245 255.255.255.252

ip access-group 140 out

encapsulation ppp

load-interval 30

dialer idle-timeout 0

dialer map ip 192.168.121.246 name SiteB class dial1 *********446756098

dialer hold-queue 100

dialer load-threshold 3 outbound

dialer callback-secure

isdn switch-type ntt

no keepalive

no cdp enable

ppp callback accept

!

interface FastEthernet0/1

description to WAN

bandwidth 4000

ip address 192.168.121.1 255.255.255.252

speed 100

full-duplex

no cdp enable

service-policy output FE_Precedence

!

router bgp 65000

no synchronization

no bgp log-neighbor-changes

network 6.0.0.0 mask 255.255.254.0

network 10.0.0.0

network 30.0.0.0 mask 255.255.224.0

network 172.16.0.0 mask 255.252.0.0

network 172.28.0.0

network 172.30.0.0 mask 255.254.0.0

network 192.168.0.0 mask 255.255.224.0

network 192.168.52.0 mask 255.255.252.0

network 192.168.56.0 mask 255.255.252.0

network 192.168.80.0

network 192.168.120.0

network 192.168.121.17 mask 255.255.255.255

network 192.168.128.0 mask 255.255.128.0

network 198.179.161.0

neighbor 192.168.121.2 remote-as 11158

neighbor 192.168.121.2 soft-reconfiguration inbound

no auto-summary

!

ip local policy route-map Precedence

no ip http server

ip classless

ip route 6.0.0.0 255.255.254.0 192.168.120.254

ip route 10.0.0.0 255.0.0.0 192.168.120.254

ip route 30.0.0.0 255.255.224.0 192

ip route 192.168.0.0 255.255.224.0 192.168.120.254

ip route 192.168.52.0 255.255.252.0 192.168.120.254

ip route 192.168.56.0 255.255.252.0 192.168.120.254

ip route 192.168.60.0 255.255.255.0 192.168.121.246 200 name SiteB_Backup

ip route 192.168.121.253 255.255.255.255 192.168.121.2 name maintenance_router

ip route 192.168.128.0 255.255.128.0 192.168.120.254

ip route 198.179.161.0 255.255.255.0 192.168.120.254

!

!

!

map-class dialer dial1

dialer callback-server username

access-list 1 permit 192.168.121.0 0.0.0.255

access-list 100 permit tcp any any eq 1720

access-list 100 permit tcp any eq 1720 any

access-list 110 permit ip host 172

access-list 120 permit tcp any any eq bgp

access-list 120 permit tcp any eq bgp any

access-list 130 permit ip any any

access-list 140 permit ip 192.168.52.0 0.0.0.255 192.168.60.

access-list 140 permit ip 192.168.52.0 0.0.0.255 host 192.

access-list 140 permit ip 192.168.52.0 0.0.0.255 host 192.1

access-list 140 permit ip 192.168.56.0 0.0.0.255 192.168.60.6

access-list 140 permit ip 192.168.56.0 0.0.0.255 host 192.1

access-list 140 permit ip 192.168.56.0 0.0.0.255 host 192.

access-list 140 permit ip host 192.168.121.245 host 192.168

no cdp run

!

route-map Precedence permit 100

match ip address 100

set ip precedence critical

!

route-map Precedence permit 110

match ip address 110

set ip precedence immediate

!

route-map Precedence permit 120

match ip address 120

set ip precedence internet

!

route-map Precedence permit 130

match ip address 130

set ip precedence routine

jsheriony Thu, 07/03/2008 - 08:01
User Badges:

****SiteB****


policy-map LLQ4ch

class Voice

priority 104

class Maintenance

bandwidth 16

class class-default

fair-queue

random-detect

!

!

!

!

interface FastEthernet0/0

description to LAN

ip address 192.168.60.254 255.255.255.0

ip policy route-map Precedence

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/2/0

description to WAN

bandwidth 1024

ip address 192.168.121.49 255.255.255.252

service-policy output LLQ4ch

encapsulation ppp

no cdp enable

!

interface BRI0/3/0

description Backup_From _SiteB

ip address 192.168.121.246 255.255.255.252

ip access-group 130 out

encapsulation ppp

load-interval 30

dialer idle-timeout 30 either

dialer map ip 192.168.121.245 name **** *******163506

dialer hold-queue 100

dialer load-threshold 1 outbound

dialer-group 1

isdn switch-type basic-net3

isdn fast-rollover-delay 5

no keepalive

no fair-queue

no cdp enable

ppp callback request

ppp authentication chap

ppp multilink

!

router bgp 65000

no synchronization

no bgp log-neighbor-changes

network 192.168.60.0

neighbor 192.168.121.50 remote-as 11158

neighbor 192.168.121.50 soft-reconfiguration inbound

no auto-summary

!

ip local policy route-map Precedence

ip classless

ip route 192.168.52.0 255.255.252.0 192.168.121.245 200 name LAN_BackUp1

ip route 192.168.56.0 255.255.252.0 192.168.121.245 200 name LAN_BackUp2

!

no ip http server

no ip http secure-server

!

!

access-list 1 permit 192.168.121.0 0.0.0.255

access-list 100 permit tcp any any eq 1720

access-list 100 permit tcp any eq 1720 any


access-list 110 permit tcp any any eq bgp

access-list 110 permit tcp any eq bgp any

access-list 120 permit ip 192.168.60.64 0.0.0.3 192.168.52.0 0.0.0.255

access-list 130 permit ip 192.168.60.64 0.0.0.3 192.168.52.0 0.0.0.255

access-list 130 permit ip 192.168.60.64 0.0.0.3 192.168.56.0 0.0.0.255

access-list 130 permit ip host 192.168.60.70 192.168.52.0 0.0.0.255

access-list 130 permit ip host 192.168.60.70 192.168.56.0 0.0.0.255

access-list 130 permit ip host 192.168.60.224 192.168.52.0 0.0.0.255

access-list 130 permit ip host 192.168.60.224 192.168.56.0 0.0.0.255

access-list 130 permit ip host 192.168.121.246 host 192.168.121.245

access-list 199 permit ip any any

dialer-list 1 protocol ip list 120

snmp-server community ****** RO

snmp-server enable traps tty

no cdp run

route-map Precedence permit 100

match ip address 100

set ip precedence critical

!

route-map Precedence permit 110

match ip address 110

set ip precedence internet

!

route-map Precedence permit 199

match ip address 199

set ip precedence routine

Richard Burts Thu, 07/03/2008 - 08:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


Thanks for the additional information. I believe that it is helpful in better understanding what is going on in your situation. Here are some of the things that I see in it:

- I do not see any configuration of backup-interface so my question about possibly being in standby state is not the issue.

- Site A does have a floating static route for the LAN subnet of B pointing to the ISDN so if the primary route for the LAN at B (which I assume would be learned via BGP) is removed then A will use ISDN to try to get to B. It looks like this should work ok.

- As I mentioned before Site A does not have a dialer group configured so it is not able to initiate a connection to B. It can only answer when B attempts to initiate a connection. If this is what was intended, then this is not a problem - other than the fact that it will not reset the inactivity timer.

- There are several things in the config at B that puzzle me. There are 2 floating static routes on B which point to the ISDN to A. But neither of them is for the subnet at A. I am not clear why you are routing 192.168.52.0 and 192.168.56.0 to A but not routing the subnet at A.

- I believe that the dialer list at B is a problem. This is what allows B to initiate a call over the ISDN. The dialer list only allows 4 IP addresses as the source address (192.168.60.64, .65, .66, and .67) and only allows it to destinations in 192.168.52.0. If your attempt to test by using ping was sourced from one of the four addresses and if the destination of the ping was in 192.168.52.0 then it looks to me like the ISDN should have worked. And if the ping was not from that source and to that destination then the dialer list is the reason that ISDN did not work.


You know this environment and we do not. Perhaps it makes sense to you but to me it looks like a problem.


HTH


Rick

jsheriony Thu, 07/03/2008 - 08:44
User Badges:

Hi Rick


Thank you for the attention.

I understand the dialgroup...if no packets from the host in the dialgroup, then the back will remain down...that's when the main link goes down.


What we're trying to initiate is to check if the back up works ok...and we tried it by ping test.

from site B, source will be the ip add of

site B's BRI port and destination is the Bri port of Site A.

The problem is the ping won't go thru..

That's what's questioning me...


what do you think???


Thank you very much


i really appreciate it...

Correct Answer
Richard Burts Thu, 07/03/2008 - 09:05
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


I thought that I had already explained it. But let me try it again in a slightly different way. The router will only activate the ISDN when a packet matches the dialer list (which uses an access list to identify the traffic). Since there is no permit in the access list for a packet whose source address is the BRI, then a ping from the BRI to the other BRI does not match and the BRI will not activate. If you want to be able to test by ping from BRI to BRI then you need to add a statement in the access list to permit that host to host traffic.


HTH


Rick

jsheriony Thu, 07/03/2008 - 09:09
User Badges:

Rick,



Thanks...

I understand now....


I almost laugh when I checked the config again

and noticed that...

looks like I was just looking too far...


It was really helpful..


very kind of you...


again..thanks for the time...


Richard Burts Thu, 07/03/2008 - 09:24
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


I am glad that my suggestions were helpful in understanding and resolving your issue. Sometimes it is the really simple things that become hard to recognize.


Thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that responses were successful in understanding and resolving the issue.


The forum is an excellent place to learn Cisco networking. I encourage you to continue your participation in the forum.


HTH


Rick

jsheriony Thu, 07/03/2008 - 09:46
User Badges:

Rick,


here's the full config for both locations.


Thanks


***Site A****

version 12.3

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname *******

!

boot-start-marker

boot-end-marker

!

logging buffered 10000 debugging

enable secret

!

no network-clock-participate slot 1

no network-clock-participate wic 0

voice-card 1

!

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup


!

isdn switch-type *****

!

!

!

!

!

!

!

!

!

!

!

username **** password

!

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

ds0-group 0 timeslots 1-24 type e&m-immediate-start

!

class-map match-all Data

match ip precedence 2

class-map match-all Voice

match ip precedence 5

class-map match-all Maintenance

match ip precedence 6

!

!

policy-map LLQ24ch

class Voice

priority 624

class Data

bandwidth 832

class Maintenance

bandwidth 48

class class-default

bandwidth 200

random-detect

policy-map FE_Precedence

class class-default

shape average 4000000

service-policy LLQ24ch

!

!

!

!

interface Loopback0

description For_voice_session_target_

ip address 192.168.121.241 255.255.255.255

!

interface FastEthernet0/0

description to LAN

ip address 192.168.120.252 255.255.255.0


!

interface BRI0/0

description ISDN_Call back_server

ip address 192.168.121.245 255.255.255.252

ip access-group 140 out

encapsulation ppp

load-interval 30

dialer idle-timeout 0

dialer map ip 192.168.121.246 name SiteB class dial1 **8446756098

dialer hold-queue 100

dialer load-threshold 3 outbound

dialer callback-secure

isdn switch-type ***

no keepalive

no cdp enable

ppp callback accept

!

interface FastEthernet0/1

description to SiteA LAN

bandwidth 4000

ip address 192.168.121.1 255.255.255.252

speed 100

full-duplex

no cdp enable

service-policy output FE_Precedence

!

router bgp 65000

no synchronization

no bgp log-neighbor-changes

network 6.0.0.0 mask 255.255.254.0

network 10.0.0.0

network 30.0.0.0 mask 255.255.224.0

network 172.16.0.0 mask 255.252.0.0

network 172.28.0.0

network 172.30.0.0 mask 255.254.0.0

network 192.0.0.0 mask 255.255.0.0

network 192.1.0.0 mask 255.255.0.0

network 192.168.0.0 mask 255.255.224.0

network 192.168.52.0 mask 255.255.252.0

network 192.168.56.0 mask 255.255.252.0

network 192.168.80.0

network 192.168.120.0

network 192.168.121.17 mask 255.255.255.255

network 192.168.128.0 mask 255.255.128.0

network 198.179.161.0

neighbor 192.168.121.2 remote-as 11158

neighbor 192.168.121.2 soft-reconfiguration inbound

no auto-summary

!

ip local policy route-map Precedence

no ip http server

ip classless

ip route 6.0.0.0 255.255.254.0 192.168.120.254

ip route 10.0.0.0 255.0.0.0 192.168.120.254

ip route 30.0.0.0 255.255.224.0 192.168.120.254

ip route 172.16.0.0 255.252.0.0 192.168.120.254

ip route 172.28.0.0 255.255.0.0 192.168.120.254

ip route 172.30.0.0 255.254.0.0 192.168.120.254

ip route 192.0.0.0 255.255.0.0 192.168.120.254

ip route 192.1.0.0 255.255.0.0 192.168.120.254

ip route 192.168.0.0 255.255.224.0 192.168.120.254

ip route 192.168.52.0 255.255.252.0 192.168.120.254

ip route 192.168.56.0 255.255.252.0 192.168.120.254

ip route 192.168.60.0 255.255.255.0 192.168.121.246 200 SiteB Backup

ip route 192.168.80.0 255.255.255.0 192.168.120.254

ip route 192.168.120.0 255.255.255.0 192.168.120.254

ip route 192.168.121.17 255.255.255.255 192.168.120.254

ip route 192.168.121.253 255.255.255.255 192.168.121.2 name maintenance

ip route 192.168.128.0 255.255.128.0 192.168.120.254

ip route 198.179.161.0 255.255.255.0 192.168.120.254

jsheriony Thu, 07/03/2008 - 09:48
User Badges:

!

!

!

map-class dialer dial1

dialer callback-server username

access-list 1 permit 192.168.121.0 0.0.0.255

access-list 100 permit tcp any any eq 1720

access-list 100 permit tcp any eq 1720 any

access-list 110 permit ip host 172.16.0.1 any

access-list 110 permit ip host 172.17.0.1 any

access-list 110 permit ip any host 172.29.40.1

access-list 120 permit tcp 192.168.121.0 0.0.0.255 eq telnet any

access-list 120 permit tcp 192.168.121.0 0.0.0.255 any eq telnet

access-list 120 permit icmp host 192.168.121.1 any

access-list 120 permit icmp host 192.168.120.252 any

access-list 120 permit tcp any any eq bgp

access-list 120 permit tcp any eq bgp any

access-list 130 permit ip any any

access-list 140 permit ip 192.168.52.0 0.0.0.255 192.168.60.64 0.0.0.3

access-list 140 permit ip 192.168.52.0 0.0.0.255 host 192.168.60.70

access-list 140 permit ip 192.168.52.0 0.0.0.255 host 192.168.60.224

access-list 140 permit ip 192.168.56.0 0.0.0.255 192.168.60.64 0.0.0.3

access-list 140 permit ip 192.168.56.0 0.0.0.255 host 192.168.60.70

access-list 140 permit ip 192.168.56.0 0.0.0.255 host 192.168.60.224

access-list 140 permit ip host 192.168.121.245 host 192.168.121.246

no cdp run

!

route-map Precedence permit 100

match ip address 100

set ip precedence critical

!

route-map Precedence permit 110

match ip address 110

set ip precedence immediate

!

route-map Precedence permit 120

match ip address 120

set ip precedence internet

!

route-map Precedence permit 130

match ip address 130

set ip precedence routine

!

snmp-server community

snmp-server enable traps tty

!

voice-port 1/0:0

input gain -6

output attenuation 6

cptone

timeouts initial 5

timeouts interdigit 3

!

!

!

!

dial-peer cor custom

!

!

!


jsheriony Thu, 07/03/2008 - 09:51
User Badges:

*******Site B*****


interface FastEthernet0/0

description to LAN

ip address 192.168.60.254 255.255.255.0

ip policy route-map Precedence

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

no cdp enable

!

interface Serial0/2/0

description to WAN

bandwidth 1024

ip address 192.168.121.49 255.255.255.252

service-policy output LLQ4ch

encapsulation ppp

no cdp enable

!

interface BRI0/3/0

description FromSiteB

ip address 192.168.121.246 255.255.255.252

ip access-group 130 out

encapsulation ppp

load-interval 30

dialer idle-timeout 30 either

dialer map ip 192.168.121.245 **9163506

dialer hold-queue 100

dialer load-threshold 1 outbound

dialer-group 1

isdn switch-type basic-net3

isdn fast-rollover-delay 5

no keepalive

no fair-queue

no cdp enable

ppp callback request

ppp authentication chap

ppp multilink

!

router bgp 65000

no synchronization

no bgp log-neighbor-changes

network 192.168.60.0

neighbor 192.168.121.50 remote-as 11158

neighbor 192.168.121.50 soft-reconfiguration inbound

no auto-summary

!

ip local policy route-map Precedence

ip classless

ip route 192.168.52.0 255.255.252.0 192.168.121.245 200 name _LAN_BackUp1

ip route 192.168.56.0 255.255.252.0 192.168.121.245 200 name _LAN_BackUp2

!

no ip http server

no ip http secure-server

!

!

access-list 1 permit 192.168.121.0 0.0.0.255

access-list 100 permit tcp any any eq 1720

access-list 100 permit tcp any eq 1720 any

access-list 110 permit tcp 192.168.121.0 0.0.0.255 eq telnet any

access-list 110 permit tcp 192.168.121.0 0.0.0.255 any eq telnet

access-list 110 permit icmp host 192.168.121.49 any

access-list 110 permit icmp host 192.168.60.254 any

access-list 110 permit tcp any any eq bgp

access-list 110 permit tcp any eq bgp any

access-list 120 permit ip 192.168.60.64 0.0.0.3 192.168.52.0 0.0.0.255

access-list 120 permit ip 192.168.60.64 0.0.0.3 192.168.56.0 0.0.0.255

access-list 120 permit ip host 192.168.60.70 192.168.52.0 0.0.0.255

access-list 120 permit ip host 192.168.60.70 192.168.56.0 0.0.0.255

access-list 120 permit ip host 192.168.60.224 192.168.52.0 0.0.0.255

access-list 120 permit ip host 192.168.60.224 192.168.56.0 0.0.0.255

access-list 120 permit ip host 192.168.121.246 host 192.168.121.245

access-list 130 permit ip 192.168.60.64 0.0.0.3 192.168.52.0 0.0.0.255

access-list 130 permit ip 192.168.60.64 0.0.0.3 192.168.56.0 0.0.0.255

access-list 130 permit ip host 192.168.60.70 192.168.52.0 0.0.0.255

access-list 130 permit ip host 192.168.60.70 192.168.56.0 0.0.0.255

access-list 130 permit ip host 192.168.60.224 192.168.52.0 0.0.0.255

access-list 130 permit ip host 192.168.60.224 192.168.56.0 0.0.0.255

access-list 130 permit ip host 192.168.121.246 host 192.168.121.245

access-list 199 permit ip any any

dialer-list 1 protocol ip list 120

snmp-server community ****** RO

snmp-server enable traps tty

no cdp run

route-map Precedence permit 100

match ip address 100

set ip precedence critical

!

route-map Precedence permit 110

match ip address 110

set ip precedence internet

!

route-map Precedence permit 199

match ip address 199

set ip precedence routine


jsheriony Thu, 07/03/2008 - 09:28
User Badges:

hi Rick...


I just noticed...


I have the ip add of the bri port of the other side at the dialer list....


but ping is NG....???


Thanks

Richard Burts Thu, 07/03/2008 - 10:28
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


I see that access list 120 has a bunch of entries added including one that should allow ping from the BRI at B to the BRI at A. The dialer list was an issue before and I believe that it is not the issue now. If ping does not work then we need to look for something else.


I would like to start with the output of show isdn status from both routers. Can you post that?


Assuming that the status looks normal we need to look at some other things to determine why ping is not working. I will list several debugs that may show us the problem. For ease of interpretation I would suggest that you run then one at a time (start the first debug, attempt the ping, gather the debug output, stop that debug and start the next debug, attempt ping, and cycle through the list:

- debug dialer (this will show whether the router believes that it should bring up the ISDN. I would expect it to show attempts at dial activity - if it does not show dial attempts then do not run the other debugs).

- debug isdn q931 (this should show the ISDN dialing activity and whether there are ISDN issues preventing the call)

- debug ppp negotiation (if ISDN dials the call then this will show the router attempting to make the PPP connection)

- debug ppp authentication (if PPP is negotiated this will show whether there are problems in authentication).


Post these debugs and we will see what they show us about the ping not working.


HTH


Rick

jsheriony Thu, 07/03/2008 - 10:41
User Badges:

Rick,



i really appreciate this...


nothing shows on the first debug....

Richard Burts Thu, 07/03/2008 - 10:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


I am surprised that there is no output in the first debug. I wonder if the output is supressed for some reason. How are you looking for the debug output? Are you on the console or are you telnet/ssh connected to the router? Would you do the show log command and post the first screen or two of output? The initial output of show log gives some helpful information about how logging is configured and the severity levels for logging. Seeing this may be helpful.


Also, just to check on the obvious: you are trying to do the ping from B to A?


HTH


Rick

jsheriony Thu, 07/03/2008 - 11:04
User Badges:

I kinda been trying from both CE

I'm doing it thru vty.Im not at the site...


when i do isdn test call from either side, it will appear as it's ok base on the sh isdn hist output...but still ping will be NG.

The connection will last for about 30 secs on either side as configured..

I can assume that ISDN wont work even when the main line is down...

jsheriony Thu, 07/03/2008 - 11:09
User Badges:

Rick,


checked the logs on Site B and nothing there but the ISDN logs ccaused by my ISDN test calls...


plus this...


Asserion failed: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob.ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771


It does look like a bug....

Richard Burts Thu, 07/03/2008 - 11:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


Based on the lack of dialer-group and dialer-list on A I would expect ping from A to B to fail. I would expect ping from B to A to work - at least based on which one can initiate the connection.


If you are on vty did you do terminal monitor before running the debug? I still would be interested in seeing the first page of two of output from show log, just to verify that debug is not supressed.


The assertion failed message is almost certainly the sign of a software problem. It might be a good idea to plan for a code upgrade.


HTH


Rick

jsheriony Thu, 07/03/2008 - 11:35
User Badges:

here's the logs


****SiteA*****

May 7 07:15:23.048 UTC: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

May 7 07:15:24.049 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down

May 7 07:26:09.055 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0, TEI 81 changed to down

May 7 07:26:31.772 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0, TEI 83 changed to up

May 7 12:15:42.370 UTC: %SYS-5-CONFIG_I: Configured from console by vty0 (192.168.121.2)

May 7 12:19:03.376 UTC: %SYS-5-CONFIG_I: Configured from console by vty0 (192.168.121.2)

May 7 12:43:06.277 UTC: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

May 7 12:43:06.277 UTC: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to *******8446756098 N/A

May 7 12:43:07.844 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up

May 7 12:43:36.519 UTC: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from *******8446756098 SiteB, call lasted 30 seco

nds

May 7 12:43:36.519 UTC: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down

May 7 12:43:37.520 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to down

May 7 12:48:33.886 UTC: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up

May 7 12:48:33.890 UTC: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to *******8446756098 N/A

May 7 12:48:35.453 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed state to up

May 7 12:49:04.128 UTC: %ISDN-6-DISCONNECT: Interface BRI0/0:1 disconnected from *******8446756098 SiteB, call las



*****site B-****

May 7 15:02:33.346 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

May 7 15:03:06.031 UTC: BR0/3/0 DDR: Attempting to dial ******9163506

May 7 15:03:06.035 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

May 7 15:03:06.219 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 102 changed to up

May 7 15:03:07.679 UTC: BRI0/3/0: wait for isdn carrier timeout, call id=0x8522

May 7 15:03:07.679 UTC: DDR: Dialing failed, 0 packets unqueued and discarded

May 7 15:03:09.867 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 102 changed to down

May 7 15:03:16.290 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

May 7 15:03:59.314 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 103 changed to up

May 7 15:04:04.334 UTC: BR0/3/0 DDR: Attempting to dial ******9163506

May 7 15:04:05.790 UTC: BRI0/3/0: wait for isdn carrier timeout, call id=0x8523

May 7 15:04:05.790 UTC: DDR: Dialing failed, 0 packets unqueued and discarded

May 7 15:04:07.981 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 103 changed to down

May 7 15:04:09.409 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

May 7 15:06:05.626 UTC: BR0/3/0 DDR: Attempting to dial ******9163506

May 7 15:06:05.630 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

May 7 15:06:05.842 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 104 changed to up

May 7 15:06:07.290 UTC: BRI0/3/0: wait for isdn carrier timeout, call id=0x8524

May 7 15:06:07.290 UTC: DDR: Dialing failed, 0 packets unqueued and discarded

May 7 15:06:09.486 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 104 changed to down

May 7 15:06:15.937 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

jsheriony Thu, 07/03/2008 - 11:37
User Badges:

I also made a debug at site B and run tests below...



SiteB#

SiteB#

SiteB#isdn test call interface BRI0/3/0 *****9163506

SiteB#

May 7 15:06:05.626 UTC: BR0/3/0 DDR: Attempting to dial *****9163506

May 7 15:06:05.630 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

SiteB#

May 7 15:06:05.842 UTC: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/3/0, TEI 104 changed to up

SiteB#

May 7 15:06:07.290 UTC: BRI0/3/0: wait for isdn carrier timeout, call id=0x8524

May 7 15:06:07.290 UTC: DDR: Dialing failed, 0 packets unqueued and discarded

SiteB#

May 7 15:06:09.486 UTC: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/3/0, TEI 104 changed to down

SiteB#

May 7 15:06:15.937 UTC: ASSERTION FAILED: file "/vws/bvb/CPY-v123_8_t_throttle.V123_8_T11/vob/ios.sys7/sys/obj-5k-c2801/../chips/gt96k/gt96k_timer.c", line 771

SiteB#



when I did the debug, yes i run term mon


thanks

Richard Burts Thu, 07/03/2008 - 11:52
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Jayson


Just verify - the output in the logs that you posted is generated when you do isdn test call and not any output is generated when you attempt to ping from B to A?


I am a bit puzzled at the fact that the logs from A seem to indicate successful connection with B but the logs on B show that dialing failed when attempting to call A. Since the date and time stamps are not accurate I can not tell whether they are in the same time range or not. Can you clarify this?


HTH


Rick

jsheriony Thu, 07/03/2008 - 11:57
User Badges:

Rick,


ping test has been NG...thus...no output can

be taken for the ping tests...


and yes the output is when I did the isdn test call from site B to site A...Site A looks to be working fine

but however, it does look like that the error at site B is preventing the ISDN to work...


yes they are at the same time range....


uhhhh...i need more study...but Rick, you're really helping me a lot...I really appreciate it...

jsheriony Thu, 07/03/2008 - 11:58
User Badges:

do you think it could be resolved by modifiying the configuration??


gonna be a big gumble though....

jsheriony Thu, 07/03/2008 - 10:55
User Badges:

here's the sh isdn status output.


***SiteA***

Global ISDN Switchtype = ***

ISDN BRI0/0 interface

dsl 0, interface ISDN Switchtyoe = ***

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 83, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask; 0x80000003

Total Allocated ISDN CCBs = 0


*****Site B******

Global ISDN Switchtype = ***

ISDN BRI0/3/0 interface

dsl 6, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 101, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask; 0x80000003

Total Allocated ISDN CCBs = 0



Thanks

Actions

This Discussion