Voice problem....

Unanswered Question
Jul 3rd, 2008
User Badges:

Hi.

We're having voice problem with the 2 sites.voice is sometimes umping and sometims totaly dead.We have replaced the

voice module already at site B, and reset the PBX at site A, but I think it hasn't been resolve.

Can please someone check the config if there's any hole in it??


here's the config.


****SITE A*****

version 12.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname *********

!

boot-start-marker

boot-end-marker

!

logging buffered 10000 debugging

enable secret

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate slot 2

ip cef

!

!

!

!

no ip domain lookup

ip host ***********

ip host ***********

voice-card 0

no dspfarm

!

voice-card 1

no dspfarm

!

voice-card 2

no dspfarm

!

!

!

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

class-map match-all Control

match ip precedence 6

class-map match-all Voice

match ip precedence 5

!

!

policy-map LLQ_12ch(320K)

class Control

bandwidth 16

class Voice

priority 320

class class-default

fair-queue

random-detect

policy-map GE_Precedence

class class-default

shape average 1000000 1000000 0

service-policy LLQ_12ch(320K)

!

!

!

!

interface GigabitEthernet0/0

description To_SiteA

bandwidth 1024

ip address 10.0.100.1 255.255.255.252

duplex full

speed 100

media-type rj45

no cdp enable

service-policy output GE_Precedence

!

interface GigabitEthernet0/1

description To_-LAN

ip address 10.0.0.65 255.255.255.0

ip policy route-map PRECEDENCE

duplex full

speed 100

media-type rj45

no cdp enable

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

no cdp enable

!

ip local policy route-map PRECEDENCE

ip route 0.0.0.0 0.0.0.0 10.0.0.1 name To_NetS*****

ip route 10.0.3.0 255.255.255.0 10.0.100.2 name To__LAN

ip route 10.0.6.0 255.255.255.0 10.0.100.2 name To__LAN

ip route 10.0.110.0 255.255.255.252 10.0.100.2 name To_-WAN

ip route 10.0.120.0 255.255.255.252 10.0.100.2 name To__WAN

ip route 10.0.200.0 255.255.255.252 10.0.100.2 name To_Maintenance

!

!

no ip http server

no ip http secure-server

!

access-list 1 remark *** For_telnet_from_Maintenance&CE-R ***

access-list 1 permit 10.0.0.0 0.0.255.255

access-list 100 remark *** For_Control_Class ***

access-list 100 permit tcp 10.0.100.0 0.0.0.3 any eq telnet

access-list 100 permit tcp 10.0.100.0 0.0.0.3 eq telnet any

access-list 100 permit icmp any any

access-list 110 remark *** For_Routine_Class ***

access-list 110 permit ip any any

no cdp run

route-map PRECEDENCE permit 10

description For_Control_Class

match ip address 100

set ip precedence internet

!

route-map PRECEDENCE permit 20

description For_Routine_Class

match ip address 110

set ip precedence routine

!

!

!

!

control-plane

!

!

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jsheriony Thu, 07/03/2008 - 06:31
User Badges:

voice-port 0/1/0

operation 4-wire

type 5

cptone JP

timeouts initial 5

timeouts interdigit 2

description **** E&M ch1 ****

!

voice-port 0/1/1

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch2 ****

!

voice-port 0/2/0

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch3 ****

!

voice-port 0/2/1

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch4 ****

!

voice-port 1/0/0

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch5 ****

!

voice-port 1/0/1

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch6 ****

!

voice-port 1/1/0

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch7 ****

!

voice-port 1/1/1

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch8 ****

!

voice-port 2/0/0

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch9 ****

!

voice-port 2/0/1

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch10 ****

!

voice-port 2/1/0

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch11 ****

!

voice-port 2/1/1

operation 4-wire

type 5

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch12 ****

!

!

!

!

!

dial-peer voice 10 pots

destination-pattern 70T

port 0/1/0

!

dial-peer voice 20 pots

destination-pattern 70T

port 0/1/1

!

dial-peer voice 30 pots

destination-pattern 70T

port 0/2/0

!

dial-peer voice 40 pots

destination-pattern 70T

port 0/2/1

!

dial-peer voice 50 pots

destination-pattern 70T

port 1/0/0

!

dial-peer voice 60 pots

destination-pattern 70T

port 1/0/1

!

dial-peer voice 70 pots

destination-pattern 70T

port 1/1/0

!

dial-peer voice 80 pots

destination-pattern 70T

port 1/1/1

!

dial-peer voice 90 pots

destination-pattern 70T

port 2/0/0

!

dial-peer voice 100 pots

destination-pattern 70T

port 2/0/1

!

dial-peer voice 110 pots

destination-pattern 70T

port 2/1/0

!

dial-peer voice 120 pots

destination-pattern 70T

port 2/1/1

!

dial-peer voice 76 voip

description To_SiteB

destination-pattern 76T

session target ipv4:10.0.110.1

incoming called-number .T

playout-delay maximum 240

playout-delay nominal 110

playout-delay minimum high

codec g729r8 bytes 40

fax rate 9600 bytes 40

ip qos dscp cs5 media

ip qos dscp cs5 signaling

no vad

!

dial-peer voice 74 voip

description To_SiteB2

destination-pattern 74T

session target ipv4:10.0.120.2

incoming called-number .T

playout-delay maximum 240

playout-delay nominal 110

playout-delay minimum high

codec g729r8 bytes 40

fax rate 9600 bytes 40

ip qos dscp cs5 media

ip qos dscp cs5 signaling

no vad

!

!

!

line con 0

exec-timeout 5 0

password

logging synchronous

login

exec prompt timestamp

stopbits 1

line aux 0

exec-timeout 5 0

password

logging synchronous

login

modem InOut

exec prompt timestamp

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4

access-class 1 in

exec-timeout 60 0

password

logging synchronous

login

exec prompt timestamp

!

scheduler allocate 20000 1000

ntp master 1

!

end


jsheriony Thu, 07/03/2008 - 06:32
User Badges:

*******Site B***********

version 12.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname *********

!

boot-start-marker

boot-end-marker

!

logging buffered 10000 debugging

enable secret

!

no aaa new-model

ip cef

!

!

!

!

no ip domain lookup

ip host *******

ip host *******

voice-card 0

no dspfarm

!

!

!

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

class-map match-all Control

match ip precedence 6

class-map match-all Voice

match ip precedence 5

!

!

policy-map LLQ_6ch+2ch(168K)

class Control

bandwidth 16

class Voice

priority 168

class class-default

fair-queue

random-detect

policy-map LLQ_2ch(48K)

class Control

bandwidth 16

class Voice

priority 48

class class-default

fair-queue

random-detect

!

!

!

!

interface GigabitEthernet0/0

description To_LAN

ip address 10.0.3.3 255.255.255.0

ip policy route-map PRECEDENCE

duplex full

speed 100

media-type rj45

no cdp enable

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

no cdp enable

!

interface Serial0/0/0

description To_WAN

bandwidth 1024

ip address 10.0.110.1 255.255.255.252

ip accounting output-packets

encapsulation ppp

no cdp enable

service-policy output LLQ_6ch+2ch(168K)

!

interface Serial1/0

description To_SiteB2

bandwidth 128

no ip address

encapsulation frame-relay IETF

serial restart-delay 0

frame-relay traffic-shaping

frame-relay lmi-type q933a

!

interface Serial1/0.1 point-to-point

ip address 10.0.120.1 255.255.255.252

no cdp enable

frame-relay class VoIP(128K)

frame-relay interface-dlci 999

!

interface Serial1/1

no ip address

shutdown

no fair-queue

serial restart-delay 0

no cdp enable

!

interface Serial1/2

no ip address

shutdown

no fair-queue

serial restart-delay 0

no cdp enable

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

no cdp enable

!

ip local policy route-map PRECEDENCE

ip route 0.0.0.0 0.0.0.0 10.0.110.2 name To_Default

ip route 10.0.6.0 255.255.255.0 10.0.120.2 name To_LAN

!

!

no ip http server

no ip http secure-server

!

!

map-class frame-relay VoIP(128K)

frame-relay cir 112000

frame-relay bc 1120

frame-relay be 0

frame-relay mincir 112000

frame-relay fragment 160

service-policy output LLQ_2ch(48K)

access-list 1 remark *** For_telnet_from_Maintenance&CE-R ***

access-list 1 permit 10.0.0.0 0.0.255.255

access-list 100 remark *** For_Control_Class ***

access-list 100 permit tcp 10.0.110.0 0.0.0.3 any eq telnet

access-list 100 permit tcp 10.0.110.0 0.0.0.3 eq telnet any

access-list 100 permit icmp any any

access-list 110 remark *** For_Routine_Class ***

access-list 110 permit ip any any

no cdp run

route-map PRECEDENCE permit 10

description For_Control_Class

match ip address 100

set ip precedence internet

!

route-map PRECEDENCE permit 20

description For_Routine_Class

match ip address 110

set ip precedence routine

!

!

!

!

control-plane

jsheriony Thu, 07/03/2008 - 06:33
User Badges:

!

!

!

voice-port 0/1/0

operation 4-wire

type 5

signal immediate

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch1 ****

!

voice-port 0/1/1

operation 4-wire

type 5

signal immediate

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch2 ****

!

voice-port 0/2/0

operation 4-wire

type 5

signal immediate

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch3 ****

!

voice-port 0/2/1

operation 4-wire

type 5

signal immediate

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch4 ****

!

voice-port 0/3/0

operation 4-wire

type 5

signal immediate

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch5 ****

!

voice-port 0/3/1

operation 4-wire

type 5

signal immediate

cptone ***

timeouts initial 5

timeouts interdigit 2

description **** E&M ch6 ****

!

!

!

!

!

dial-peer voice 10 pots

destination-pattern 76T

port 0/1/0

!

dial-peer voice 20 pots

destination-pattern 76T

port 0/1/1

!

dial-peer voice 30 pots

destination-pattern 76T

port 0/2/0

!

dial-peer voice 40 pots

destination-pattern 76T

port 0/2/1

!

dial-peer voice 50 pots

destination-pattern 76T

port 0/3/0

!

dial-peer voice 60 pots

destination-pattern 76T

port 0/3/1

forward-digits 0

!

dial-peer voice 70 voip

description To_SiteA

destination-pattern 70T

session target ipv4:10.0.100.1

incoming called-number .T

playout-delay maximum 240

playout-delay nominal 110

playout-delay minimum high

codec g729r8 bytes 40

fax rate 9600 bytes 40

ip qos dscp cs5 media

ip qos dscp cs5 signaling

no vad

!

dial-peer voice 74 voip

description To_SiteB2

destination-pattern 74T

session target ipv4:10.0.120.2

incoming called-number .T

playout-delay maximum 240

playout-delay nominal 110

playout-delay minimum high

codec g729r8 bytes 40

fax rate 9600 bytes 40

ip qos dscp cs5 media

ip qos dscp cs5 signaling

no vad

!

!

!

line con 0

exec-timeout 0 0

password

logging synchronous

login

exec prompt timestamp

stopbits 1

line aux 0

exec-timeout 5 0

password

logging synchronous

login

modem InOut

exec prompt timestamp

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4

access-class 1 in

exec-timeout 5 0

password

logging synchronous

login

exec prompt timestamp

!

scheduler allocate 20000 1000

ntp clock-period 17180002

ntp server 10.0.100.1

!

end




Thanks a LOT

Actions

This Discussion