Catalyst 2960 - setup/switch information?

Unanswered Question
Jul 3rd, 2008
User Badges:

I have a Catalyst 2960 series switch. To be precise it is a 2960-48TC-L. I downloaded the "Catalyst 2960 Switch

Getting Started Guide" yet am having a few issues. The switch is being used in a business office and will be used to share the internet/printer between 4-6 computers.


1. Once I get to the express setup page in my browser, it asks for the IP address, Default gateway, and Subnet mask of the router. I am not sure what to put for these and this is where I am stuck. I tried to put in a bunch of variations but none worked. How do I find out/know what to put for these?


2. After doing express setup, what is my next step? Would it be installing the Network Assistant?



Thanks to anyone who offers to help or comment about my problem, it is much appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
djsmvp222 Thu, 07/03/2008 - 10:34
User Badges:

I am slightly unfamiliar with these forums, if this post is not in the right place please inform me; or if someone has the power to move it to the correct spot on these boards that would be great too. Thanks.

javickas1 Thu, 07/03/2008 - 10:40
User Badges:

Greetings

I don't know that I can answer all your questions but I can share with you what comes to mind after reading your post.

When you first bring up the switch it goes through a setup script. You don't need to use that script, you can manually set any values using CLI commands. The ip address it's asking you to assign is for access to the management interface. The default gateway is to provide access to the management interface. In most cases when someone uses a switch it will be connected to other switches and routers. The assumption is that you will want to be able to telnet into the switch from anywhere on your network, that's why you need an address and default gateway. If you're only gonna access the switch thru the console cable then you don't need an address or default gateway

djsmvp222 Thu, 07/03/2008 - 10:55
User Badges:

First off, thank you very much for your response. I have always considered myself somewhat computer savvy, although currently I prefer hardware/software over networking :). I am somewhat new to this whole thing so all assistance is appreciated.


Basically our office has an internet port. We want to split that between 4-6 computers (and have a shared printer). This switch is obviously overkill for this job but my boss purchased it a while back and has no other use for it (the current cheap 4-port switch we have is too small).


I have tried the basic "power on the switch, plug the internet into a switch port, and hook computers up to the switch via ethernet cables." This results in a 'limited to no connectivity' error on the computer.


Do I even have to do the express setup/network assistant or am I just doing it wrong?


Thanks again!

nmooremvsc Tue, 07/08/2008 - 08:49
User Badges:

Do you currently have a Router in your office? It sounds like you don't, you will need to plug the internet into the router and then the router into the switch.

djsmvp222 Tue, 07/08/2008 - 08:55
User Badges:

Well we are currently using a D-link 4 port switch which has worked very well. Unfortunately we need a few more ports but would rather use what we have (catalyst 2960) rather than purchasing a new switch.


Im assuming since the d-link switch works there is a router before the connection to our office?

robserfozo Tue, 07/08/2008 - 09:32
User Badges:

Did you have an IP address on your Dlink? Was that IP also your PC's default Gateway?

djsmvp222 Tue, 07/08/2008 - 09:40
User Badges:

I dont know the IP of my switch.



cmd -> ipconfig (some info x'd out)


IP Address. . . . . . . . . .: 10.xx.xx.1

Subnet Mask . . . . . . . . .: 255.255.255.0

Default Gateway . . . . . . .: 10.xx.xx.254


Does this help at all? What I dont understand is that the current switch im using works just fine. All I did was plug it into the internet jack in the wall to give it internet and connected the computers/printer to the switch. I tried doing the same thing with this switch and it said "limited to no connectivity."


thanks for all help and future help as well, i look forward to resolving this problem asap.

robserfozo Tue, 07/08/2008 - 09:49
User Badges:

This may not be the best solution, but something to try. Thge Dlink is routing as well, or something else is. I would try to plug the dlink into the Internet jack and then plug the Cisco into the Dlink. You may have to use a cross-over cable from the Cisco to Dlink.


Good Luck.

Actions

This Discussion