converting a 1310 to autonomous IOS mode

Answered Question
Jul 3rd, 2008

I have a 1310 that I need to convert to autonomous IOS mode. For this I have the 1310 connected to a 2100 WLAN controller. The problem is when I run the config ap tftp-downgrade command the ap returns the following error message

examining image...

%Error opening (Timed out)

archive download: takes 62 seconds

lwapp_image_proc: unable to open tar file

I feel that I should note that the only time I can ping the AP is if it's connected to the management interface of the controller. The same goes to my computer which is acting as the tftp server. Any ideas on what is wrong here would be a great help. Thanks

I have this problem too.
0 votes
Correct Answer by Scott Fella about 8 years 5 months ago

Try to change it and see if that helps.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Scott Fella Thu, 07/03/2008 - 09:50

If you can't ping the 1310 from any subnet other than the management subnet, then it looks like a routing issue. If you can ping the 1310 from the management, you should be able to put your laptop on that subnet and tftp should not ba an issue. It also can be ACL's on the network that might be blocking certain traffic.

Do you see the device trying to access the tftp. I use 3CDaemon for TFTP.... works great. Also make sure you don'at have a firewall on your laptop blocking tftp.

http://www.petenetlive.com/Tech/Apps/Misc/tftp.html

l.cantrell Thu, 07/03/2008 - 09:58

Everything is on the same network the management interface is set to 10.200.4.4 and the AP has a static IP of 10.200.4.106 and the laptop as 10.200.4.105. This is setup in a test environment so those are the only things connected to it. As for the pinging it is only when something is plugged into port 1(management interface) that it becomes pingable.

Scott Fella Thu, 07/03/2008 - 10:04

Well, without looking at your configuration, port 1 is your management and ap-manager interface. You should have that trunked to your switch. This also should be untagged or set to 0 on the lwc. The switch port should be set to native vlan X.

Post your show run-config

l.cantrell Thu, 07/03/2008 - 10:08

Here is a copy of the running-config. Now I do not have the the controller hooked up to a switch. Both the laptop and the ap plug directly into the controller. Could this be the problem?

Cisco Controller) >show running-config

802.11a cac voice tspec-inactivity-timeout ignore

802.11a cac voice stream-size 84000 max-streams 2

802.11b cac voice tspec-inactivity-timeout ignore

802.11b cac voice stream-size 84000 max-streams 2

location rssi-half-life tags 0

location rssi-half-life client 0

location rssi-half-life rogue-aps 0

location expiry tags 5

location expiry client 5

location expiry calibrating-client 5

location expiry rogue-aps 5

ap syslog host global 255.255.255.255

dhcp create-scope Ap-dhcp

dhcp address-pool Ap-dhcp 10.200.4.100 10.200.4.104

dhcp default-router Ap-dhcp 10.200.4.105

dhcp enable Ap-dhcp

dhcp dns-servers Ap-dhcp 10.20.3.27 10.10.3.20

dhcp domain Ap-dhcp ptrcs.com

dhcp network Ap-dhcp 10.200.4.0 255.255.255.0

local-auth method fast server-key *****

interface address ap-manager 10.200.4.3 255.255.255.0 10.200.4.1

interface address management 10.200.4.4 255.255.255.0 10.200.4.1

interface address virtual 1.1.1.1

interface dhcp ap-manager primary 10.200.4.4

interface dhcp management primary 10.200.4.4 secondary 10.200.4.3

interface port ap-manager 2

interface port management 2

load-balancing window 5

logging syslog host 0.0.0.0

mesh security eap

mgmtuser add admin **** read-write

mobility group domain Pierce

network master-base enable

network otap-mode disable

network rf-network-name Pierce

radius cred-cache enable

snmp version v2c enable

snmp version v3 enable

sysname WLAN_Controller

wlan create 1 Pierce Pierce

wlan session-timeout 1 1800

wlan wmm allow 1

wlan security static-wep-key encryption 1 104 1

wlan enable 1

Scott Fella Thu, 07/03/2008 - 10:13

yes... you need to have the port your management and ap manager is on connected to a switch. the 2106 isn't a true switch.

l.cantrell Thu, 07/03/2008 - 12:07

Ok I attached the AP and the laptop running the tftp server to a 2960 switch. I can ping everything now. However, when I run the config ap tftp-downgrade command I get a invalid AP name. The AP is called ap1. Why does it say that it is invalid?

l.cantrell Thu, 07/03/2008 - 12:15

Same issue the controller can see the ap but if you try to make any changes like changing the name etc. it returns Cisco AP name is invalid. If I do a show ap summary it list the ap with the name ap1 right IP and mac address though.

l.cantrell Thu, 07/03/2008 - 13:00

Ok fixed the issue when I tried to do the tftp-downgrade to the a 12.3-7JA version it worked without complaints. Thanks for all the help.

Scott Fella Thu, 07/03/2008 - 13:36

That is good news... it was bugging me and I was going to try it in my lab.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode