C2950 boot system command

Unanswered Question
Jul 3rd, 2008
User Badges:

Hello all,

During an IOS upgrade the IOS was installed in a sub-directory - flash:/flash/c2950-i6k2l2q4-mz.121-22.EA11.bin. I don't know how. Upon rebooting the switch boots up to switch: prompt and I have to manually point to the IOS command boot flash:/flash/c2950-i6k2l2q4-mz.121-22.EA11.bin. The config-reg value is 0xF.

I entered command boot system flash:/flash/c2950-i6k2l2q4-mz.121-22.EA11.bin and boot system /flash/c2950-i6k2l2q4-mz.121-22.EA11.bin and saved each one but neither helped.

Any idea why the boot system command won't take? Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
n.nandrekar Thu, 07/03/2008 - 21:56
User Badges:
  • Silver, 250 points or more

hi!

You would have to change the boot options (confreg) to 0x2102. Tho option 0xF would tell the device to boot from rommon. Use the following procedure :



rommon 2 > confreg 0x2102



You must reset or power cycle for new config to take effect


=== or ======


rommon 3 > priv

You now have access to the full set of monitor commands.

Warning: some commands will allow you to destroy your

configuration and/or system images and could render

the machine unbootable.


rommon 5 > confreg



Configuration Summary

(Virtual Configuration Register: 0x2)

enabled are:

[ 0 ] break/abort has effect

[ 1 ] console baud: 9600

boot: ...... image specified by the boot system commands or default to: cisco2-Cat6k-Sup32


do you wish to change the configuration? y/n [n]: y

enable "diagnostic mode"? y/n [n]:

enable "use net in IP bcast address"? y/n [n]:

enable "load rom after netboot fails"? y/n [n]:

enable "use all zero broadcast"? y/n [n]:

disable "break/abort has effect"? y/n [n]:

enable "ignore system config info"? y/n [n]:

change console baud rate? y/n [n]:

change the boot characteristics? y/n [n]: y <<<<<<<<<


enter to boot:

0 = ROM Monitor

1 = the boot helper image

2-15 = boot system

[2]: 2 <<<<<<<<<<<<<<


Configuration Summary

(Virtual Configuration Register: 0x2)

enabled are:

[ 0 ] break/abort has effect

[ 1 ] console baud: 9600

boot: ...... image specified by the boot system commands or default to: cisco2-Cat6k-Sup32


do you wish to change the configuration? y/n [n]: n

rommon 6 > sync


rommon 7 > reset


Resetting .......



Either of these will set the config reg to 0x

Regards,

Niranjan


(please rate helpful posts)


vpersaud001 Mon, 07/07/2008 - 07:25
User Badges:

Thanks for your suggestion. I'll try that as soon as I can get a webex session going with someone on site.

n.nandrekar Mon, 07/07/2008 - 21:59
User Badges:
  • Silver, 250 points or more

Oh! Sorry!

Did you try the

"The Switch Goes to ROMmon Mode (switch: prompt) as Automatic Boot does not Occur"

section config given in the link that you just posted? That should work. I was trying to suggest the same which is done by use of config registers in other platforms. Probably 2900 needs this method.


Regards,

Niranjan

vpersaud001 Wed, 07/09/2008 - 05:03
User Badges:

I did. Thanks. :)

It's an old switch and may be shot - we're going to replace it.

vpersaud001 Thu, 10/02/2008 - 09:15
User Badges:

FYI: The mode button on the switch was stuck causing it to boot up into ROMMON mode (to boot the 2950 to rommon requires holding down the mode button for 10 secs.). Toggling the mode button to free it up resolved the issue.

Thanks for your help.

glen.grant Thu, 10/02/2008 - 11:49
User Badges:
  • Purple, 4500 points or more

If its in a directory your boot statement would have to be "boot system flash:c2950-i6k2l2q4-mz.121-22.EA11/c2950-i6k2l2q4-mz.121-22.EA11.bin. The upgrade must have used a .tar file to upgrade.

Actions

This Discussion