Configure 2801 for 15 channel PRI

Answered Question
Jul 3rd, 2008

I'm new to configuring PRI's so excuse me if there is an obvious answer to my question. I recently purchased CUCM Business Edition and a 2801 router. I've configured the CM and the router and now have outbound calling working but cannot call in to any of the DID's. On the controller I did

pri-group timeslots 1-15 service mgcp

and i want to know if anyone knows if that is correct for a 15 channel partial PRI. Also if anyone has any ideas why I'd be able to make calls out but not receive calls. Any help greatly appreciated.

Here is part of the router config:

...

controller T1 0/1/0

framing esf

linecode b8zs

pri-group timeslots 1-15,24 service mgcp

!

!

!

interface FastEthernet0/0

ip address 172.16.6.1 255.255.255.0

speed 100

full-duplex

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/1/0:23

no ip address

isdn switch-type primary-4ess

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip classless

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

control-plane

!

disable-eadi

!

!

voice-port 0/1/0:23

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.16.6.2

ccm-manager config

!

mgcp

mgcp call-agent 172.16.6.2 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

!

line con 0

...

Correct Answer by Paolo Bevilacqua about 8 years 7 months ago

Hi,

the ISDN is all good. The problem is that your CM doesn't know what to with called number 16619.

Unfortunately I'm not good with the CM configuration to tell you exactly how to translate this number to match your extensions.

If you were using H.323 or SIP, it would be instead a simple configuration on the GW.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Justin Brenton Thu, 07/03/2008 - 23:49

Hi Houstonrob,

You do not have the DID configured, that's why you cannot receive calls. Your voice gateway receives the call through the PRI but do not know what to do with it.

configure:

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

Hope this helps if so please rate below in the checkbox.

Regards,

Justin

Paolo Bevilacqua Fri, 07/04/2008 - 00:52

Justin,

He is using MGCP, consequently DP do not apply.

Still, it would be needed to see a "debug isdn q931" with "term mon" to understand the problme.

houstonrob Fri, 07/04/2008 - 06:28

Thanks for the help, when i do debug isdn q931 or 921 there is no activity until i try to call one of my numbers, then i get:

2801VGW#debug isdn q931

debug isdn q931 is ON.

2801VGW#

*Jul 4 14:18:59.229: ISDN Se0/1/0:23 Q931: RX <- SETUP pd = 8 callref = 0x0A92

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Called Party Number i = 0x80, '16619'

Plan:Unknown, Type:Unknown

*Jul 4 14:18:59.233: ISDN Se0/1/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref =

0x8A92

Cause i = 0x8081 - Unallocated/unassigned number

and

2801VGW#debug isdn q921

debug isdn q921 is ON.

2801VGW#

*Jul 4 14:21:03.089: ISDN Se0/1/0:23 Q921: User RX <- INFO sapi=0 tei=0, ns=6 n

r=6

*Jul 4 14:21:03.093: ISDN Se0/1/0:23 Q921: User TX -> RR sapi=0 tei=0 nr=7

*Jul 4 14:21:03.097: ISDN Se0/1/0:23 Q921: User TX -> INFO sapi=0 tei=0, ns=6 n

r=7

*Jul 4 14:21:03.105: ISDN Se0/1/0:23 Q921: User RX <- RR sapi=0 tei=0 nr=7

Thanks

Correct Answer
Paolo Bevilacqua Fri, 07/04/2008 - 06:32

Hi,

the ISDN is all good. The problem is that your CM doesn't know what to with called number 16619.

Unfortunately I'm not good with the CM configuration to tell you exactly how to translate this number to match your extensions.

If you were using H.323 or SIP, it would be instead a simple configuration on the GW.

houstonrob Fri, 07/04/2008 - 06:35

Thank you very much, you pointed out that the telco setup for 5 significant digits, they shouldve set up for 4. I'll call them and have them correct the problem

Thanks

Actions

This Discussion