Switch thinks it's root while it's actually not

Answered Question
Jul 4th, 2008

Our server guys got two new c7000 blade enclosures, and I set up the blade switches (3120X) that came w/ them.

I set them up as a single VBS.

After connecting the switch stack to our DC aggr 6513, it somehow says it's the root of EVERY vlan!

Checked the priority of the new switch, it's got the higher number than the actual root.

I hardcode the priority to 64400 (or something close to it), same thing.

Has anyone seen anything like this?

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 8 years 4 months ago

You are only allowing vlans 3,6 & 13 across the trunk link from the 6500 switches. So if you look at the spanning-tree for these vlans on the 3120's they should be reporting the 6500's as STP root.

But for all the other vlans by not allowing them across the trunk you stop STP running across the trunk for those vlans so both will think they are root.

Solution depends on what you are trying to achieve

1) By only allowing 3,6,13 on the link it sounds like these are the only vlans present on the 3120 switches. If so you could make the 3120 switches VTP transparent and only have those vlans created on the switches.

2) Rather than using allowed you can prune the trunk link. If you prune then STP will still run across the link for the pruned vlans so the 3120's should see the 6500 switches as root for all vlans. Be careful not to use a list of vlans with the prune command though as this has the same effect as using the "allowed" keyword ie. it stops STP for vlans not in the list.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
n.nandrekar Sat, 07/05/2008 - 03:51

hi!!

In case of spanning tree, the switch with a "LOWER" priority becomes the root bridge. Hoping that I am understanding your problem correctly, you need to "DECREASE" the priority of the new switch to a value lesser than 6513 in order to make the new switch as the root bridge.

Regards,

Niranjan

(pls rate helpful posts)

huangedmc Sat, 07/05/2008 - 05:29

We don't want the new switch to be root.

Our problem is that even though the new switch has a higher priority, it says it's the root for all the vlan's.

n.nandrekar Sat, 07/05/2008 - 08:02

Oh!! Your statement in the original post...."Checked the priority of the new switch, it's got the higher number than the actual root. "

was contradicting what you said in the latest post. Hence that was my reply.

Anyways, to troubleshoot,

1. Are both switches connected using a trunk?

2. Does the 6500 also recognize the new switch as the root? or are both declaring themselves as the root? it could tell us that one of them is not receiving/processing the other's bpdus.

3. Is it possible for you to paste "sh spanning-tree" from both the switches? and also the connected port configs?

Regards,

Niranjan

huangedmc Sat, 07/05/2008 - 14:38

Switches are connected via trunk ports, and both declare themselves as root.

6513:

interface GigabitEthernet12/35

description CS-BE-34-179

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,6,13

switchport mode trunk

no ip address

speed 1000

duplex full

channel-group 2 mode active

end

CS-SWHC-0-2#sh run int g13/40

Building configuration...

Current configuration : 244 bytes

!

interface GigabitEthernet13/40

description CS-BE-34-179

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,6,13

switchport mode trunk

no ip address

speed 1000

duplex full

channel-group 2 mode active

end

CS-SWHC-0-2#sh run int po2

Building configuration...

Current configuration : 183 bytes

!

interface Port-channel2

description CS-BE-34-179

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,6,13

switchport mode trunk

no ip address

end

3120X:

interface GigabitEthernet1/0/23

switchport mode trunk

speed 1000

duplex full

channel-group 1 mode active

interface GigabitEthernet3/0/23

switchport mode trunk

!I shut down the port as part of troubleshooting procedure

shutdown

speed 1000

duplex full

channel-group 1 mode active

interface Port-channel1

description PO to 6513-1

switchport mode trunk

We have too many VLAN's so I'm only copying one of them:

6513:

CS-SWHC-0-2#sh spanning-tree

VLAN0001

Spanning tree enabled protocol rstp

Root ID Priority 24577

Address 0009.1228.6e40

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24577 (priority 24576 sys-id-ext 1)

Address 0009.1228.6e40

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi1/2 Desg FWD 4 128.2 P2p Peer(STP)

3120X:

VLAN0001

Spanning tree enabled protocol rstp

Root ID Priority 49153

Address 0021.a1b7.b600

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 49153 (priority 49152 sys-id-ext 1)

Address 0021.a1b7.b600

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

UplinkFast enabled but inactive in rapid-pvst mode

Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Po1 Desg FWD 3004 128.488 P2p

Correct Answer
Jon Marshall Sat, 07/05/2008 - 23:32

You are only allowing vlans 3,6 & 13 across the trunk link from the 6500 switches. So if you look at the spanning-tree for these vlans on the 3120's they should be reporting the 6500's as STP root.

But for all the other vlans by not allowing them across the trunk you stop STP running across the trunk for those vlans so both will think they are root.

Solution depends on what you are trying to achieve

1) By only allowing 3,6,13 on the link it sounds like these are the only vlans present on the 3120 switches. If so you could make the 3120 switches VTP transparent and only have those vlans created on the switches.

2) Rather than using allowed you can prune the trunk link. If you prune then STP will still run across the link for the pruned vlans so the 3120's should see the 6500 switches as root for all vlans. Be careful not to use a list of vlans with the prune command though as this has the same effect as using the "allowed" keyword ie. it stops STP for vlans not in the list.

Jon

Giuseppe Larosa Sun, 07/06/2008 - 02:58

Hello,

what is important is what happens for the vlans permitted on the trunk

do a sh spanning-tree vlan 3

sh spanning-tree vlan vlan 6

sh spanning-tree vlan vlan 13

the root bridge for these should be the 6513 if using rapid per vlan STP.

If so it is ok.

If using a different type of STP like MST you may need to allow also vlan 1 on the trunk, because in this case BPDUs are not sent out on every vlan. The IST (spanning tree instance 0) will carry info for all the defined instances inside its BDPUs.

hope to help

Giuseppe

Actions

This Discussion