qos on 2651

Answered Question
Jul 5th, 2008
User Badges:
  • Bronze, 100 points or more

as a practice I'm trying to setup qos on my home router but so far it hasn't worked


heres what I've tried so far

------------------------------

class-map match-all Xbox360

match ip dscp 8


policy-map Xbox360

class Xbox360

priority 208 310


interface fastethernet 0/0

service-policy output Xbox360



class-map match-all game

match access-group 101


policy-map game

class game

set ip dscp 8


access-list 101 permit ip host 10.2.0.11 any

access-list 101 deny ip any any


interface fastethernet 0/1.3

service-policy input game

---------------------------

I tried wireshark on the 360 to see if it had any dscp values coming from it and it didn't


any ideas?

could my 2924M-XL switch be interfering with dscp values?

Correct Answer by n.nandrekar about 8 years 8 months ago

hi!

you can check with the "sh policy-map interface fa0/1.3" to see if the counters for class-map game is increasing and packets are getting marked.

Also a 2924 switch could interfere and reset the dscp values to 0. Please see if the "mls qos trust dscp" is configured on the 2924 ports.


Regards,

Niranjan

(pls rate the post if helpful)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (9 ratings)
Loading.
Correct Answer
n.nandrekar Sun, 07/06/2008 - 10:00
User Badges:
  • Silver, 250 points or more

hi!

you can check with the "sh policy-map interface fa0/1.3" to see if the counters for class-map game is increasing and packets are getting marked.

Also a 2924 switch could interfere and reset the dscp values to 0. Please see if the "mls qos trust dscp" is configured on the 2924 ports.


Regards,

Niranjan

(pls rate the post if helpful)

is66rlhntadm Sun, 07/06/2008 - 10:54
User Badges:
  • Bronze, 100 points or more

the 2924m-xl doesn't have the mls command


thats why I was hopeing to reset the dscp on all packets from 10.2.0.11


the 2924m-xl can only go up to 12.0 IOS

the 2651 can only go up to 12.3 ios both are at the latest IOS release that they can

is66rlhntadm Sun, 07/06/2008 - 10:59
User Badges:
  • Bronze, 100 points or more

I just re-entered the config and did the "sh policy-map interface fa0/1.3" and the packet count is going up


what is a good priority to set?

n.nandrekar Sun, 07/06/2008 - 11:26
User Badges:
  • Silver, 250 points or more

Hi!

So that means that the traffic is getting marked... there must be something which is resetting the DSCP.

The priority reserves the bandwidth for that traffic class. So it must be set to any value that wyou want to guarantee to the traffic.


Regards,

Niranjan

n.nandrekar Sun, 07/06/2008 - 11:28
User Badges:
  • Silver, 250 points or more

Can you SPAN (monitor session) the egress port and run wireshark on the probe to see if the traffic is sent as marked? This will point towards the 2900 for any resets.


Regards,

Niranjan


is66rlhntadm Sun, 07/06/2008 - 11:58
User Badges:
  • Bronze, 100 points or more

I think its working now


the link from router to switch is a trunk and the 2924 won't do port monitor on a trunk


I don't think there would be much point in seeing the return data


thanks

Actions

This Discussion