Telnet to Switch Issue

Unanswered Question
Jul 6th, 2008

I have two Switches A and B. Currently, the fibre is connected to only Switch A which is live.

Say now i bring in a new Switch B. I try to trunk the fastethernet to Switch A and it works. I am able to access internet through Switch B.

1) However, i cannot telnet to Switch B. I have already configure a telnet password. What could went wrong?

2) I tried to telnet to Switch A but i could not type in the username and password.

The moment i type in, it will display:

"Username: Connection closed by foreign host."

Why it will affect Switch A connection?

3)Lastly, i choose to connect from fastethernet interface to the other fasterthernet interface. Both are 3560 series switches.

Is it because i did not use a GigaStack module to connect to each other or fasterthernet interface is not allowed to connected to another fasterthernet interface?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
joseph.derrick Sun, 07/06/2008 - 19:25


Have you configured a management ip address on switch B ?

Can you telnet to switch A if your host is directly connected to its ports and not through switch B ?



kian_hong2000 Sun, 07/06/2008 - 19:34

Both Switch A and B have a different management IP and are within the same subnet and domain name.

I am able to telnet to Switch A. However, i cannot proceed after i telnet in. All the hosts are connected to Switch A and B and are able to access internet.

This issue is i cannot remotely monitor both the swithes after i add in a new switch B.

Rick Morris Mon, 07/07/2008 - 06:49

to make sure I understand.

Switch A

vlan 1 (management)

IP address (example only)

Switch B

vlan 1 (management)

IP address (example only)

on switch A do a sh cd neigh detail and see if switch A can see switch B

kian_hong2000 Mon, 07/07/2008 - 18:03

I think it is a seperate issue. I take out the connection from Switch B to Switch A.

However, Switch A stills get the same error.


User Access Verification

Username: Connection closed by foreign host.


What causes it to be disconnect?

kian_hong2000 Mon, 07/07/2008 - 23:46

I have found out the root cause.

I have type in the same IP address in Switch B. That is the reason why i telnet to Switch A, it always disconnect itself. It is a human error.

I have tried to connected through fasterthernet interfaces between two switches using cross cable and it works.


This Discussion