Receiving FAX with ATA

Answered Question
Jul 7th, 2008

Hello, we have a CCM cluster (5.1), with GW 2821 (VWIC2-1MFT-T1/E1). The voice calls are working great, but a fax connected through an ATA can't receive anything because it doesn't recognize as a data transmission. However it can send fax correctly.

The ATA has the las firmware (SCCP 3.2.3), and is registered in the CCM.

Any idea?


I have this problem too.
0 votes
Correct Answer by Zin.Karzazi about 8 years 3 months ago

Your ATA config seems fine. Please Add the following under the voip Dial peer:

fax rate disable

modem passthrough nse codec g711ulaw

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Paolo Bevilacqua Mon, 07/07/2008 - 01:28


Have you configured

"network-clock-select 1 E1 x/y/z" ?

Without that, fax cannot work correctly.

victorgarciaternero Mon, 07/07/2008 - 01:58

Hola Paolo, I have configured the command "network-clock-select 1 E1 0/0/0" and there is no difference. The disconnect value is 17 (user busy), but the fax receive the call as a voice call.


Paolo Bevilacqua Mon, 07/07/2008 - 02:03


Fax calls are voice calls. I do not understand why "user busy is returned". If you call from a phone, do you hear the fax answering and the fax tones ?

victorgarciaternero Mon, 07/07/2008 - 02:13

If I call from a phone I hear a tone during few msec. and after only silence. The call is disconnected (cause value 16) after 40 sec. aprox.


Paolo Bevilacqua Mon, 07/07/2008 - 02:38

Check "debug isdn q931" with "term mon". There you should see that a fax call is the same as a voice call.

The only difference might be the bearer capability for fax calls to be "3.1 KHz" instead of "Speech". That should not prevent the call to be routed to the ATA.

victorgarciaternero Mon, 07/07/2008 - 02:51

Here is the output of debug isdn q931 for a fax connection:

*Jul 7 10:48:23.989: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x6300

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA1838F

Preferred, Channel 15

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band inf


Calling Party Number i = 0x2183, 'sssssssss'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, 'ddddddddd'

Plan:ISDN, Type:National

Sending Complete

*Jul 7 10:48:23.997: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x


Channel ID i = 0xA9838F

Exclusive, Channel 15

*Jul 7 10:48:24.169: ISDN Se0/0/0:15 Q931: TX -> ALERTING pd = 8 callref = 0xE


*Jul 7 10:48:30.669: ISDN Se0/0/0:15 Q931: TX -> CONNECT pd = 8 callref = 0xE3


*Jul 7 10:48:30.713: ISDN Se0/0/0:15 Q931: RX <- CONNECT_ACK pd = 8 callref =


*Jul 7 10:48:30.713: %ISDN-6-CONNECT: Interface Serial0/0/0:14 is now connected

to sssssssss N/A

*Jul 7 10:48:33.601: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/

0:14, changed state to up

*Jul 7 10:49:19.289: %ISDN-6-DISCONNECT: Interface Serial0/0/0:14 disconnected

from sssssssss , call lasted 48 seconds

*Jul 7 10:49:19.289: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0


Cause i = 0x8090 - Normal call clearing

*Jul 7 10:49:19.333: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x63


*Jul 7 10:49:19.337: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref =


Everything seems correctly, but it is not working. The fax report says that the incoming call is a voice call and it doesn't print anything.


Paolo Bevilacqua Mon, 07/07/2008 - 02:55

Can you try a different fax machine ?

The next step would be to check the ATA setting as indicated in the "troubleshooting ATA Fax" document.

The further following step would be converting the ATA to H.323.

victorgarciaternero Mon, 07/07/2008 - 03:09

Hello, the gateway is configured wit H323 protocol (not controlled by the CCM). So an incoming call goes to the E1 card (in the 2821 gw), it matchs a DID dial-peer (h323) to the CCM, the CCM makes a translation (from public number to an extension) and then it matchs the internal extension of the fax (in ATA, which is registered as SCCP phone).

This is the ATA config:

LBRCodec 3

AudioMode 0x00350035

ConnectMode 0x90000400

FXSInputLevel -1

FXSOutputLevel -4

The dial-peer:

dial-peer voice 2 voip

description Llamadas entrantes del PRIMARIO

destination-pattern xxxxxxxxx

session target ipv4:yyyyyyyyy


dial-peer voice 3 pots

incoming called-number xxxxxxxxx



And the translation pattern in CCM:

Translation Pattern: xxxxxxxxx

Called Party Transform Mask: 1828


Correct Answer
Zin.Karzazi Mon, 07/07/2008 - 03:25

Your ATA config seems fine. Please Add the following under the voip Dial peer:

fax rate disable

modem passthrough nse codec g711ulaw

victorgarciaternero Mon, 07/14/2008 - 03:11

Hi, although it seems working fine, many times we receive the fax incomplete. Usually it stops at the middle of the fax.


Paolo Bevilacqua Mon, 07/14/2008 - 03:16

Hi, check "show controllers E1", it must have 0 errors, and 0 slips for fax to work reliably.

Steellllllllll0 Thu, 07/17/2008 - 01:55

Hi Guys,

I am having the same problem as this posting only difference being i am using 3 bri`s instead of an E1.i have added the network clock 1 BRI0/1/1 but still no change....

I have checked my ATA settings, added the fax rate disable and the modem passthrough nse command to the dial-peers but still no difference.Using H.323.

Any Ideas ??

Steellllllllll0 Wed, 07/30/2008 - 02:05

Hi Guys,

I have attached some output for this issue which i have still not been able to resolve :

Anything else i can check please let me know...

Michael Hanes Thu, 07/31/2008 - 19:11

Can you post a packet capture of the failed call and let us know the IP of the voice gateway and ATA?



Steellllllllll0 Fri, 08/01/2008 - 00:56


For security reasons i will not be able to provide the ip addresses for these devices. Is there anything else i can try or look at ??

Michael Hanes Fri, 08/01/2008 - 05:54

A packet capture is the quickest way to get to the root of the issue. Because you are doing NSE-based passthrough your troubleshooting options are more limited as compared to fax relay where the helpful command "debug fax relay t30 all-level-1" is available. You confirmed earlier in the thread that you have the ATA and voice gateway configured correctly. Most of the time, problems such as yours are config issues. Can you post your configs so that we can double check your setup?

There are debugs on the ATA using prserv that will allow you to confirm the NSE switchover. You can also use the command "debug voip hpi" along with "no debug voip hpi stats" on the voice gateway (warning - this is an intensive debug so make sure you follow the appropriate debugging procedures before enabling this). The HPI debug can be difficult to decode but it shows IOS programming the DSP for passthrough as well as the NSE switchover messages. Additionally, you can repeat the commands "show call active voice brief" and "show voice call " as the passthrough call is occurring to check the DSP stats for issues. Unfortunately, there is not much else that you are going to be able to get from these devices for a passthrough call.

The packet capture is your best piece of troubleshooting information as it shows the NSE switchover messages, confirms a successful transition to G.711, shows network impairments that could be harming the call, and additionally you can extract the G.711 audio from the RTP stream and then figure out from the fax tones if there is a problem in the T.30 negotiation.

I understand your reluctance in posting packet captures and IP addresses on a forum such as this. You may feel more comfortable working directly with Cisco TAC on this type of issue. I hope the troubleshooting information above helps.




This Discussion