CUBE and Transcoding

Answered Question
Jul 7th, 2008
User Badges:

Hello all,


I wanted to configure a CUBE to do transcoding on the box so I put together this config from various docs on CCO:


interface GigabitEthernet0/1

ip address 10.212.1.7 255.255.255.0

duplex full

speed 100

no mop enabled

h323-gateway voip interface

!

voice-card 0

dspfarm

dsp services dspfarm

!

sccp local GigabitEthernet0/1

sccp ccm 10.212.1.7 identifier 1 priority 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2 register XCODE123456

keepalive retries 1

keepalive timeout 10

switchover method immediate

switchback method immediate

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

maximum sessions 10

associate application SCCP

!

!

telephony-service

ip source-address 10.212.1.7 port 2000

sdspfarm units 1

sdspfarm transcode sessions 10

sdspfarm tag 1 XCODE123456

network-locale GB

create cnf-files version-stamp 7960 Jul 07 2008 14:42:17

max-conferences 8 gain -6

transfer-system full-consult


The problem is that the transcoder is not registering. Here is the Show SCCP output:-



cube-1#sh sccp

SCCP Admin State: UP

Gateway IP Address: 10.212.1.7, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.212.1.7, Port Number: 2000

Priority: 1, Version: 3.1, Identifier: 1


Transcoding Oper State: ACTIVE_IN_PROGRESS - Cause Code: TCP_CONN_ERROR

Active Call Manager: NONE

TCP Link Status: NOT_CONNECTED, Profile Identifier: 2

Reported Max Streams: 20, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30


Any ideas?


Correct Answer by Ayodeji Okanlawon about 8 years 8 months ago

Here is a working config that used version 4.0....Though this was used for conferencing, I believe the config is similar...

You need to use a version higher than 3.3...Below is the config

!

sccp local FastEthernet0/0

sccp ccm 10.66.75.79 identifier 1 version 4.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2 register confprof2

!

dspfarm profile 2 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 8

conference-join custom-cptone jointone

conference-leave custom-cptone leavetone

associate application SCCP

no shutdown <----- need to manually add the no shut after the profile has been created

!




!

telephony-service

sdspfarm conference mute-on 111 mute-off 222

sdspfarm units 3

sdspfarm unregister force

sdspfarm tag 2 confprof2


Correct Answer by pcameron about 8 years 8 months ago

To do the local registration of transcoding for CUBE/IP2IP gateway, you need to register to the local IP address using SCCP version 5 as previously advised. The other critical setting you need is to define a 'max-dn' and a 'max-ephone' under the telephony service, otherwise the registration won't work.


Here is a working config (IOS is 12.4.15T5). It may take around 60 seconds for the transcoder to register.



!

interface fastEthernet0/0

ip address 10.66.75.13 255.255.255.128

!

voice-card 0

dspfarm

dsp services dspfarm

!

sccp local fastEthernet0/0

sccp ccm 10.66.75.13 identifier 1 version 5.0.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2 register XCODE123456

keepalive retries 1

keepalive timeout 10

switchover method immediate

switchback method immediate

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

maximum sessions 10

associate application SCCP

no shutdown

!

!

telephony-service

ip source-address 10.66.75.13 port 2000

sdspfarm units 1

sdspfarm transcode sessions 2

sdspfarm tag 1 XCODE123456

max-dn 2

max-ephone 1

create cnf







RTA-Test#sh sccp

SCCP Admin State: UP

Gateway IP Address: 10.66.75.13, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.66.75.13, Port Number: 2000

Priority: N/A, Version: 5.0.1, Identifier: 1


Transcoding Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 10.66.75.13, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 2

Reported Max Streams: 20, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30


RTA-Test#


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Ayodeji Okanlawon Mon, 07/07/2008 - 08:00
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

The version command is missing on your sccp config...Depending on the callmanager version you are using..if you are using ccm 6 use ver 5.0.1 or do version ? to see the versions supported by your voice gateway


example below:


sccp local GigabitEthernet0/0.33

sccp ccm 10.33.2.20 identifier 11 version 5.0.1

sccp ccm 10.33.2.21 identifier 10 version 5.0.1

sccp

csg-admin Tue, 07/08/2008 - 00:12
User Badges:

I think you may have missed my point. I want to do transcoding on the box, in otherwords the transcoding service needs to register with the telephony-service on the box not with a CUCM5 or 6.


I've added this line:-


sccp ccm 10.212.1.7 identifier 1 priority 1 version 3.3


but transcoding is still down. Incidentially, I can't go any higher that 4.1 with the version command. I'm a 2821 running c2800nm-adventerprisek9_ivs-mz.124-19b.bin.


?

ashok_boin Tue, 07/08/2008 - 03:17
User Badges:
  • Bronze, 100 points or more

Can you send debugs of the following? Hope it's not yet into production network.


"debug dspfarm" & "debug sccp" and then do "no dspfarm" & "dspfarm" to get registration details from beginning again.


Regards...

-Ashok.

csg-admin Tue, 07/08/2008 - 03:29
User Badges:

Thanks for the reply.


I am unable to perform a debug dspfarm - its not a valid command in this IOS. Attached is a debug sccp.


Let me know what you find?



Correct Answer
pcameron Tue, 07/08/2008 - 04:09
User Badges:
  • Cisco Employee,

To do the local registration of transcoding for CUBE/IP2IP gateway, you need to register to the local IP address using SCCP version 5 as previously advised. The other critical setting you need is to define a 'max-dn' and a 'max-ephone' under the telephony service, otherwise the registration won't work.


Here is a working config (IOS is 12.4.15T5). It may take around 60 seconds for the transcoder to register.



!

interface fastEthernet0/0

ip address 10.66.75.13 255.255.255.128

!

voice-card 0

dspfarm

dsp services dspfarm

!

sccp local fastEthernet0/0

sccp ccm 10.66.75.13 identifier 1 version 5.0.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2 register XCODE123456

keepalive retries 1

keepalive timeout 10

switchover method immediate

switchback method immediate

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

maximum sessions 10

associate application SCCP

no shutdown

!

!

telephony-service

ip source-address 10.66.75.13 port 2000

sdspfarm units 1

sdspfarm transcode sessions 2

sdspfarm tag 1 XCODE123456

max-dn 2

max-ephone 1

create cnf







RTA-Test#sh sccp

SCCP Admin State: UP

Gateway IP Address: 10.66.75.13, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.66.75.13, Port Number: 2000

Priority: N/A, Version: 5.0.1, Identifier: 1


Transcoding Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 10.66.75.13, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 2

Reported Max Streams: 20, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30


RTA-Test#


Correct Answer
Ayodeji Okanlawon Tue, 07/08/2008 - 05:06
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Here is a working config that used version 4.0....Though this was used for conferencing, I believe the config is similar...

You need to use a version higher than 3.3...Below is the config

!

sccp local FastEthernet0/0

sccp ccm 10.66.75.79 identifier 1 version 4.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 2 register confprof2

!

dspfarm profile 2 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 8

conference-join custom-cptone jointone

conference-leave custom-cptone leavetone

associate application SCCP

no shutdown <----- need to manually add the no shut after the profile has been created

!




!

telephony-service

sdspfarm conference mute-on 111 mute-off 222

sdspfarm units 3

sdspfarm unregister force

sdspfarm tag 2 confprof2


csg-admin Tue, 07/08/2008 - 06:42
User Badges:

Thanks all. I downgraded from 12.4-19b to 12.4-15(T5) and the keyword 5.0.1 appeared.


Thanks for your help, transcoders are now registered.

Ayodeji Okanlawon Tue, 07/08/2008 - 08:17
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

csg,


No rating for all the work the guys put in here for you!!!!

csg-admin Wed, 07/09/2008 - 00:04
User Badges:

Of course you deserve a rating - the delay was my overjoyment in getting this working - thanks very much! :)

Actions

This Discussion