Duplex problem

Unanswered Question
Jul 7th, 2008

I have connected cisco 7500 router with a cisco switch 2950. The problem i am facing is that we can't running the link with full duplex . The cisco switch is supporting 100 Mbps, 100Base TX and the Router(7500) FastEthernet support 100Mbps, 100Base TX/FX

When I enable the link as full duplex in router the Switch interface(the connected port ) is goes down.(switch port already enabled as full duplex)

But when i connect the same switch with another

Cisco 3745 router , it is working as full duplex link.

It may pointed that the Cisco 7500 router has no "auto" negotiable option as in cisco 3745 router has

"auto" negotiable option( full/half) there.

pls help me.

pls help me.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
owillins Fri, 07/11/2008 - 06:18

Be careful that some modes (on, nonegotiate, off) explicitly specify in which state the port will end up. A bad configuration can lead to a dangerous, inconsistent state in which one side is trunking and the other side is not.

gpulos Fri, 07/11/2008 - 07:10

It is a good rule of thumb to not allow routers, switches, servers to use AUTO speed/duplex negotiation.

(specifically for these types of weird problems your facing..among others)

Set your 7500 to 100mbs/Full Duplex statically with the interface commands:

speed 100

duplex full

As you already have your switch at 100/Full statically, you should set the router statically as well.


This Discussion