%CDP-4-DUPLEX_MISMATCH: duplex mismatch between 7206VXR to CAT 3750

Unanswered Question
Jul 7th, 2008
User Badges:

My remote site customer has a Cisco 7206VXR router (IOS 12.3(14)T3) connected to a Cisco 3750 switch (IOS 12.2(25)SEB4) seeing the following error:

Jul 7 14:32:18: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet6/0 (not half duplex), with 4IP_ORU_3750_1 GigabitEthernet2/0/1 (half duplex)

Router interface:

Interface FastEthernet6/0

description 4IRV_ORU_3750_1 PORT 22

ip address n.n.n.n 255.255.255.0

no ip redirects

ip pim sparse-mode

ip cgmp

no ip mroute-cache

duplex full

end

Interface FastEthernet2/0

description 4IRV_ORU_3750_1 PORT 22

ip address n.n.n.n 255.255.255.0

no ip redirects

ip pim sparse-mode

ip cgmp

no ip mroute-cache

duplex full

end

On the switch side:

interface GigabitEthernet2/0/1

description ORCPA1 F6/0

duplex full

speed 100

If you do a sh int fa6/0:

FastEthernet6/0 is up, line protocol is up

Hardware is DEC21140, address is 0002.fcb1.a8a8 (bia 0002.fcb1.a8a8)

Description: 4IRV_ORU_2950_1 PORT 22

Internet address is n.n.n.n/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output 00:00:00, output hang never

Last clearing of "show interface" counters 37w6d

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 165000 bits/sec, 57 packets/sec

5 minute output rate 221000 bits/sec, 95 packets/sec

534569097 packets input, 1623728571 bytes

Received 21581395 broadcasts, 0 runts, 642 giants, 0 throttles

276922 input errors, 276922 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

1317438747 packets output, 1448949510 bytes, 0 underruns

YOU WILL NOTICE INTERFACE IS SET TO 100 FULL, HOWEVER ON THE SWITCH SIDE THE INTERFACE IS SEEN AS FOLLOWS:

GigabitEthernet2/0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0015.f937.8601 (bia 0015.f937.8601)

Description: ORCPA2 F6/0

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:05, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 214000 bits/sec, 69 packets/sec

5 minute output rate 100000 bits/sec, 34 packets/sec

219076587 packets input, 2215591721 bytes, 0 no buffer

Received 2151817 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 2137942 multicast, 0 pause input

0 input packets with dribble condition detected

61422762 packets output, 140950304 bytes, 0 underruns

0 output errors, 79030 collisions, 1 interface resets

0 babbles, 279939 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

PLEASE NOTE: ALTHOUGH THE INTERFACE FOR THE SWITCH INTERFACE SPECIFIES DUPLEX FULL SPEED 100...THE INTERFACE IS SET TO HALF/100 THUS CAUSING THE MISMATCH...WE ARE UNSURE WHY THIS IS OCCURRING...

No changes to the routers and the 3750 was reloaded about a month ago.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
a.alekseev Mon, 07/07/2008 - 13:01
User Badges:
  • Gold, 750 points or more

set speed and duplex manually on both sides or set it "auto"

rlortiz Mon, 07/07/2008 - 13:18
User Badges:

I thought the configs I have shown are manually set for duplex full on all interfaces involved. The speed cannot be set on the 7206VXR IOS version we have, but can on the switch, which was done. The show interface on the router does show the correct speed and duplex, but not on the switch.



a.alekseev Mon, 07/07/2008 - 13:24
User Badges:
  • Gold, 750 points or more

on the switch

sh run int GigabitEthernet2/0/1

rlortiz Mon, 07/07/2008 - 13:33
User Badges:

The initial GigabitEthernet2/0/1 is from a very recent "show tech". I don't have access to do show run int GigabitEthernet2/0/1, at this time.


I could have my customer set all the involved interface to "auto" and see if it does fix the problem. I am just a bit confused when you state to manually set the speed to 100/full when that was done in the first place.


Thanks for the input..

robdog01 Mon, 07/07/2008 - 13:25
User Badges:

I have seen this situation before and usually it requires setting either both to 100/full or both to auto.


Not sure if it's required, but it's helped for me... do a shut for a few seconds (10+ seconds or so), then a no shut.



glen.grant Mon, 07/07/2008 - 13:35
User Badges:
  • Purple, 4500 points or more

Are you sure you are looking at the correct ports on the devices ? Notice the following ,


interface GigabitEthernet2/0/1

description ORCPA1 F6/0



GigabitEthernet2/0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0015.f937.8601 (bia 0015.f937.8601)

Description: ORCPA2 F6/0


Notice the description field is different is this a misprint? The description field should be the same as it is taken right from the config . Can you post a "show cdp neighbor detail"




rlortiz Mon, 07/07/2008 - 13:46
User Badges:

Glen,


There are 2 routers involved that are seeing the same problem. I just gave one router's config and pasted the incorrect router's "show tech" output for the GigabitEthernet2/0/1.


The config is the same:


interface GigabitEthernet2/0/1

description ORCPA2 F6/0

duplex full

speed 100


I don't have access to the switch or router, at this time and will do the "show cdp neighbor detail" early tomorrow morning.


Thanks..

pthaynes Mon, 07/07/2008 - 20:08
User Badges:

I have seen the same issue before - if you hard set the speed and duplex on a 3750 or some of the newer 3560s you will sometimes get them autonegotiating to half duplex. I have no idea what triggers it off. The solution has always been to set both ends of the link to auto speed and auto duplex.


It doesn't seem to be limited to the type of device at the other end either - I have seen the negotiation (when both ends are hard set to a speed and duplex) happen between the switch models mentioned and other switches, pcs and servers. The end hosts have been running Windows (various flavours) and Linux. So it just seems that those switches have some trouble when you tell then NOT to autonegotiate. It also seems to happen at varying times - sometimes immediately and others after a few days or weeks of error free running.


Hope this helps,


Peter

rlortiz Tue, 07/08/2008 - 07:31
User Badges:

I have told my remote site customer to set both sides to auto duplex and speed, but won't be able to do it until off hours.



Here is the "show cdp neighbor detail" from the switch:


sh cdp nei det

-------------------------

Device ID: DC2GATE1

Entry address(es):

IP address: n.n.n.n

Platform: cisco 7206, Capabilities: Router

Interface: GigabitEthernet1/0/2, Port ID (outgoing port): FastEthernet5/0

Holdtime : 165 sec


Version :

Cisco Internetwork Operating System Software

IOS (tm) 7200 Software (C7200-JS-M), Version 12.2(10b), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Thu 11-Jul-02 13:46 by pwade


advertisement version: 2

Duplex: full (Mismatch)

Management address(es):


-------------------------

Device ID: orcpa2

Entry address(es):

IP address: n.n.n.n

Platform: Cisco 7206VXR, Capabilities: Router Source-Route-Bridge

Interface: GigabitEthernet2/0/1, Port ID (outgoing port): FastEthernet6/0

Holdtime : 133 sec


Version :

Cisco IOS Software, 7200 Software (C7200-JS-M), Version 12.3(14)T3, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Tue 12-Jul-05 01:47 by ccai


advertisement version: 2

Duplex: full (Mismatch)

Management address(es):


-------------------------

Device ID: ORCPA1

Entry address(es):

IP address: n.n.n.n

Platform: Cisco 7206VXR, Capabilities: Router Source-Route-Bridge

Interface: GigabitEthernet1/0/1, Port ID (outgoing port): FastEthernet2/0

Holdtime : 176 sec


Version :

Cisco IOS Software, 7200 Software (C7200-JS-M), Version 12.3(14)T3, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Tue 12-Jul-05 01:47 by ccai


advertisement version: 2

Duplex: full (Mismatch)

Management address(es):


Here is the show cdp neig detail from one of the routers:


sh cdp nei det

-------------------------

Device ID: 4IP_ORU_3750_1

Entry address(es):

IP address: n.n.n.n

Platform: cisco WS-C3750G-24TS-1U, Capabilities: Switch IGMP

Interface: FastEthernet6/0, Port ID (outgoing port): GigabitEthernet2/0/1

Holdtime : 170 sec


Version :

Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(25)SEB4, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Tue 30-Aug-05 15:47 by yenanh


advertisement version: 2

Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27, value=00000000FFFFFFFF010221FF0000000000000015F9378600FF0000

VTP Management Domain: '4IP_ORU'

Native VLAN: 1

Duplex: half


-------------------------

Device ID: TLCOR1

Entry address(es):

IP address: n.n.n.n

Platform: Cisco 3845, Capabilities: Router Switch IGMP

Interface: Serial5/0, Port ID (outgoing port): Serial1/0

Holdtime : 170 sec


Version :

Cisco IOS Software, 3800 Software (C3845-ENTSERVICES-M), Version 12.4(3a), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Fri 30-Sep-05 12:45 by hqluong


advertisement version: 2

VTP Management Domain: ''


orcpa2#


4IP_ORU_3750_1#

Kevin Dorrell Tue, 07/08/2008 - 07:37
User Badges:
  • Green, 3000 points or more

Sorry, I have jumped into this thread late. But you say ".. remote site ..." and that triggers alarm bells.


How are these two devices connected? Are they connected via some service provider? If so, they may not be as directly connected as you think they are. If that is the case, then the speed/duplex settings are more about your connections to the service provider than about the end-to-end connection between your two devices.


Could you give a little more detail please?


Kevin Dorrell

Luxembourg

rlortiz Tue, 07/08/2008 - 07:41
User Badges:

Kevin,


Sorry to have misled you, but "remote site" means that I am not local to the site. The routers are directly connected to the switch. There is no service provider involved.

eparamo Wed, 09/01/2010 - 07:45
User Badges:

Hi,


I have came accros that issue on 3560G platform. After several tests I found out that 12.2(25)SEB4 doesn´t work fine with duplex hardcoded when the switch boot up. It behaves like it was configured as "duplex auto" instead of "duplex full". Just try to replace that IOS. I've replaced it with 12.2(44)SE2 and it works fine.


Regards,

Eduardo.


P.S: IOS 12.2(25)SEB4 on 3560 platforms works fine , but not on 3560G platforms.

paul.matthews Wed, 09/01/2010 - 11:09
User Badges:
  • Silver, 250 points or more

I cannot recall exact versions, but there were some versions of 3560/3750 code that had bugs that meant the configured speed/duplex settings were ignored after a reload, and auto was actually used. I am pretty certain the version you have is affected by those bugs.


To sort your problem you have two ways forwards. Set both ends to auto anyway, and they should negotiate 100/Full, or upgrade to a more cent version of software. There is a third option of both!


Given the age of your software, I woud suggest an upgrade may be in order anyway.


Paul.

Actions

This Discussion