DHCP not passing on Data VLAN for AP1231

Unanswered Question

I have a network that uses an AP 1231 for voice and data. On the Voice VLAN wireless phones or computers receive DHCP and all appropriate network info to enable Voice/Data. The Voice VLAN is 100 and the Data VLAN is 200.

On the router, a 2651XM - 12.3(14)T7, I can see bindings with appropriate MAC. The switch is a CE-500 and the port is configured for an AP.

On the AP I see the association with IP/MAC info.

When I select the Data VLAN on the wireless computer I see the bindings with IP and MAC but on the AP the IP is missing.

Here is a piece of the config

no ip dhcp use vrf connected

ip dhcp excluded-address 10.1.1.1 10.1.1.100

ip dhcp excluded-address 20.3.9.1 20.3.9.100

.

.

.

ip dhcp pool Cisco-Voice

import all

network 10.1.1.0 255.255.255.128

option 150 ip 10.1.1.10

default-router 10.1.1.1

dns-server 24.92.226.12

!

ip dhcp pool Data

import all

network 20.3.9.0 255.255.255.128

dns-server 24.92.226.12

default-router 20.3.9.1

.

.

.

interface FastEthernet0/0.100

description Voice subnet 10.1.1.0 for Phones

encapsulation dot1Q 100

ip address 10.1.1.1 255.255.255.0

no snmp trap link-status

service-policy output output-L3-to-L2

!

interface FastEthernet0/0.200

description native subnet 20.3.9.0 for Data

encapsulation dot1Q 200

ip address 20.3.9.1 255.255.255.0

ip helper-address 10.1.1.10

ip helper-address 30.3.9.10

no ip redirects

no snmp trap link-status

service-policy output output-L3-to-L2

Does anyone have an idea what I missed, what I may need to do to resolve this problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Mon, 07/07/2008 - 19:04

Try removing the ip helper-address on the interface FastEthernet0/0.200. Since you have DHCP configured on the above device, you don't need this:

ip helper-address 10.1.1.10

Also is there a reason you have on the dhcp pool a mask of /25 and on the interface you have a mask of /24?

ip helper-address 30.3.9.10

I removed IP Helper and adjusted the scope of addresses. This did not resolve the problem. I still see the address increment in the pool on the router and the association of the wireless computer on the AP but no address appears on the AP and also not on the computer. All I need to do is allow the computer to associate to the phone VLAN and everything is good.

I do see the timeout IP of 169.... displayed in the AP Association window for the wireless computer.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode