Ciscoworks & the NME-16ES-1G EtherSwitch module

Unanswered Question
Jul 8th, 2008
User Badges:

Howdy Folks,


I have a 2811 fitted with an NME-16ES-1G ether switch module and I would like to manage it using LMS 2.6.


I require the module be managed by a specific IP address, namely the IP address associated with VLAN 1.


The problem is that whenever the switch module responds to polls from CiscoWorks, it responds with the interface IP address closest to the CiscoWorks server ... which in this case is the IP associated with the internal interface GigabitEthernet1/0/2.


Sample config below:


<snip>

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

!

interface GigabitEthernet1/0/2

no switchport

ip address 192.168.201.254 255.255.255.252

!

interface Vlan1

ip address 192.168.9.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 GigabitEthernet1/0/2

ip route 192.168.9.2 255.255.255.255 GigabitEthernet1/0/2

!

<snip>


So at the moment the module responds using IP 192.168.201.254, where as I require it to respond with 192.168.9.1.


Is it possible to set the source IP address of this switch?


I can find nothing that tells me so ...


Many thanks in advance


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 07/08/2008 - 09:27
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This sounds like a bug. If you poll the switch as 192.168.9.1, it should respond from 192.168.1.9. Do you have a sniffer trace showing the conversation between LMS and this module?

paul1032777 Thu, 07/10/2008 - 02:13
User Badges:

Hi thanks for the response.


Unfortunately I do not have a trace at this stage and I am making an assumption here about the switching module responding with the IP of the interface closest to the LMS, but this is the only thing that makes sense.


The LMS is successfully managing other Cisco devices connected to the 192.168.9.0/24 VLAN via the EtherSwitch module.


I can attempt to get a trace but it won't happen for a little while as this issue exists on a customer's private network ...


thanks again,

paul


O

ahmedshoaib Thu, 07/10/2008 - 02:55
User Badges:
  • Silver, 250 points or more

Dear Paul;

Please use snmp-server trap-source {interface} - to specify the source interface for SNMP Traps.

e.g: (config) snmp-server trap-source F0/0

Regards;


paul1032777 Thu, 07/10/2008 - 03:06
User Badges:

Hello Ahmed,


Thanks for the response. I have this already as part of the configuration;


!

snmp-server trap-source Vlan1


where:


!

interface Vlan1

ip address 192.168.9.1 255.255.255.0


I figured that SNMP traps being generated by this device would be using this address ok but am not sure which address is being used when responding to queries from the LMS.


The device appears red and uncontactable in CiscoView ...


Joe Clarke Thu, 07/10/2008 - 06:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I haven't seen your switch's SNMP configuration, and I doubt that you're seeing the switch reply with a different IP (we should have taken care o those bugs a long time ago). The trace and a show run would really be the best thing for troubleshooting this.


If this information is too sensitive to post to an open forum, then please open a TAC service request.

paul1032777 Thu, 07/10/2008 - 06:46
User Badges:

thanks mate ... i can show the config but will not be able to get a trace until next week.


configuration below:


ES-Switch#sh run

Building configuration...


Current configuration : 1579 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ES-Switch

!

enable secret xxx

enable password whatever

!

no aaa new-model

vtp mode transparent

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet1/0/1

!

interface FastEthernet1/0/2

!

interface FastEthernet1/0/3

!

interface FastEthernet1/0/4

!

interface FastEthernet1/0/5

!

interface FastEthernet1/0/6

!

interface FastEthernet1/0/7

!

interface FastEthernet1/0/8

!

interface FastEthernet1/0/9

!

interface FastEthernet1/0/10

!

interface FastEthernet1/0/11

!

interface FastEthernet1/0/12

!

interface FastEthernet1/0/13

!

interface FastEthernet1/0/14

!

interface FastEthernet1/0/15

!

interface FastEthernet1/0/16

!

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

!

interface GigabitEthernet1/0/2

no switchport

ip address 192.168.201.254 255.255.255.252

!

interface Vlan1

ip address 192.168.9.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet1/0/2

ip route 192.168.9.2 255.255.255.255 GigabitEthernet1/0/2

ip http server

!

logging 192.168.4.125

snmp-server community read RO

snmp-server community write RW

snmp-server trap-source Vlan1

snmp-server host 192.168.4.125 whatever

!

control-plane

!

!

line con 0

line vty 0 4

password whatever

no login

line vty 5 15

no login

!

end


ES-Switch#

Actions

This Discussion