Cisco 871W and WCCP Issues

Unanswered Question
Jul 8th, 2008

Hi there, I have purchased and setup a lovely Cisco 871W unit with advanced IP services and I'm now attempting to sort out WCCP connected to Squid on it.

I have read multiple documents and I believe I have the first step complete.

The Squid cache is setup several hops away from the 871W unit which is on a remote site. I've setup the GRE tunnel between the devices and Squid and the Cisco unit can see each other.

The problem occurs that when I redirect the traffic, the source IP the Squid box receives is the private IP (before NAT is performed), this means the box can't do anything since this address isn't routeable to.

In short I believe I need the WCCP requests to come from the translated address of the client which is routeable to from the Squid server.

I've setup static NAT mappings (there are reasons rather than using pools) for each private IP which maps to the WAN IP. However WCCP doesn't seem to take this into account.

I've read CEF can cause this so I've disabled it, I've also followed some other information I found on Cisco using the 'exclude' WCCP command but none of them seem to get the packets to arrive from the translated address.

Any help would be greatly appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)


This Discussion