Cuspa.vbs wont execute

Unanswered Question
Jul 8th, 2008

I am trying to upgrade my Unity 4.2(1) and when I double-click the Cuspa.vbs file, nothing happens, at all. There are no application or system log reports, CSA is disabled. What might this be?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Christopher McAlpin Tue, 07/08/2008 - 10:49

If you are running CUSPA on Windows 2003, from a network location, you may need to add the network location to Internet Explorers Local intranet or Trusted Sites security zone.

IE --> Tools --> Internet Options --> Security

Local intranet or Trusted Sites

swensonj Tue, 07/08/2008 - 10:57

Hmm silly me, I forgot the rest of it.

I am running on a local session and it is Windows 2000 5.00.2195 sp4, Iexplore 6.0.28.

MS Script host says it is apparantly installed but I fear not working properly.

tsteger1 Tue, 07/08/2008 - 11:41

Try opening a command window and running:

wscript Cuspa.vbs

This should give you an indication if it is running and/or display any messages

You might need to run it in Cscript mode.

If so, run this in a command window.

cscript Cuspa.vbs


swensonj Tue, 07/08/2008 - 12:06

It does run, with no output. I stepped through it, this old debugger doesn't make it very easy to watch what happens to data in a process. Checking manually I see that it is not creating directories or copying files, then exiting on matching:

If IsDrvVolatile (Left(strScriptPath,2)) Then





tsteger1 Thu, 07/10/2008 - 13:38

The only other suggestion I can think of is to force cscript to run it.

There may be some commands incompatible with wscript (not having the script, I cannot say).

Have you tried running other scripts on this server or running this script on another server?



This Discussion