configuring 1861 FXS ports with SCCP

Unanswered Question
Jul 9th, 2008

Hi,

It's supported the configuration of a Cisco 1861 with a CCM 5.1 using SCCP to control its FXS ports?

On CCM 5.1 console it's available the 1861 as a GW and using SCCP. Then I've selected VIC3-4FXS/DID-SCCP on subunit 0 of the NM config.

For the 1861 config, I've used this link:

http://www.cisco.com/en/US/docs/ios/12_4t/12_4t2/ht1vg224.html

So the actual config is:

stcapp ccm-group 1

stcapp

stcapp call-control mode feature

voice-port 0/0/0

timeouts ringing infinity

caller-id enable

sccp local FastEthernet0/0

sccp ccm 20.13.1.240 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

dial-peer voice 200 pots

service stcapp

port 0/0/0

But if I debug the sccp, I receive a reject:

Jul 9 19:14:38.951: SCCP(AN1D45B95AA0000)rcvd RegisterRejectMessage

*Jul 9 19:14:38.951: sccp_appl_service_stop_timer: Stop 869A3CFC timer

*Jul 9 19:14:38.951: sccp_parse_control_msg: rcvd register rej, reason: Error: DB Config

So, it's supported?

TIA

Andres Pasten

Adexus S.A.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kelvin.blair Wed, 07/09/2008 - 20:14

One thing that stands out is your sccp ccm 20.13.1.240 line. By default the sccp version is CM 3.1. You need to specify 4.1 for 4.1 and later.

sccp ccm 20.13.1.240 identifier 1 version 4.1.

Everything else is straight forward.

andres.pasten Thu, 07/10/2008 - 09:02

Hi,

I've tried, but it's still rejected.

sccp local FastEthernet0/0

sccp ccm 20.13.1.240 identifier 1 version 4.1

debug:

*Jul 10 17:02:00.262: sccp_parse_control_msg: msg_ptr 8683E4F8, msg_len 36, msg_id 157

*Jul 10 17:02:00.262: sccp_parse_control_msg: glob_ccm->version 6ndebu

*Jul 10 17:02:00.262: SCCP(AN1D45B95AA0000)rcvd RegisterRejectMessage

*Jul 10 17:02:00.262: sccp_appl_service_stop_timer: Stop 869A3CFC timer

*Jul 10 17:02:00.262: sccp_parse_control_msg: rcvd register rej, reason: Error: DB Config

*Jul 10 17:02:00.262: sccp_initiate_ccm_connect_interval_timer: Start CCM connect interval timer for prof_id 0, appl_type 4

I've looked on the compatibility matrix, and appears supported since 6.1(1). Why it appears available to config?

TIA

Andres Pasten

Adexus S.A.

Ayodeji oladipo... Thu, 07/10/2008 - 09:25

Hi,

I have configured this with CCM6.1 and I believe its supported with CCM5.1.3...

In your module slot 0, you should select NM-4VWIC-MBRD. This is the option I used with CCM6 and its the one I see with my CCM5.1.3 server right now..

andres.pasten Thu, 07/10/2008 - 11:01

Hi,

Yes, I've on module slot 0 selected NM-4VWIC-MBRD, and on subunit 0 selected VIC3-4FXS/DID-SCCP.

Then the port is configured as POTS.

The CCM is 5.1(3), so it you have it running please let me know.

TIA

Andres Pasten

Adexus S.A.

andres.pasten Fri, 08/08/2008 - 06:13

Hi,

Finally I've configured the Cisco 1861 controlled by MGCP. I've tried many configurations and on SCCP it wasn't possible to control that GW with a CCM 5.1(3)

But I've experience problem with FXS ports. They became unavailable with congestion tone. On the CCM the port appears as registered, but if you call it, you receive congestion. If you off hook the phone you experience congestion.

On the GW the connection shows this:

JUANEB_SANANTONIO#sh mgcp conn

Endpoint Call_ID(C) Conn_ID(I) (P)ort (M)ode (S)tate (CO)dec (E)vent[SIFL] (R)esult[EA] (ME)dia (COM)Addr:Port

1. aaln/S0/SU0/1 C=,979,-1 I=0x0 P=0,0 M=0 S=9,0 CO=0 E=3,10,10,3 R=0,0 ME=0 COM=0.0.0.0:0

I've tried shutting down and up the dial-peer, the voice-port and deletting the mgcp config, but the problem persist. Only with a reload on the Cisco 1861 the connection is released. But is not a good solution.

There is a way to resolve this? Maybe resetting something on the mgcp.

The MGCP config is:

mgcp

mgcp call-agent 20.13.1.240 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp modem passthrough voip codec g711alaw

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

no mgcp explicit hookstate

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface Loopback20

mgcp bind media source-interface Loopback20

Please let me know.

TIA

Andres Pasten

Adexus S.A.

andres.pasten Fri, 07/11/2008 - 07:46

Hi,

It's available only VIC-4FXS. But it didn't works.

*Jul 11 15:02:14.308: sccp_parse_control_msg: glob_ccm->version 6

*Jul 11 15:02:14.308: SCCP(AN1D45B95AA0000)rcvd RegisterRejectMessage

*Jul 11 15:02:14.308: sccp_appl_service_stop_timer: Stop 869A3CFC timer

*Jul 11 15:02:14.308: sccp_parse_control_msg: rcvd register rej, reason: Error: DB Config

*Jul 11 15:02:14.308: sccp_initiate_ccm_connect_interval_timer: Start CCM connect interval timer for prof_id 0, appl_type 4

*Jul 11 15:02:14.308: sccp_appl_service_start_timer: Start timer type 0 with time_out 10000ms

I've noted something on the debug: the GW tries to register as AN1D45B95AA0000, that's as a VG224 using the ethernet MAC plus a 000 which is the FXS port. But on CCM the configuration using Skinny is labeled as a MGCP configuration and the GW is labeled with the MGCP way.

TIA,

Andres Pasten

Adexus S.A.

Actions

This Discussion