IEEE 802.3ad Link Bundling with Cisco 2600 Series - Unrecognized command

Unanswered Question
Jul 9th, 2008
User Badges:

I've been trying to implement Link Aggregation on a Cisco 2611XM Router, using the onboard interfaces FastEthernet0/0 and FastEthernet0/1, so far I followed this article:

http://www.cisco.com/en/US/docs/ios/12_2sb/feature/guide/sbcelacp.html

Simple said, I want to create a trunk with the two Fast Ethernet interfaces onboard.

In the global configuration mode I've identified the port channel and tried to configure the interface in a channel group:

arnsberg#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

arnsberg(config)#interface port-channel 1

arnsberg(config-if)#channel-group 5 mode active

^

% Invalid input detected at '^' marker.


As you can see, the channel-group command is unrecognized. I am running IOS 12.3(4)T7.

Is IEEE 802.3ab not supported in the Type T Release?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ralphcarter Wed, 07/09/2008 - 12:27
User Badges:

You enable "channel-group 5 mode active" on the actual interface and not on the port-channel


int f0/0

switchport mode trunk

switchport trunk encap dot1q

channel-protocol lacp

channel-group 5 mode active


int f0/1

switchport mode trunk

switchport trunk encap dot1q

channel-protocol lacp

channel-group 5 mode active


Depending on the Ios, this will create the port-channel 5 for you or you need to make it manualy with the "interface port-channel 5"


Then under the port-channel 5, you manually set:


# switchport mode trunk

# switchport trunk encap dot1q

lbrinias8546 Wed, 07/09/2008 - 13:52
User Badges:

Sorry, I have to say, I haven't included every command used in the posting. When on the actual interface and using the channel-group command, it is still not recognized. However, even if not on the actual interface, channel-group should still be a recognized command - at least according to the Feature Guide.

However, any of the other commands you posted, aren't recognized either.

Kevin Dorrell Wed, 07/09/2008 - 12:29
User Badges:
  • Green, 3000 points or more

AFAIK, none of the lower end router platforms support link aggregation at all. I think the 10000 and 12000 do so, but there you are talking BIG router$. Sorry.


But it is strange it allowed you to go into a port-channel interface at all. Maybe the NM-16ESW module supports EtherChannel, but I don't think so.


In any case, if you could do it, you would put the channel-group n mode active command on the physical interfaces, and then configure the corresponding port-Channel interface (Pon) for the bundle.


Kevin Dorrell

Luxembourg


lbrinias8546 Wed, 07/09/2008 - 14:03
User Badges:

Well, looking at the feature guide, it does say that this command was implemented on the Cisco 2600, 3600 and 3700 series from 12.2(2)XT and 12.2(8)T. Also does Cisco state, that it is not required to create a port channel previously.

I thought about the same - regarding the NM-16ESW - however, I couldn't find any related information.

glen.grant Wed, 07/09/2008 - 14:38
User Badges:
  • Purple, 4500 points or more

Kevin is correct old routers like the 2621 would not do etherchannel . If they supported hwics and could runn newer code it might work but only with a switch card installed in the router . It probably took the commands because cisco likes to leave commands in the code even when they are not supported on a given platform.

a.alekseev Wed, 07/09/2008 - 12:32
User Badges:
  • Gold, 750 points or more

Port-Channel is not supported on this platform.


You can you BVI instead.

Actions

This Discussion