VXML Server Not Reachable

Unanswered Question
Jul 9th, 2008

Guys,

I am working on a new deploymnt of CVP 4.0. I have everything working except one of the VXML Servers is always not reachable in my Control Center. THe License file has been uplaoded. The Call Server on this box is working just fine.. Any ideas?

Chad

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Chad Stachowicz Wed, 07/09/2008 - 23:20

Caused by: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: 10.1.61.40; nested exception is:

java.net.ConnectException: Connection refused: connect]

I see this in the logs but the service is up and running. Maybe I should run a repair on it?

david.macias Thu, 07/10/2008 - 05:38

Honestly when trying to get the different pieces to show up in the management portal a reinstall usually fixes the issue a lot faster than trouble shooting. I spent 8 hours trying to bring up a call server and it took 15 minutes to reinstall and presto!

david

So you can start and stop the VXML server OK using the services.msc on the box itself?

Something is wrong with the ORM connection to the Ops Console. Is that where you see the error? In CVP\logs\ORM\Errorxxx.log?

You can try removing the VXML server from the network map and adding it again. This can be problematic if the Ops Console cannot contact the target. Are your Call Servers and VXML Servers coresident?

Regards,

Geoff

samkk2 Thu, 07/10/2008 - 07:28

Chad,

How was the License file uploaded ?

If you did that via OAMP Server ?

Are you able to pull the System ID from OAMP Server ? (under control center >VXML Server>System ID tab )

If your other VXML Server(s) are seen by OAMP Server, then the following is not applicable in your case as you have done it right the first time...if not, please read below:

Check the status of License from the VXML Server with following URL (put your Server IP address vs. localhost, as it works better sometimes)

http://10.X.Y.Z:7000/CVP/Licensing

Log in as Admin & password (defaults).

Please note that CVP VXML Server has .txt as license file unlike the CVP Call Server license which is .Lic file (Most TAC people seem to overlook this fact, even as co-hosted box setup).

Are you sure you applied the .txt file license via the above URL: (Cisco Unified CVP VXML Server Software Activation Console )

If not, please let me if you need more help...

Regards,

Sam

Chad Stachowicz Thu, 07/10/2008 - 10:05

I did not upload it that way I did it via the File Transer on the VXML server itself. I have 2 co-resident Call Server/ VXML Servers. both call servers are licensed and up, and one fof the 2 VXML servers is licensed and up, the other one says unreachable, but it didn't always. I think something is messed in the OPS Console. Where should I look to resolve this?

Chad

Chad Stachowicz Thu, 07/10/2008 - 11:25

I can pull the system ID just fine, and I know its licensed properly. I simply cannot view status in Control Center :(

Chad

Chad Stachowicz Thu, 07/10/2008 - 12:25

Geoff,

The server and services are completely fine, only OPS Console is having a problem talking to it. I think this all started when changing secure communications. Is there some way to check for traces of the device in ops console and make sure all history is gone?

Chad

Chad Stachowicz Thu, 07/10/2008 - 14:30

Geoff,

I have tried that, I have tried removing it and rebooting both servers. I have tried running the reimage.bat on both the OPS Console and Call Server / VXML Server. No matter what I do or how many times i rebuild or do whatever, the VXML always shows up as not reachable. I have opened a TAC case because im freaking out... Somehow I have a feeling that this is going to end with me rebuilding the whole CVP stuff... how stupid of a problem to have :(

Chad

Chad, I had a similar problem when the customer wanted to change the IP addressing of all the servers at side B - Call Server, VXML Server, Media Store, CUPS etc. Because the IP address change was made before I could delete the items from the map, I was unable to delete them. Changing IP addresses is mentioned in the Trouble Shooting Guide. I did not get a chance to do this properly, and when I forcibly deleted them it still ended up a mess.

I simply removed the install on the Ops Server and reinstalled CVP there, and built the Device Map again. This actually wasn't too bad - just a couple of hours.

Fortunately, I had excellent notes of what I had already done, complete with screen shots, so I silently praised my own methodology (well, no one else does ;-)).

Regards,

Geoff

Chad Stachowicz Fri, 07/11/2008 - 08:17

Well, I hunted down the problem, or a problem. I am not sure what causes it other then the obvious of licensing. The wierd part is the error and how its worded + being the right system ID. TAC is working on it now..

07/10/2008 11:08:35, SERVER ERROR: This License Key was issued for another system. Please verify that you are using the correct License Key. This software is not yet activated.

1. If this is the first time that you are seeing this error please

make sure you have a valid Installation Key or License file by going

to the Cisco Software registration website at:

http://www.cisco.com/go/license.

2. Please deploy the license that matches the System ID via the Cisco

Unified Customer Voice Portal Operations Console.

3. Restart the VXML Server in order for the license to take effect.

In case this fails please submit a Service Request using the online

TAC Service Request Tool located at this URL:

http://www.cisco.com/techsupport/servicerequest.

4. For a complete list of Cisco TAC contacts go to this URL:

http://www.cisco.com/techsupport/contacts.

The error was: com.audium.server.licensing.k: This License Key was issued for another system. Please verify that you are using the correct License Key. This software is not yet activated.

1. If this is the first time that you are seeing this error please

make sure you have a valid Installation Key or License file by going

to the Cisco Software registration website at:

http://www.cisco.com/go/license.

2. Please deploy the license that matches the System ID via the Cisco

Unified Customer Voice Portal Operations Console.

3. Restart the VXML Server in order for the license to take effect.

In case this fails please submit a Service Request using the online

TAC Service Request Tool located at this URL:

http://www.cisco.com/techsupport/servicerequest.

4. For a complete list of Cisco TAC contacts go to this URL:

http://www.cisco.com/techsupport/contacts.

07/10/2008 11:11:15, SERVER ERROR: The Installation Key is missing or invalid. Please set a valid Installation Key. This software is not yet activated.

1. If this is the first time that you are seeing this error please

make sure you have a valid Installation Key or License file by going

to the Cisco Software registration website at:

http://www.cisco.com/go/license.

2. Please deploy the license that matches the System ID via the Cisco

Unified Customer Voice Portal Operations Console.

3. Restart the VXML Server in order for the license to take effect.

In case this fails please submit a Service Request using the online

TAC Service Request Tool located at this URL:

http://www.cisco.com/techsupport/servicerequest.

4. For a complete list of Cisco TAC contacts go to this URL:

http://www.cisco.com/techsupport/contacts.

The error was: com.audium.server.licensing.k: The Installation Key is missing or invalid. Please set a valid Installation Key. This software is not yet activated.

1. If this is the first time that you are seeing this error please

make sure you have a valid Installation Key or License file by going

to the Cisco Software registration website at:

http://www.cisco.com/go/license.

2. Please deploy the license that matches the System ID via the Cisco

Unified Customer Voice Portal Operations Console.

3. Restart the VXML Server in order for the license to take effect.

In case this fails please submit a Service Request using the online

TAC Service Request Tool located at this URL:

http://www.cisco.com/techsupport/servicerequest.

4. For a complete list of Cisco TAC contacts go to this URL:

http://www.cisco.com/techsupport/contacts.

These were in the VXML Server Apache ERROR Log... However I want to add the System ID is right, and it started happening it originally licensed and came up alright..

Chad

samkk2 Fri, 07/11/2008 - 09:02

Chad,

Sorry for the repeat question...but if I may...

You have a VXML license file as a .txt file and not the .lic file. With .lic you would get an error from OAMP Server as the wrong license type...if you try to download it.

In any case the manual method works fine from the VXML Server itself, via the activation URL, as long as you have a .txt type license file

Also if you try to read the license file, it should contain IP address as 0.0.0.0; as this type of VXML License with .txt file extension seems to work fine. Hopefully you are not NIC teaming, mark active NIC#1 (description: NO SHUT License NIC) and disable NIC2.

Hopefully you are using CVP 4.1 (and not 4.0.2 version as it not so bug free).

Regards,

Sam

Chad Stachowicz Fri, 07/11/2008 - 10:07

I was able to get it resovled. I forgot a dash when I entered in my system ID :(. Also does licensing work backwards compatibly with 4.1 as with 4.02? I just got the media in for 4.1, and I want to upgrade, just want to make sure its not a licensing issue!

Thanks to everyone for their valued input time to go rate the good stuff!

Chad

Sam writes:

>Hopefully you are using CVP 4.1 (and not 4.0.2 version as it not so bug free).

Tell us more. I have 4.0(2) and don't have any problems. I am waiting for 7.0 to get onto the Software Compatibility Matrix and upgrade to 7.0, bypassing 4.1. I want the local file resolution of SRV records.

But if there are important bug fixes, I'll consider it.

Regards,

Geoff

Chad Stachowicz Fri, 07/11/2008 - 13:05

Geoff,

I have 7.0 running in the lab, and I was unable to get the Local SRV Records to work correctly... Maybe someone can help me out.

Chad

valiegenus Mon, 07/28/2008 - 02:08

Hello ,

if the license isn't uploaded , so what is the expected status massege ? is it "unreachable" or "DOWN" ??

and can i devide the license based on the ports quantity and system id ???

Regards

Actions

This Discussion