HSRP with VLAN

Unanswered Question
Jul 10th, 2008
User Badges:

Hi All


I am working on one work around in my scenario where i need your suggestion, my goal is to have my L3 switch redundancy along with link redundancy.


1) Can i use HSRP for redundancy between 2 3560 switch where on both multiple VLAN is configured (on both switch VLAN are for similar network), as all example for HSRP says for one network only and i have multiple subnets on my L3 switch and i want redundancy for that switch.


Thanks in advance,

Dhaval Tandel




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Thu, 07/10/2008 - 02:38
User Badges:
  • Green, 3000 points or more

Yes you can do that


The HSRP commands would need to configured under all the SVI interfaces in that case


eg.


Switch1


interface vlan 2

ip address 10.10.10.2 255.255.255.0

standby 2 ip 10.10.10.1

standby 2 preempt

standby 2 priority 105


interface vlan 3

ip address 20.20.20.2 255.255.255.0

standby 3 ip 20.20.20.1

standby 3 preempt

standby 3 priority 105


On switch 2


interface vlan 2

ip address 10.10.10.3 255.255.255.0

standby 2 ip 10.10.10.1

standby 2 preempt


interface vlan 3

ip address 20.20.20.3 255.255.255.0

standby 3 ip 20.20.20.1

standby 3 preempt


Narayan

dhavaltandel Thu, 07/10/2008 - 03:41
User Badges:

Thanks Narayan,


Just want to confirm,


1) If i put 1-100 MBPS link in SW-1-VLAN2 and another of 10 MBPS in SW-2-VLAN2, is it also possible to utilize Link failure redundancy, in case if my 100 MBPS link goes down?


- If it is Along with Hardware redundancy i will also get Link failure redundancy.


Thanks in Advance,

Dhaval Tandel

tdrais Thu, 07/10/2008 - 04:49
User Badges:
  • Blue, 1500 points or more

Short answer is yes but it is not as easy as it would seem.


If this were a router with a WAN link these tend to really go to a down state when they fail. With ethernet many times the port is up but something else is preventing data from flowing.


So in the simple case you build a track object like


track 22 interface gigabitethernet0/1 line-protocol

The add to the hot router

standby 2 track 22


So if the port goes physically down it will switch


If you want to do more you have to use a more advanced track object.


They call the feature enhanced object tracking but they used to use the RTR command and now call it SAA so the exact configuration will be release dependant



Kevin Dorrell Thu, 07/10/2008 - 02:43
User Badges:
  • Green, 3000 points or more

Normally, you have an HSRP instance running on each VLAN independently.


BTW, this kind of assumes that both switches have access to all the VLANs, so that the active switch is guaranteed to be able to forward the traffic to the other VLANs. This is usually the case, but not always.


Kevin Dorrell

Luxembourg


johnroche_2 Thu, 07/10/2008 - 05:13
User Badges:

You can configure and instance of HSRP on each vlan. But if you have a lot of vlans its messy.

Or you could use a dynamic routing protocol like OSPF to give redunancy


purohit_810 Thu, 07/10/2008 - 05:43
User Badges:
  • Silver, 250 points or more

Hi Dhaval,


Nice question, You need to create HSRP group group for each VLAN.


Create Etherchannel between both of them to pass traffic high speed.


Is you need redundancy as well as Load Balancing between the switches you can go ahed on GLBP protocol. You need to check GLBP supports by 3500 or not.


Thanks,

Dharmesh Purohit

Actions

This Discussion