VLAN config on 2811 with Fa and HWIC

Unanswered Question
Jul 10th, 2008
User Badges:

I have a 2811 router with the 9port HWIC installed. I am trying to use the Fa0/0 port as an uplink to my corporate LAN for the VLAN that is configured on the HWIC. I have tried adding an IP directly to the Fa port and also tried creating dot1q subinterfaces on the Fa port with no luck. When I did this the local IPs could ping each other but no connection to the corporate LAN could be established. I resorted to using one of the HWIC ports as the uplink using the config below. How can I setup the Fa port as the uplink so I can free up the HWIC port I am currently using?



Thanks,

Diego



!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/3/0

switchport mode trunk

switchport voice vlan 100

!

interface FastEthernet0/3/1

switchport mode trunk

switchport voice vlan 100

!

interface FastEthernet0/3/2

switchport mode trunk

switchport voice vlan 100

!

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

!

interface Vlan100

ip address 10.1.1.1 255.255.255.0

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
a.alekseev Thu, 07/10/2008 - 07:29
User Badges:
  • Gold, 750 points or more

You cannot connect 9port HWIC to you internal LAN through onboard F0/0,F0/1 ports..


"interface Vlan100" and

"interface F0/0.100

enacap dot1q 100"

is not the same thing..

rsgamage1 Thu, 07/10/2008 - 08:03
User Badges:
  • Bronze, 100 points or more

How do you distinguish between them and what's the use of "interface Vlan" command?

DIEGO ALONSO Thu, 07/10/2008 - 08:04
User Badges:

I don't understand where you are going with that. Would you be so kind as to give more detail?


Thanks,

Diego

a.alekseev Thu, 07/10/2008 - 08:20
User Badges:
  • Gold, 750 points or more

my english is not perfect :))


you have a router with two onboard ports (F0/0,F0/1) and one virtual port for HWIC access. The virtual port is a trunk to your HWIC. To access vlan 200 on HWIC you must create "interface vlan200".

But there is no briging between the virtual port and F0/0,F0/1.


So you can connect them each other only by routing.

glen.grant Thu, 07/10/2008 - 11:38
User Badges:
  • Purple, 4500 points or more

I believe that is the case with hwics , they are basically a standalone switch inserted into a router chassis .

Actions

This Discussion