Help on HSRP (Standby tracking)

Answered Question
Jul 13th, 2008

Hi Guys,

I need help on the standby tracking command. There are two switches (Switch 1 and Switch 2). The switch 1 is active for all the vlans and has priority of 110 and switch 2 is standby for all the vlans. The configuration is :

switch01#sh run int vlan 224

Building configuration...

Current configuration : 260 bytes

!

interface Vlan224

ip address 10.150.255.225 255.255.255.248

no ip redirects

no standby redirect

standby 224 ip 10.150.255.227

standby 224 priority 110

standby 224 preempt

standby 224 track GigabitEthernet1/3 (Connected to remote switch sw01)

standby 224 track GigabitEthernet1/4 (Connection to remote switch sw02)

end

switch1#sh standby vlan 224

Vlan224 - Group 224

Local state is Active, priority 110, may preempt

Hellotime 3 sec, holdtime 10 sec

Next hello sent in 2.368

Virtual IP address is 10.150.255.227 configured

Active router is local

Standby router is 10.150.255.226 expires in 7.576

Virtual mac address is 0000.0c07.ace0

1 state changes, last state change 2d08h

IP redundancy name is "hsrp-Vl224-224" (default)

Standby ICMP redirects disabled

Priority tracking 2 interfaces, 2 up:

Interface Decrement State

GigabitEthernet1/3 10 Up

GigabitEthernet1/4 10 Up

interface GigabitEthernet1/3

description trunk link to nfausyslsw03 2/49

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 255

switchport trunk allowed vlan 224,238,239,241,243-247,250,252,255,548

switchport mode trunk

spanning-tree guard root

interface GigabitEthernet1/4

description trunk link to nfausyslsw04 2/49

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 255

switchport trunk allowed vlan 224,238,239,241,243-247,250,252,255,548

switchport mode trunk

spanning-tree guard root

There are several vlans going on trunk g1/3 and g1/4. If the g 1/3 goes down on switch 1 will the same switch be the active switch for all the vlans as it has still got int g1/4 up or the second switch will become the active switch for all the vlans.

Tks & Rgds

Correct Answer by Edison Ortiz about 8 years 7 months ago

It depends on the decrement value placed on each tracking interface.

Currently, the active switch has a priority of 110. If the standby switch has the default value of 100, the standby will only take over if the priority in the active switch is less than 100.

Therefore, if you want this switch to be the active HSRP VIP, then just apply a decrement of 6 on G1/3 tracking entry (if it goes down the priority changes from 110 to 104) and also add a decrement of 6 on G1/4 tracking entry (if it goes down along with G1/3 the priority changes from 104 to 98).

HTH,

__

Edison.

Please rate helpful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Edison Ortiz Sun, 07/13/2008 - 21:03

It depends on the decrement value placed on each tracking interface.

Currently, the active switch has a priority of 110. If the standby switch has the default value of 100, the standby will only take over if the priority in the active switch is less than 100.

Therefore, if you want this switch to be the active HSRP VIP, then just apply a decrement of 6 on G1/3 tracking entry (if it goes down the priority changes from 110 to 104) and also add a decrement of 6 on G1/4 tracking entry (if it goes down along with G1/3 the priority changes from 104 to 98).

HTH,

__

Edison.

Please rate helpful posts

mahmoodmkl Sun, 07/13/2008 - 21:43

Hi

The 2 link which u r using for the connectvity i think one of them should be in blocking mode to prevent the stp loop.

If the active link goes down its going to take normal stp timers to converge and the original active router will be the same.

Thanks

Mahmood

Actions

This Discussion