VXML problem

Unanswered Question
Jul 14th, 2008
User Badges:

I have vxml script and two Ip-phones on CCME.. Locally all works - i call to script number 7804, hear music, press the buttons.. events nomatch and noinput also works.. from CCM (5xxx) i can call to CCME (78xx) and back.. transfer also works... when I call to script, the call is set and script is done according debug and "show commands".. but it only thinks a few seconds and then "busy"...


At CCME side:


application

service menu flash:menu.vxml


dial-peer voice 100 voip

service menu out-bound

destination-pattern 7804 //script number

session target ipv4:172.18.1.1

dtmf-relay rtp-nte h245-signal

codec g711ulaw

no vad


dial-peer voice 13 voip

destination-pattern 5... // CCM numbers

session protocol sipv2

session target ipv4:172.18.1.1

dtmf-relay sip-notify

codec g711ulaw


From CCM side there is route pattern to CCME numbers


P.S. script and scheme are attached



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Yagami_Light Wed, 07/16/2008 - 23:44
User Badges:

nobody knows?.. there is idea, that locally ip-phones are seen like pots.. and when i call from outside - like voip.. and ivr don't want to work with it :(.. our provider also is working to solve this problem

Tim Smith Thu, 07/17/2008 - 00:46
User Badges:
  • Silver, 250 points or more

Hi,


Start with the basics...


Where is your inbound dial peer?


Have you done a "debug isdn q931" to watch the inbound call from the PSTN and see why it gets disconnected?


First level is to get the call from outside, and get it to match the dial peer with the script on it... you need to verify this is happening.


Cheers,


Tim

Tim Smith Thu, 07/17/2008 - 00:50
User Badges:
  • Silver, 250 points or more

You are using G711 on the CME box..

Are your CallManager extensions trying to use G711 also?


Cheers,


Tim


Actions

This Discussion