ping to router from switch Un-sucessfull ?

Answered Question
Jul 14th, 2008
User Badges:

1) configured router with sub-interfaces and assigned vlan's to every sub-interface using dot1q


2)configured switch ports with vlan's and attachd Pc's to every vlan.


3)pc's from all vlan can ping all the subinterface and other vlans's.


4)I can't ping the router sub-interfaces from the switch


do we have to configure any more on switch or router to make switch ping all the router sub-interfaces?

Correct Answer by Richard Burts about 8 years 10 months ago

Kiran


Posting the router config is helpful. It shows that you do not have anything configured on the router on FastEther0/0 for VLAN 1. VLAN 1 is the management interface of the switc. If the router does not have VLAN 1 configured with an IP address that matches the subnet used on the switch then the switch will not be able to ping the router (or anything else in the network).


Note that not having an interface on the router for VLAN 1 only impacts traffic from the management interface of the switch. All the switch ports and all the devices connected to user VLANs on the switch will still work ok. But the switch itself will not be able to access anything without VLAN 1 configured and active on the router.


HTH


Rick

Hi There


As p.bevilacqua said above. Your switch is purely a layer 2 switch at present.


You need to do the folowing.


a). Decide on an IP subnet for your device management.


b). Create another sub interface on your router and assign it the first IP address from your management subnet.


c). Assign the second IP address from your management subnet to the VLAN1 SVI on the switch.


d). Configure a default gateway on the switch. The default gateway IP address should be the IP address assigned to the sub interface on the router which has the first IP address of the management subnet.


HTH



Best Regards,


Michael

Correct Answer by equiduct1 about 8 years 10 months ago

Your switch is running as a pure L2 switch.

You need to configure L3 interfaces -SVIs- on the switch with for each vlan you want to ping.


int vlan x

ip add [][]


only after that you can ping from the sw.

Correct Answer by Richard Burts about 8 years 10 months ago

Kiran


You need to configure an IP address for VLAN 1 to enable ping from the switch to the router. As has been suggested you also need a default-gateway configured if you want the switch to access anything outside the subnet of its management interface.


HTH


Rick

Correct Answer by paolo bevilacqua about 8 years 10 months ago

I suppose it's a purely layer 2 switch that you're talking about. If so, configure "ip default-gateway x.x.x.x" on the switch where x.x.x.x is router address in vlan 1 (native).


Please rate post if it helps!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.4 (5 ratings)
Loading.
Correct Answer
paolo bevilacqua Mon, 07/14/2008 - 04:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I suppose it's a purely layer 2 switch that you're talking about. If so, configure "ip default-gateway x.x.x.x" on the switch where x.x.x.x is router address in vlan 1 (native).


Please rate post if it helps!

a.alekseev Mon, 07/14/2008 - 04:14
User Badges:
  • Gold, 750 points or more

show the switch's configuration

kirankumar.chamakura Mon, 07/14/2008 - 04:28
User Badges:

Building configuration...


Current configuration : 1759 bytes

!

version 12.1

no service password-encryption

!

hostname Switch

!

enable secret x $xxxxxxxxxxxxxx./

enable password xxxxxxx

!

!

!

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 5

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 6

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 7

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 8

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 9

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 11

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 12

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 13

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 14

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 15

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 16

switchport mode access

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface Vlan1

no ip address

!

line con 0

password xxxxx

login

!

line vty 0 4

password xxxxxx

login

line vty 5 15

password xxxxxx

login

!

!

end

Correct Answer
Richard Burts Mon, 07/14/2008 - 04:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Kiran


You need to configure an IP address for VLAN 1 to enable ping from the switch to the router. As has been suggested you also need a default-gateway configured if you want the switch to access anything outside the subnet of its management interface.


HTH


Rick

Correct Answer
equiduct1 Mon, 07/14/2008 - 04:36
User Badges:

Your switch is running as a pure L2 switch.

You need to configure L3 interfaces -SVIs- on the switch with for each vlan you want to ping.


int vlan x

ip add [][]


only after that you can ping from the sw.

Correct Answer

Hi There


As p.bevilacqua said above. Your switch is purely a layer 2 switch at present.


You need to do the folowing.


a). Decide on an IP subnet for your device management.


b). Create another sub interface on your router and assign it the first IP address from your management subnet.


c). Assign the second IP address from your management subnet to the VLAN1 SVI on the switch.


d). Configure a default gateway on the switch. The default gateway IP address should be the IP address assigned to the sub interface on the router which has the first IP address of the management subnet.


HTH



Best Regards,


Michael

kirankumar.chamakura Mon, 07/14/2008 - 04:36
User Badges:

Router configuration


interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description VLAN-2

encapsulation dot1Q 2

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0.2

description VLAN-3

encapsulation dot1Q 3

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/0.3

description VLAN-4

encapsulation dot1Q 4

ip address 192.168.3.1 255.255.255.0

!

interface FastEthernet0/0.4

description VLAN-5

encapsulation dot1Q 5

ip address 192.168.4.1 255.255.255.0

!

interface FastEthernet0/0.5

description VLAN-6

encapsulation dot1Q 6

ip address 192.168.5.1 255.255.255.0

!

interface FastEthernet0/0.6

description VLAN-7

encapsulation dot1Q 7

ip address 192.168.6.1 255.255.255.0

!

interface FastEthernet0/0.7

description VLAN-8

encapsulation dot1Q 8

ip address 192.168.7.1 255.255.255.0

!

interface FastEthernet0/0.8

description VLAN-9

encapsulation dot1Q 9

ip address 192.168.8.1 255.255.255.0

!

interface FastEthernet0/0.9

description VLAN-10

encapsulation dot1Q 10

ip address 192.168.9.1 255.255.255.0

!

interface FastEthernet0/0.10

description VLAN-11

encapsulation dot1Q 11

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/0.11

description VLAN-12

encapsulation dot1Q 12

ip address 192.168.11.1 255.255.255.0

!

interface FastEthernet0/0.12

description VLAN-13

encapsulation dot1Q 13

ip address 192.168.12.1 255.255.255.0

!

interface FastEthernet0/0.13

description VLAN-14

encapsulation dot1Q 14

ip address 192.168.13.1 255.255.255.0

!

interface FastEthernet0/0.14

description VLAN-15

encapsulation dot1Q 15

ip address 192.168.14.1 255.255.255.0

!

interface FastEthernet0/0.15

description VLAN-16

encapsulation dot1Q 16

ip address 192.168.15.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Vlan1

no ip address

!

router eigrp 100

network 192.168.1.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

network 192.168.5.0

network 192.168.6.0

network 192.168.7.0

network 192.168.8.0

network 192.168.9.0

network 192.168.10.0

network 192.168.11.0

network 192.168.12.0

network 192.168.13.0

network 192.168.14.0

network 192.168.15.0

network 192.168.16.0

no auto-summary

Correct Answer
Richard Burts Mon, 07/14/2008 - 04:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Kiran


Posting the router config is helpful. It shows that you do not have anything configured on the router on FastEther0/0 for VLAN 1. VLAN 1 is the management interface of the switc. If the router does not have VLAN 1 configured with an IP address that matches the subnet used on the switch then the switch will not be able to ping the router (or anything else in the network).


Note that not having an interface on the router for VLAN 1 only impacts traffic from the management interface of the switch. All the switch ports and all the devices connected to user VLANs on the switch will still work ok. But the switch itself will not be able to access anything without VLAN 1 configured and active on the router.


HTH


Rick

kirankumar.chamakura Tue, 07/15/2008 - 01:29
User Badges:

HI Guy's


Thanks, you'R Suggestions helped me a lot.I have rated you all guys thanks once again


Kiran

paolo bevilacqua Tue, 07/15/2008 - 02:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Thank you for the appreciation and good luck!

Actions

This Discussion