Routing on layer 3 switch without any VLAN.

Unanswered Question
Jul 15th, 2008

Hi,

may be a very basic Q but need a help!

I have a 3550 switch all ports are in vlan 1.I made 2 ports as layer 3 ports by giving command 'no switchport' and then made them UP .Also gave both ports different IPs (port 6->10.1.1.1 and port 7->14.130.13.109). I connected a laptop on port6, gave ip 10.1.1.2 and trying to ping 14.130.13.109.obviously did not work .So enabled ip routing on switch and configure a route.no luck this time also.I want to communicate between these 2 IPs without creating VLANs.

BUT I am not sure is this a correct way ?Does switch will be able to ping 14 IP address this way?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lee.reade Tue, 07/15/2008 - 00:53

Hi,

Well what you have done so far is oorrect, you need ip routing enabled on switch.

Also you will need to config the laptop to use 10.1.1.1 as the default gateway, did you do this?

HTH

LR

abdave Tue, 07/15/2008 - 00:56

Thanks for confirmation that my approach was right. Perhaps I did'nt give default GW yet.Will try that .thanks again.

abdave Tue, 07/15/2008 - 02:30

No luck.Routing not working.Below is the small LAB diagram. Please advice how to ping server from laptop.

----------------------

1* 2* 3* 4* 5* 6* 7*

----------------------

port 1 is directly connectted to laptop

port 2 is directly connected to a server

port 1 is enabled with 'no switchport' and has IP 10.1.1.1

Laptop has IP 10.1.1.2 with default GW 10.1.1.1

port 2 is enabled with 'no switchport' and has IP 14.130.13.108

server has IP 14.130.13.109

------------------------------------------

nmooremvsc Tue, 07/15/2008 - 12:28

Is the default gateway on the server 14.130.13.108? Or is the a specific return route on the server letting it know how to get back to 10.1.1.1?

abdave Tue, 07/15/2008 - 21:36

no static routing. so no reverse route.I gave default gateway as 14.130.13.108 and enabled routing by command 'ip routing'.it worked!

itdsmartnet Fri, 07/25/2008 - 04:34

hi,

i think the firwall is enabled on your server or on Laptop i.e windows firewall. Turn it off and try to ping now.

Thanks

Actions

This Discussion