How to configure HSRP sub interfaces to pass information through switches

Answered Question
Jul 15th, 2008
User Badges:

We are trying to configure a new subinterface g0/0.1725 on both our routers.


This will allow a few devices to use the 192.168.172.x range


I have configured the subinterfaces on the primary and the failover router.


However they are not passing HSRP information.


Router A is connected to switch A

and Router B is connected to switch B.


Switches A and B are trunked together.


We have 2 vlans configured on the switches. Both are passing HSRP information.


Do I need to configure vlan 1720 so the information will pass on the new subnet

we are trying to configure to pass HSRP?

Correct Answer by lee.reade about 8 years 8 months ago

You need to go config VTp TRANSPARENT mode to config vlan numbers higher than 1005.


So config term

vtp mode transparent

on both switches.


Also, you subnet masks are wrong, 172.20.255.240 is network address, you should use .241 on router 1 and .242 on router 2, also the stanby address is in another subnet completely, this should be somethting like .243.


Without all this, it wont work.


HTH


LR

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lee.reade Tue, 07/15/2008 - 06:33
User Badges:
  • Silver, 250 points or more

Hi,


What vlan do you have specified under that subinterface?


Ie. encapsulation dot1q 100


Do you have this vlan enabled on both switches, and allowed across the trunk?


HTH


LR

brooklynheight Tue, 07/15/2008 - 06:37
User Badges:

router 1


interface GigabitEthernet0/0.1725

encapsulation dot1Q 1725

ip address 172.20.255.240 255.255.255.248

no snmp trap link-status

standby 4 ip 172.20.255.1


router 2


interface GigabitEthernet0/0.1725

encapsulation dot1Q 1725

ip address 172.20.255.241 255.255.255.248

no snmp trap link-status

standby 4 ip 172.20.255.1

standby 4 preempt



The switches are than configured as basic

trunks allowing all vlans to pass through.


However vlan 1725 is not configured on the switches.


switch(config)#vlan 1725

switch(config-vlan)#exit

% Failed to create VLANs 1725

Extended VLAN(s) not allowed in current VTP mode.

%Failed to commit extended VLAN(s) changes.



Correct Answer
lee.reade Tue, 07/15/2008 - 06:51
User Badges:
  • Silver, 250 points or more

You need to go config VTp TRANSPARENT mode to config vlan numbers higher than 1005.


So config term

vtp mode transparent

on both switches.


Also, you subnet masks are wrong, 172.20.255.240 is network address, you should use .241 on router 1 and .242 on router 2, also the stanby address is in another subnet completely, this should be somethting like .243.


Without all this, it wont work.


HTH


LR

brooklynheight Tue, 07/15/2008 - 07:42
User Badges:

thx on the vtp transparent mode..that was the issue..



the ip's were typos O:-)

Actions

This Discussion