Question about secondary IP and vlan

Unanswered Question
Jul 15th, 2008
User Badges:

We are providing an entirely new subnet

for our video conf. equipment.


The engineers have added a 172.20.255.x network for video conf. but have configured the router the following way.


interface GigabitEthernet0/1

description to LAN

ip address 172.20.255.34 255.255.255.248 secondary

ip address 192.168.92.251 255.255.255.0

load-interval 30

duplex auto

speed auto

media-type rj45

standby 1 ip 192.168.92.1

standby 1 ip 172.20.255.33 secondary

standby 1 preempt


With 192.168.92.x being the local lan

and 172.20.255.x being the video conf.

equipment network


My question is this



Would it have been better to configure the router interfaces with sub interfaces

instead of using secondary ip's?


Also..do the switches still need vlans

configured with the current configurations..


or will vlan 1 suffice



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
paolo bevilacqua Tue, 07/15/2008 - 10:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, proper and clean design do not use any secondary address.


In most cases, having VLAN / subinterfaces is a big advantage, and you should seriously consider doing that.


Please rate post if it helps!

is66rlhntadm Tue, 07/15/2008 - 10:44
User Badges:
  • Bronze, 100 points or more

Yes if they only set secondary ip's then that must mean that the layer2 is still one large broadcast domain


I would certainly want to make sub-interfaces and split them into vlans


although creating that structure would affect access to the router for as long as it takes to get the switch port set to trunk and the sub-interfaces created so just plan accordingly


I'm sure you would do it the same way I'm thinking but (console cable to router and to switch) and put together a text file of all of the commands in the order needed

nygenxny123 Tue, 07/15/2008 - 11:31
User Badges:

I couldnt figure out why a secondary IP

would be congiured.


Could the possiblity be the port would

have to be shut down in order

to configure a sub-int on for the LAN

and video conf. equipment

is66rlhntadm Tue, 07/15/2008 - 11:43
User Badges:
  • Bronze, 100 points or more

well yes the port would stop routing for a short time as the "no ip address" command would need to be entered to configure subinterfaces


example


enable

configure terminal

interface GigabitEthernet 0/1

no ip address

interface GigabitEthernet 0/1.1

ip address 172.16.x.y 255.255.255.0

encap dot1q 1

interface GigabitEthernet 0/1.2

ip address 192.168.x.y 255.255.255.0

encap dot1q 2

end

copy run start


and youd need to configure the switchport to be in trunk mode


enable

configure terminal

Interface GigabitEthernet 0/1

switchport trunk encapsulation dot1q

switchport mode trunk


also create vlan2 on the switch

(if the switch in non-cisco then more help will be neded)

paolo bevilacqua Wed, 07/16/2008 - 06:54
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

When configured properly, HSRP works fine with subinterfaces.

Joseph W. Doherty Wed, 07/16/2008 - 16:14
User Badges:
  • Super Bronze, 10000 points or more

One disadvantage of using subinterfaces, you can't easily prioritize the vidconf traffic if there's congestion on the physical interface. Perhaps a better solution would be to have a separate physical interface dedicated to the vidconf network.

Actions

This Discussion