Routing/switching question.

Unanswered Question
Jul 15th, 2008

I can't seem to get past the Eth0 of the router when I am on the switch, however, when I am consoled on the router, I can ping everyone and their mother. I don't get it.

I'm hoping this mini graph will help. I also have the FA0/2 set as a trunk b/c I will be operating VLANs on a couple of switches which will lead off of ports 3 & 4.

Anyone who can help -- thank you. I can't seem to figure out what's wrong...and I've been trying to get this small problem resovled for the past 36 hours...went as far as hooking up a Linksys WRT54G



1720 series router.

Catalyst 3560G-24TS



Eth0: /24

FA0: /30






ip routing



interface GigabitEthernet0/2

description To Router

switchport trunk encapsulation dot1q

switchport mode trunk

interface Vlan1

ip address


ip classless

ip route

ip route

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mark Yeates Tue, 07/15/2008 - 15:07

On your switch you should either remove the trunk commands or the IP address. The port cannot be both layer 2 & 3. Since the connection from FA0 on the router is a layer 3 port I would remove the trunk commands and place the trunk somewhere else down the line. Unless I am missing something give those a try.


tip-admin Tue, 07/15/2008 - 15:12

Mark, thanks for your quick response... Unfortunatly, I have to say, welcome to my world. It didn't work. :(

I have on my router and very basic config...just the needed to connect. On the switch, it's the same way.

Mark Yeates Tue, 07/15/2008 - 16:02

Sorry that didn't work but, it was the first thing that I noticed. If you can post configs your problem could be better diagnosed.

tip-admin Fri, 07/18/2008 - 08:04

Hey Mark -- upon working on it I finally got it to work. What didn't make sense to me was, out of frustration, I hooked up a Linksys Wireless Router and went Eth0 to the WAN connection on the Linksys, set a 30 bit network between the two and from my switch, I could get out. Based on that, I checked my cables to see if I was using a straight through when I should have been using a X-over etc...basic, minor troubleshooting.

Still not being able to get what I needed without using the Linksys, I wiped the IOS on the Router and went down to 12.2.XX and tried each, thinking that I might have loaded an IOS that required memory which I somehow overlooked and that I didn't meet (and yet my router could get to either location).

Finally 2 days ago - on Wed, I decided to take a look at the current network topology and decided to play with just one port setting which was a direct connect to our Dist. Switch in our Data center...and it dawned on me -- We have VLANS and the configs I was using - yeah, didn't match. So all along it was a vlan setting pre set causing it. I opened that puppy up and BAM - just like that, I was back in business.

Thanks for your help...I didn't even catch the initial config problem between the layer 2/3 I initially had.


Mark Yeates Fri, 07/18/2008 - 08:54

Not a problem. Thanks for letting me know that your problem has been resolved.



This Discussion