dialup on Cisco 1811 build in modem

Answered Question
Jul 16th, 2008

i am having problem, it connects and disconnects shortly. here is the config.

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer remote-name name

dialer idle-timeout 300

dialer string 13101310

dialer hold-queue 10

dialer-group 1

no peer default ip address

no cdp enable

ppp authentication pap chap callin

ppp chap hostname [email protected]

ppp chap password 0 wateen

exit

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async mode interactive

exit

ip route 0.0.0.0 0.0.0.0 Dialer0

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

logging on

loggin monitor

exit

terminal monitor

debug dialer

debug async state

debug ppp negotiation

I have this problem too.
0 votes
Correct Answer by Richard Burts about 8 years 4 months ago

Usman

It looks like you are making some progress. In the output of 21-debug-ppp-auth.TXT authentication is failing on both sides. In the output of 21-debug-ppp-auth-nag.TXT (which is a bit later according to the timestamps) you are being authenticated successfully by the other device - but you are not authenticating the other device.

You are receiving a CHAP challenge from the other device using ID of lah-as5400-as1. To be able to authenticate successfully that device I would think that you would need a username configuration statement giving the name and password of that device.

HTH

Rick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Richard Burts Wed, 07/16/2008 - 03:10

Usman

I agree that knowing what is in the debug output would be very helpful. I would be especially interested in the output of debug ppp negotiation. In addition I would suggest running debug ppp authentication. In my experience symptoms similar to what you describe are frequently the result of problems with authentication.

HTH

Rick

usmanjathol Wed, 07/16/2008 - 03:48

Router#ping 192.168.196.97

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.196.97, timeout is 2 seconds:

*Jul 16 11:40:13.775: As1 DDR: rotor dialout [best] least recent failure is also

most recent failure

*Jul 16 11:40:13.775: As1 DDR: rotor dialout [best] also has most recent failure

*Jul 16 11:40:13.775: As1 DDR: rotor dialout [best]

*Jul 16 11:40:13.775: As1 DDR: Dialing cause ip (s=10.10.0.1, d=192.168.196.97)

*Jul 16 11:40:13.775: As1 DDR: Attempting to dial 13101310

*Jul 16 11:40:13.775: CHAT1: Attempting async line dialer script

*Jul 16 11:40:13.775: CHAT1: no matching chat script found for 13101310

*Jul 16 11:40:13.775: CHAT1: Dialing using Modem script: d0efault-d0ials0cript &

System script: none

*Jul 16 11:40:13.775: CHAT1: process started

*Jul 16 11:40:13.775: CHAT1: Asserting DTR

*Jul 16 11:40:13.775: CHAT1: Chat script d0efault-d0ials0cript started.....

Success rate is 0 percent (0/5)

Router#

*Jul 16 11:40:42.435: CHAT1: Chat script d0efault-d0ials0cript finished, status

= Success

*Jul 16 11:40:42.435: As1 PPP: Async Protocol Mode started for 0.0.0.0

*Jul 16 11:40:44.435: %LINK-3-UPDOWN: Interface Async1, changed state to up

*Jul 16 11:40:44.435: As1 DDR: Dialer statechange to up

*Jul 16 11:40:44.435: %DIALER-6-BIND: Interface As1 bound to profile Di0

*Jul 16 11:40:44.435: As1 DDR: Dialer call has been placed

*Jul 16 11:40:44.435: As1 PPP: Using dialer call direction

*Jul 16 11:40:44.435: As1 PPP: Treating connection as a callout

*Jul 16 11:40:44.435: As1 PPP: Session handle[44000008] Session id[4]

*Jul 16 11:40:44.435: As1 PPP: Phase is ESTABLISHING, Active Open

*Jul 16 11:40:44.435: As1 PPP: No remote authentication for call-out

*Jul 16 11:40:44.435: As1 LCP: O CONFREQ [Closed] id 31 len 20

*Jul 16 11:40:44.435: As1 LCP: ACCM 0x000A0000 (0x0206000A0000)

*Jul 16 11:40:44.435: As1 LCP: MagicNumber 0x1EFEFE04 (0x05061EFEFE04)

*Jul 16 11:40:44.435: As1 LCP: PFC (0x0702)

*Jul 16 11:40:44.435: As1 LCP: ACFC (0x0802)

*Jul 16 11:40:44.527: As1 LCP: I CONFREQ [REQsent] id 1 len 24

*Jul 16 11:40:44.527: As1 LCP: ACCM 0x000A0000 (0x0206000A0000)

*Jul 16 11:40:44.527: As1 LCP: AuthProto PAP (0x0304C023)

*Jul 16 11:40:44.527: As1 LCP: MagicNumber 0xA6EB8E29 (0x0506A6EB8E29)

*Jul 16 11:40:44.527: As1 LCP: PFC (0x0702)

*Jul 16 11:40:44.527: As1 LCP: ACFC (0x0802)

*Jul 16 11:40:44.527: As1 LCP: O CONFNAK [REQsent] id 1 len 9

*Jul 16 11:40:44.527: As1 LCP: AuthProto CHAP (0x0305C22305)

*Jul 16 11:40:44.535: As1 LCP: I CONFACK [REQsent] id 31 len 20

*Jul 16 11:40:44.535: As1 LCP: ACCM 0x000A0000 (0x0206000A0000)

*Jul 16 11:40:44.535: As1 LCP: MagicNumber 0x1EFEFE04 (0x05061EFEFE04)

*Jul 16 11:40:44.535: As1 LCP: PFC (0x0702)

*Jul 16 11:40:44.535: As1 LCP: ACFC (0x0802)

a.alekseev Wed, 07/16/2008 - 03:55

try

interface Async1

async mode dedicated

and show again the debugs...

Richard Burts Wed, 07/16/2008 - 04:10

Usman

In looking at the debug output that you posted I see that most of the negotiation seems to be about disagreement about authentication. Can you post how the other end of the connection is configured - especially how it is configured for authentication?

Your router is configured to authenticate on callin. I see these messages in your logs:

*Jul 16 11:40:44.435: As1 PPP: No remote authentication for call-out

and it makes me wonder what the remote end is expecting about authentication.

HTH

Rick

usmanjathol Wed, 07/16/2008 - 04:14

I am passing the dialup number, user id and password.

when i give same number, user and pwd on laptop modem it connects and i get ip and works fine.

i need to dial thru router and get ip and ping the auto assigned gateway thru router..

the nde debug with dedicated is attached

thanks a lot for help

Attachment: 
a.alekseev Wed, 07/16/2008 - 04:22

Try to use PAP instead of CHAP.

ppp authentication pap callin

ppp pap sent-username PAPUSER password xxxx

usmanjathol Thu, 07/17/2008 - 00:44

Hi,

Please check. Still not working.

I am attaching the running and debug.

Plz help

the same user id and pwd works fine when i connect thru laptop modem.

i want to establish a backup dialup settings. so when my WAN link goes down it should dial dialup and keep connected.

thanks

usman

Attachment: 
Richard Burts Thu, 07/17/2008 - 04:23

Usman

The debugs that are in either of the files posted today are much less helpful than the previous posted ones. It would be helpful to see output of debug ppp negotiation. And it would be especially helpful to see output of debug ppp authentication.

But without seeing those debugs I have a suggestion. change:

ppp authentication pap callin

to

ppp authentication pap

Give it a try and let us know what happens.

HTH

Rick

Richard Burts Fri, 07/18/2008 - 03:17

Usman

The ppp authentication debug is helpful. It clearly shows that while you are configured to authenticate with PAP that the other end is configured to authentidcate with CHAP:

*Jul 18 03:57:42.843: As1 CHAP: I CHALLENGE id 1 len 34 from "lah-7206-vhg1"

*Jul 18 03:57:42.843: As1 CHAP: Unable to authenticate for peer

I would suggest that either you change your router to authenticate with CHAP or that you get the other side to accept authentication with PAP.

HTH

Rick

Correct Answer
Richard Burts Mon, 07/21/2008 - 03:57

Usman

It looks like you are making some progress. In the output of 21-debug-ppp-auth.TXT authentication is failing on both sides. In the output of 21-debug-ppp-auth-nag.TXT (which is a bit later according to the timestamps) you are being authenticated successfully by the other device - but you are not authenticating the other device.

You are receiving a CHAP challenge from the other device using ID of lah-as5400-as1. To be able to authenticate successfully that device I would think that you would need a username configuration statement giving the name and password of that device.

HTH

Rick

usmanjathol Mon, 07/21/2008 - 18:37

Rick,

thanks for being with me.

I do not want to authenticate the remote device. Its a service provider network.. i just need to login there using the authentication they have give me..

I just need one way authentication.

any suggestions , what i need to change...

thanks

Usman

Richard Burts Mon, 07/21/2008 - 18:58

Usman

If you want the other device to authenticate you but you to not authenticate the other device then add the parameter "callin" to the authentication command. So you would configure:

ppp authentication chap callin

HTH

Rick

usmanjathol Mon, 07/21/2008 - 20:21

Hi Rick,

It worked... i am successfully in now and getting IP from other side and can ping my desired location.

Thanks a lot for your help and valued contribution.

my 2nd issue is the backup DDR

i'll come back with that soon.

Thanks

Usman

Richard Burts Tue, 07/22/2008 - 03:56

Usman

I am glad that my suggestions were able to help you to resolve your issue. If you have questions about DDR please post them, but I would suggest that you open a new discussion rather than continuing in this discussion. Thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can know that there was a successful resolution to the issue.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

usmanjathol Tue, 07/22/2008 - 04:03

Thanks Rick

I really appreciate ppl like you helping ppl ..

excellent job and excellent forum...

thanks again

Usman

Actions

This Discussion