Can't connect WLCs to WCS

Answered Question
Jul 16th, 2008
User Badges:
  • Bronze, 100 points or more

We're having a bit of trouble connecting our Wireless LAN Controllers to the WCS. Every time I try and add a controller I get the “Failed to add device to WCS” message, I've tried all the suggestions from the Cisco site, however no luck. I've also attached the SNMP debug from the controller when I try to connect if that will help. Any assistance would be greatly appreciated.


Many thanks

Chris



Attachment: 
Correct Answer by Scott Fella about 8 years 8 months ago

Looks like WCS. Backup WCS and install 4.2.97.0 and then do a restore, see if that works.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Scott Fella Wed, 07/16/2008 - 03:24
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

When you try to add the wlc to WCS, you do not change the admin and password field. What I have done is also recreate your community strings (at least your RW) and make sure the network is allowed. Try to remove the special character to see if one of them is causing issue if you have any in the RW string.

Chris Illsley Wed, 07/16/2008 - 03:34
User Badges:
  • Bronze, 100 points or more

I've recreated the community strings, currently there are no special characters, I reset the controller and set it up with a basic config and tried using the default private community string, no joy.


"When you try to add the wlc to WCS, you do not change the admin and password field."


I'm not too sure what you mean here I'm afraid

Chris Illsley Wed, 07/16/2008 - 03:38
User Badges:
  • Bronze, 100 points or more

Do you mean in SNMP V3? I'm using SNMP V2

Scott Fella Wed, 07/16/2008 - 05:52
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

My mistake... that was the location appliance. On WCS, just verify the version you are using and the community string. On the WLC under the community string, remover the Read Only, Make sure the Read Write is enabled and set the network to 0.0.0.0 or the ip of the wcs server. don't keep trying it if it fails, move out of that screen and go back into the screen. That seems to of worked for me.

Chris Illsley Wed, 07/16/2008 - 08:32
User Badges:
  • Bronze, 100 points or more

Ah right, no worries.


The versions are:

Model: 4404

Software: 4.2.130.0


WCS Version: 4.0.96.0

Type: Basic


There is another 4402 which also won't connect running 4.2.65.0 but I'm mainly leaving that alone as it is production.


The community string is definitely read/write, I tried read only if that would help, no luck there though. I've tried with 0.0.0.0 catch all and with the specific IP address. There is no filtering going on between the vlans, I've used getif to do an snmp query and it has no problems there. No luck with moving out of the screen, I've even gone as far as changing PCs.


Thanks once again.

Scott Fella Wed, 07/16/2008 - 09:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Try to restart WCS and see if the service is running. You don't have windows FW running that might be blocking snmp?

Chris Illsley Wed, 07/16/2008 - 10:25
User Badges:
  • Bronze, 100 points or more

Restarted the WCS, actually went as far as reinstalling the software, to no avail. No Windows FW turned on. I didn't do the SNMP query from the server, will do that shortly.

Chris Illsley Wed, 07/16/2008 - 10:39
User Badges:
  • Bronze, 100 points or more

Done, and the SNMP query goes through fine. Gah.

Scott Fella Wed, 07/16/2008 - 13:18
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Well at least you got it working. Now just make sure you perform a backup just in case you have to reinstlall WCS.

Chris Illsley Wed, 07/16/2008 - 21:22
User Badges:
  • Bronze, 100 points or more

Ooops, sorry, it's still not working.

Scott Fella Thu, 07/17/2008 - 03:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

You have a license installed on the WCS? Can you do a getif from the wcs server?

Chris Illsley Thu, 07/17/2008 - 03:38
User Badges:
  • Bronze, 100 points or more

Yes, licence installed and getif works fine from the server.


Cheers


Correct Answer
Scott Fella Thu, 07/17/2008 - 04:05
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Looks like WCS. Backup WCS and install 4.2.97.0 and then do a restore, see if that works.

Chris Illsley Thu, 07/17/2008 - 06:27
User Badges:
  • Bronze, 100 points or more

Cheers, will do, I'll let you know the result.

rbaeumer Thu, 07/17/2008 - 06:27
User Badges:

Hi Chris, just a little story I experienced just today. I tried to connect the two controllers of my WiSM to WLC. No success with snmpv3. But the following trick finally did it. I first added with V2, then released and then added with V3 and it worked so far..... Greetings

Chris Illsley Thu, 07/17/2008 - 06:57
User Badges:
  • Bronze, 100 points or more

Cheers, rbaumer, doesn't look like I'll be trying that though upgrading the software has fixed the problem. Thanks very much fella5 and anyone else who has taken the time to help it's much appreciated.


Cheers

Chris

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode