WLAN Controller in Campus 5.0.3 (LMS 3.0.1)

Unanswered Question
Jul 16th, 2008

The Campus 5.0.3 release notes state that the WLAN Controller 4400 series are supported. After installation of the 5.0.3 patch, the Controller is still a red icon (unknown) on the topology map.

The credentials are fine because I'm able to perform a SNMP MIB walk via CWLMS.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 07/16/2008 - 08:49

Check the DCR credentials for this device. The fact that the icon is red has nothing to do with support; that means the device is unreachable via SNMP. You may also want to start a sniffer trace filtering on udp/161 traffic to this device, then run a new Campus Data Collection to see how Campus is querying the controller.

vergeerf Wed, 07/16/2008 - 22:34

credentials are correct, I posted the ANI.log, one of the error messages is; Cannot normalize/resolve CDP port name Unit

This controller is connected via a multi-module channel. But other controllers are connected via a GEC on a single switch have the same problem

From the switch perspective I do see the controller as a neighbor.

Joe Clarke Wed, 07/16/2008 - 22:44

This looks like an SNMP timeout issue, or an issue reading the CISCO-CDP-MIB on the controllers. Can you post a sniffer trace filtering on udp/161 traffic to one of the affected controllers when running a Campus Data Collection?

Joe Clarke Thu, 07/17/2008 - 08:09

Campus is polling these controllers with the community string of "campus" and the controllers are responding with noSuchName for every object. This is causing your problem. This points to either an SNMP configuration error on the controller, or you have the wrong community strings configured in DCR.

vergeerf Thu, 07/17/2008 - 23:43

FYI: The WLC4404 is not supported, only the WLC4402. However, the MIB implementation in the 4.2 firmware on the 4404 has a bug.

snmpwalk -v 2c -c public . returns: SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.14179.

So MIB walk reports that it's a 4402 but it's a 4404 ;-)

Joe Clarke Fri, 07/18/2008 - 08:01

That still wouldn't explain why you're seeing the noSuchName errors when Campus tries to poll this device. In fact, this bug should allow Campus to support the 4404.

vergeerf Tue, 07/29/2008 - 10:58

FYI: I enabled debugging on the WLC4404 and discovered that datacollection was using SNMP v1 which is disabled on the controller by default.

For a workaround I've enabled SNMP v1 on the controller but Is there a way to force Campus (ANI) to use SNMP v2 instead??

g.meerkoetter Wed, 07/30/2008 - 06:25

I would not expect a device to respond to

SNMPv1 requests when that version is

explicitely disabled. But the WLCs sends

an "End of MIB" answer.

Maybe this contributes to the problem?

Joe Clarke Wed, 07/30/2008 - 07:05

Not really. If the device didn't respond at all, the symptoms in Campus would be the same: the device would be unreachable.


This Discussion