CSS will not complete box-tobox redundancy

Unanswered Question
Jul 16th, 2008

Hello can someone please help.

I've had problems with the

commit_redundConfig "" command

I've used the -f but its still not copying the config from the master to the backup, here is the output from the

commit_redundConfig " -d"


Checking available disk space on systems ...

Checking the disk space locally before continuing with the script.


Verifying app and redundancy configs ...

Verifying that ip redundancy is activated on Master switch.

Verifying that app session is up with backup switch.

Making sure app session is up.

Seconds to wait before calling it quits: 120

Checking the disk space remotely before continuing with the script.

Checking local and remote switch versions ...

Storing the running code versions of the local and remote switch.

Storing the local switch's version.

Retrieving the remote switch's version.

Checking remote version for 4.0

Checking Master redundancy-config for redundancy-protocol set

and if so storing it in variable MASTER_IP.

Verify that the Ip Address specified is the Backup's Ip Address.

Checking Backup app session up....

Making sure app session is up.

Seconds to wait before calling it quits: 120

Saving Master running-config to startup-config and archiving startup-config.

Copying running-config to startup-config.

Archiving startup-config.

Copying startup-config to a temp file tmp.cfg.

Swapping Master and Backup ip addresses in tmp.cfg for app

Checking for multiple APP sessions between redundant peers.

App Session IP:, Local IP address:

Checking IP Address size differences : <> <>

Adding APP session IP length difference to LOCALCONFIG byte size : 0

Adding APP session IP length difference to REMOTECONFIG byte size : 0

Removing CIRCUIT and INTERFACE modes from tmp.cfg.

Checking if ip redundancy master is set

Checking redundancy state....

Checking for SSL configuration ...



Using rcmd to copy tmp.cfg to a file on Backup switch.

Archiving copy to Backup's startup-config.

Archiving Backup's current startup-config.

Restoring startup-config (new copy) to startup-config.

Clearing running-config.

Script playing the copy script of the Master's running-config. NOT_USED NOT_USED NOT_USED NOT_USED 0

Checking to make sure backup App goes down

Making sure app session is down.

Seconds to wait before calling it quits: 175

Copy success being verified by comparing byte sizes of archived running-

configs of the Master switch and the Backup switch.

Making sure app session is up.

Seconds to wait before calling it quits: 0

Stand By Switch's app session is not up.

Check for script commit_failure on the Backup.


when I look at the backup CSS it has erased the app config completely! so I have to start again using the config below


conf t

ip redundancy


app session

ip route 1

!************************* INTERFACE *************************

interface e1

bridge vlan 99

phy 100Mbits-FD

description "**** Failover Link to Stby CSS ****"

!************************** CIRCUIT **************************

circuit VLAN99

description "Link to Standby for Redundancy"

ip address


I've checked for the script commit_failure on the Backup and cleared it but it still doesn't want to work

Any suggestions would be greatly appreciated

Regards Tony

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Syed Iftekhar Ahmed Wed, 07/16/2008 - 16:31

It looks as if active CSS couldn't sense app session on the backup css.

You can try few things


show app session verbose

on both CSS and see if you get

"State: APP_SESSION_UP" on both CSS

"show redundancy" on both CSS and look for

"Number of times redundancy state changed to Master: "

If these changes are incrementing constantly

then there could be a link issue between the CSSs.

you can also remotely execute commands over session using

rcmd "any css command"

for e.g

rcmd "sh clock"

to verify if app session is working.

Before running all the above tests make sure both CSSs are in same time zone and try changing the failover link to auto-negotiate on both CSSs.


tholmes@cistek-... Fri, 07/18/2008 - 01:15

Hello Syed,

Many thanks for the reply.

I initially set up the

ip redundancy


app session

and the interface/circuit VLAN stuff on the backup CSS ok

When the app session is showing as 'up' I issue the commit command from the master, it all goes ok until the master wipes the config off the backup and then I lose the app session!

Really strange behaviour

Any ideas appreciated

Cheers Tony


This Discussion