traps not being sent

Unanswered Question
Jul 16th, 2008

I have macnotification traps enabled and originally I thought I was having a problem receiving the traps but using "show" I see that they are not even being generated because the counters are not being incremented. Any clue on what else I might need to enable?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Wed, 07/16/2008 - 09:56

Is it just the MAC notification traps that are not being sent, or is it all traps?

MZydorczyk2 Wed, 07/16/2008 - 10:20

Well I'm just getting this from the show command "sh cam noti all". I am using CatOS version 8.4, if my memory serves me right.

If you happen to know any more detailed commands for showing trap counters in CatOS I can get the output as well. Thanks.

Joe Clarke Wed, 07/16/2008 - 10:46

show snmp counters will show you the number of snmpOutTraps. If that number is not increasing, then no traps are going out. In general, you need to following configured which are specific to MAC notification traps on CatOS:

set cam notification enable

set snmp trap enable macnotification

set snmp trap HOST COMMUNITY version TRAPVERSION

set cam notification added enable PORT

set cam notification removed enable PORT

MZydorczyk2 Fri, 07/18/2008 - 05:45

The traps did increase when we issued a "test snmp trap 3". I was told to use this command to manually generate a trap but I don't know what the "3" is supposed to stand for.

yjdabear Fri, 07/18/2008 - 06:04

test snmp trap 3

- send a linkUp trap

A couple of others:

test snmp trap 0

- send a coldstart trap

test snmp trap 1

- send a warmstart trap

MZydorczyk2 Fri, 07/18/2008 - 06:38

Is there one to send macnotification traps? Since the switch is generating the linkUp traps wouldnt it generate the others or could it generate some and not others?

Also, according to the requirements for getting macnotification to work, that was posted above, I have everything configured BESIDES the community string. Does the community string need to be specified on our server which is accepting the traps? We use net-snmp. Or do I just need to put in any community string I want and only on the switch?

yjdabear Fri, 07/18/2008 - 06:56

I just found there's a "test snmp trap all" command. So, if you're daring, fire away with that one =)

Is the linkUp trap handled as expected on the net-snmp end?

What version of net-snmp do you have deployed?The newer versions may have "authcommunity TYPES COMMUNITY" configured in snmptrapd.conf, in which case your switch will need to send traps using the "COMMUNITY" community string, in order for net-snmp to accept the trap. Otherwise, net-snmp would receive the trap, but not do anything. This behavior can be turned off by configuring "disableAuthorization yes" in snmptrapd.conf, however.

MZydorczyk2 Fri, 07/18/2008 - 08:25

The problem doesn't seem to be that the switch isn't SENDING traps but instead, it doesn't see any mac address' ADDED or REMOVED. Here is our config.

set snmp trap enable macnotification

set snmp trap 10.1.1.100 all port 162 owner CLI index 2

set snmp trap 10.1.1.200 public port 162 owner CLI index 3

set cam notification added enable 2/1-48

set cam notification removed enable 2/1-48

set cam notification enable

Joe Clarke Fri, 07/18/2008 - 08:36

This looks right. I assume you're testing by connecting and disconnecting one of the configured ports? Please post an snmpwalk of ciscoMacNotificationMIB (1.3.6.1.4.1.9.9.215).

Joe Clarke Fri, 07/18/2008 - 09:25

Yes. You should have a few lines for each port in addition to the global objects.

MZydorczyk2 Fri, 07/18/2008 - 09:30

bash-2.03$ snmpwalk 10.1.1.18 1.3.6.1.4.1.9.9.215

SNMPv2-SMI::enterprises.9.9.215.1.1.1.0 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.1.2.0 = Gauge32: 5

SNMPv2-SMI::enterprises.9.9.215.1.1.3.0 = Counter32: 0

SNMPv2-SMI::enterprises.9.9.215.1.1.4.0 = Counter32: 0

SNMPv2-SMI::enterprises.9.9.215.1.1.5.0 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.1.6.0 = Counter32: 0

SNMPv2-SMI::enterprises.9.9.215.1.1.7.0 = Gauge32: 300

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.4 = INTEGER: 2

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.5 = INTEGER: 2

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.11 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.12 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.13 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.14 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.15 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.16 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.17 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.18 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.19 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.20 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.1.21 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.4 = INTEGER: 2

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.5 = INTEGER: 2

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.11 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.12 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.13 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.14 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.15 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.16 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.17 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.18 = INTEGER: 1

SNMPv2-SMI::enterprises.9.9.215.1.2.1.1.2.19 = INTEGER: 1

MZydorczyk2 Fri, 07/18/2008 - 09:38

This is the output from the switch showing no changes in added and removed.

ni_4k01_12> (enable) sh cam not count

MAC addresses added = 0

MAC addresses removed = 0

MAC addresses added overflowed = 0

MAC addresses removed overflowed = 0

MAC address SNMP traps generated = 0

Joe Clarke Fri, 07/18/2008 - 10:15

You may have a bug. I couldn't find one, and I don't have a 8.4 switch with which to test. My 8.5(3) switch is working fine with your config. I suggest you open a TAC service request so they can do further analysis.

MZydorczyk2 Tue, 07/22/2008 - 07:14

Thanks. We will try upgrading to a newer version to see if it fixes the problem.

While on the topic of traps, is there anyway you can have a switch (4000s, 4500s, and 6500s) send traps on things that aren't specificly in the config mode?

Joe Clarke Tue, 07/22/2008 - 08:14

You can enable all traps:

snmp-server enable traps

snmp-server host 10.1.1.1 traps public

For CatOS:

set snmp trap enable all

set snmp trap 10.1.1.1 public

MZydorczyk2 Tue, 07/22/2008 - 08:30

But what I'm asking is that if I enable "all" traps, those are the ONLY ones I can have (the ones the "all" parameter includes)?

Joe Clarke Tue, 07/22/2008 - 08:36

Yes. That will enable all the traps the device supports. To get new traps you'd have to upgrade to a software version in which they've been added.

Actions

This Discussion