WAE-612-K9 Inline configuration not working

Unanswered Question
Jul 17th, 2008

Let me prefix this by saying that I've been working with Cisco on this for 2 weeks to no avail.

I have a 6 WAE Devices(5 WAE-612-K9's and 1 WAE-512-K9) out of which I can't seem to configure 1 WAE-612-K9 to work properly. To explain my configuration a bit. The 512 is my CM and the remaining 612's are my AA's. I have 2 612's in serial in one location, 2 612's in serial in another location, and the final 612(the problem child) in a third location. All are behind Cisco 2811 routers, same IOS, virtually mirrors of each other(configuration wise).

I have individual core cluster and edge groups as well as connectivity groups created for all locations. I have a single configuration group for all devices. Whenever I join the single 612 to the configuration group it works for a few minutes and then goes offline. While it's online I can pass ping and a few other protocols through to that network but nothing that's supposed to be accelerated. In order to get it to work again I have to telnet on to the WAE, remove all the config/acceleration rules and sometimes I have to destroy the CMS Database as well in order to allow normal traffic to pass.

Perhaps it's something I'm doing wrong but I've created a test config group and added one protocol at a time but everytime I do, I can't pass traffic on that protocol. Any suggestions? I can clean up and post any particular config that may help, I'm just not sure what would be helpful from the outside looking in. TIA.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dstolt Thu, 07/17/2008 - 07:12

If you have a FastEthernet interface on the switch, hard set the inline group, the router and the switch to the same speed/duplex if you have not done so already.

If you are only using one inlinegroup, like InlineGroup0, try using InlineGroup1 in case you are having issues with a port. It's always possible that you have a bad card as well. Can you try WCCP at that site?

Dan

metrologic Thu, 07/17/2008 - 07:19

Sorry Dan, I should've included that as part of my configuration. I have hard set 100Mbps / Full Duplex on all interfaces(Switch, InlineGroup/lan & wan, and Router) . I was using WCCP before I installed the inline adapter which is why this is frustrating. WCCP redirect worked 100% so we moved to inline which was supposed to be more efficient. However I haven't tried moving to InlineGroup1 instead of InlineGroup0 yet. I'll give that a shot and post results. Thanks.

metrologic Fri, 07/18/2008 - 04:40

Ok switching inline ports didn't work so I switched to my spare card, still doesn't work. I tried disabling EPM as well. Any thoughts?

dstolt Fri, 07/18/2008 - 05:06

What version of WAAS are you using? Maybe a sysreport or at least a running config would be helpful.

Dan

dstolt Fri, 07/18/2008 - 06:55

You mentioned that you disabled EPM earlier, so it must have been older code? Does it still give you problems after the 4.0.19 upgrade?

Dan

metrologic Fri, 07/18/2008 - 07:12

Yes, I still have the same issue. ICA/HTTPS/MAPI all fail with optimization turned on . Even with pass-thru enabled I still can't pass that traffic. I did an ethereal log and I'm getting invalid checksums and TCP resets on the following protocols:

microsoft-ds

netbios-ssn

ICA

HTTP

HTTPS

2598

dstolt Fri, 07/18/2008 - 07:46

Everything works when you shut the inlinegroup?

Are you using firewalls or tunnels on the WAN?

Can you post a sysreport somewhere I can look at it?

Dan

dstolt Sun, 07/20/2008 - 19:36

Hmmm,

I can't get into the FTP server, however, that brings up a good question. What version of IOS are you running on the 28xx?

Is it the same version that is running on the other 2800s? When running WAAS optimized traffic through Cisco IOS FW, "ip inspect WAAS enable" needs to be enabled.

Dan

metrologic Wed, 07/23/2008 - 06:56

Ok I've figured this out. Thanks for your help Dan. It turned out to be IP Inspects on my router causing the issue. I didn't know that using an inline interface you still had to use the same router model as when you use WCCP redirection.

dstolt Wed, 07/23/2008 - 17:56

I'm glad you figured it out!

You usually don't need the same routers unless it's something with security (FW), then it's mostly IOS versions then hardware.

Dan

Actions

This Discussion