How to send an octothorpe '#' character

Unanswered Question
Jul 17th, 2008
User Badges:

Hi,


my customer has an special need that some DNIS terminate with the # character. The issue is that callmanager uses this character as end of dial string and strip off before sent to the gateway (in my case H.323).


Anyone know, how can I send the '#' character? And if the voice gateway will discard this '#' character too!


Best Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Thu, 07/17/2008 - 07:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Configure:


dial-peer terminator '0'-'9', 'A'-'F', '*', or '#'


or


no dial-peer terminator


Please rate post if it helps!


Fabio Funaki Fri, 07/18/2008 - 06:22
User Badges:

Hi,


I cannot test yet because apparently the '#' digit is not being sent by CallManager to the voice gateway.


Best Regards

kgroves42 Thu, 07/17/2008 - 10:10
User Badges:

There is also a Service Parameter called "Strip # Sign from Called Party Number Required Field" That by default is set to true in the Call Managers Service Parameter field

Fabio Funaki Fri, 07/18/2008 - 06:20
User Badges:

Hi, I have configured this parameter and looking in the depug vpm signal output, I cannot see the '#' digit in the DNIS.


Best Regards

paolo bevilacqua Fri, 07/18/2008 - 06:23
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

How the call is coming into the router? Perhaps the # doesn't arrive to it at all.

Fabio Funaki Fri, 07/18/2008 - 07:25
User Badges:

The call control between CCM and the Voice Gateway is H.323.

I have an Route Pattern in CallManager for International calls with the pattern: "0.00[1-9][1-9]!#", CCM is not discarding any digit.

This pattern is associated with an Route List and the Route List with an Route Group. None of this elements performs transforms in called number.


Best Regards


Actions

This Discussion