Impossible to launch RME ???

Unanswered Question
Jul 18th, 2008
User Badges:

Hi,


I have rebooted the server , resetcasuser but the RME doesn't want to start.


Error message is the following :


Could not get database connection. Make sure that RME DB server is running. Check RMEHome.log for more details.


Any ideas ?


Please find the log from RMEHome.log :


[ Thu Jul 17 18:36:40 WAT 2008 ],WARN ,[Ajp13Processor[9009][3]],com.cisco.nm.rmeng.common.VerifyRMELicense,validate,?,Got DataRetrivalException while getting devices in RMEEXCP0006: Connection to RME DB Failed. Check the RME DB status.

[ Thu Jul 17 19:09:39 WAT 2008 ],FATAL,[Ajp13Processor[9009][4]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,isJRM,865,RMEHome -->Exception happed in isJRM()com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "JRM" : Not found !!

[ Thu Jul 17 19:09:39 WAT 2008 ],FATAL,[Ajp13Processor[9009][4]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,perform,117,RMEHome --> CTMJRMServer is not running..

[ Thu Jul 17 19:09:40 WAT 2008 ],FATAL,[Ajp13Processor[9009][4]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,isDBRun,845,RMEHOME --> DBEngine is not runningjava.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused: connect

[ Thu Jul 17 19:09:40 WAT 2008 ],ERROR,[Ajp13Processor[9009][4]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,perform,126,RMEHome --> RMEDBEngine is not running..

[ Fri Jul 18 09:03:24 WAT 2008 ],FATAL,[Ajp13Processor[9009][3]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,isJRM,865,RMEHome -->Exception happed in isJRM()com.cisco.nm.xms.ctm.common.CTMException: URN_NOT_FOUND : urn "JRM" : Not found !!

[ Fri Jul 18 09:03:24 WAT 2008 ],FATAL,[Ajp13Processor[9009][3]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,perform,117,RMEHome --> CTMJRMServer is not running..

[ Fri Jul 18 09:03:25 WAT 2008 ],FATAL,[Ajp13Processor[9009][3]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,isDBRun,845,RMEHOME --> DBEngine is not runningjava.sql.SQLException: JZ006: Caught IOException: java.net.ConnectException: Connection refused: connect

[ Fri Jul 18 09:03:25 WAT 2008 ],ERROR,[Ajp13Processor[9009][3]],com.cisco.nm.rmeng.home.ui.action.RMEHomeAction,perform,126,RMEHome --> RMEDBEngine is not running..


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Fri, 07/18/2008 - 08:02
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the output of the pdshow command.

ogor Mon, 07/21/2008 - 02:39
User Badges:

Hi,


it's ok now I don't understand why ???


but now when I try to generate a syslog report it show me 0 syslogs ????


I have correctly subscribe into RME->Tools->Syslog->Syslog Collector Status


Do you know why ?


Best regards

Olivier


ogor Mon, 07/21/2008 - 02:51
User Badges:

Please find the end of the AnalyzerDebug.log in debug mode.


[ Mon Jul 21 11:24:48 WAT 2008 ],ERROR,[Thread-7],java.sql.SQLException: JZ0S2: Statement object has already been closed.

[ Mon Jul 21 11:24:48 WAT 2008 ],ERROR,[Thread-7],java.sql.SQLException: JZ0C0: Connection is already closed.

[ Mon Jul 21 11:24:48 WAT 2008 ],ERROR,[Thread-7], Unable to initialize logging infrastructure for localization

[ Mon Jul 21 11:24:48 WAT 2008 ],ERROR,[Thread-7],No resource is associated with key "Unable to initialize logging infrastructure for localization".

[ Mon Jul 21 11:24:48 WAT 2008 ],ERROR,[Thread-7],Unable to initialize logging infrastructure for localization


ogor Mon, 07/21/2008 - 08:22
User Badges:

This has solved my Syslog pb.


- reset the rme database:

Open a DOS shell and issue the command:

net stop crmdmgtd


Once you get the prompt back, open up the task manager and go to processes.

If any of these processes are listed, kill them manually:

sm_server

sm_authority

brstart


Now, go to CSCOpx\bin and issue the commands (case sensitive):

perl dbRestoreOrig.pl dsn=rmeng dmprefix=RME


To re-start the CiscoWorks application:

net start crmdmgtd

Actions

This Discussion