Richard Burts Fri, 07/18/2008 - 12:45

Mohammad

There are several things that might cause this issue. I suggest that you check on these things:

- did you issue the command terminal monitor before running the debug? If you are accessing the router remotely (telnet or SSH) then terminal monitor will send a copy of log messages to your session. If you do not enter terminal monitor then no copy of the debug output goes to your session.

- did you change the severity level of output going to the monitor logging? You can check this by looking at the output at the beginning of the show log command.

- did you try looking in the output of show log for the debug output? This can be helpful if you forgot to use terminal monitor.

- is it possible that no IP packets matched the conditions in your access list. Perhaps you can post the access list so we can check it.

HTH

Rick

Richard Burts Fri, 07/18/2008 - 13:03

Mohammad

Yes you should enable process switching. (and remember to enable cef again after debug is completed)

HTH

Rick

tahseen12 Fri, 07/18/2008 - 23:40

Isn't going to be destructive if I disable cef when I am running MPLS.Is there no other way?

mohammedmahmoud Sat, 07/19/2008 - 10:29

Hi Mohammed,

Why don't you use the "debug ip cef packet" command:

Router#debug ip cef packet all ?

input Apply to ingress traffic

output Apply to egress traffic

Router#debug ip cef packet all in

Router#debug ip cef packet all input ?

<1-199> IP access list (standard or extended)

<1300-2699> IP expanded access list (standard or extended)

rate rate limit

Router#debug ip cef packet all input r

Router#debug ip cef packet all input rate ?

<0-100> msg/s, 0 not rate limited

You can replace the "all" with whichever interface you want, and please be as specific as you can using specific interface, ACL and rate if we are talking about an in production router.

BR,

Mohammed Mahmoud.

Actions

This Discussion