remote teleworker phone keeps "registering"

Unanswered Question
Jul 19th, 2008
User Badges:

Hi,

It used to work fine, but testing coused the problem

Debuging tftp events and ephone register, gves the following

000355: Jul 19 08:49:07.453: TFTP: Looking for CTLSEP001F9E26A32D.tlv

000356: Jul 19 08:49:07.625: TFTP: Looking for SEP001F9E26A32D.cnf.xml

000357: Jul 19 08:49:07.629: TFTP: Opened flash:/its/SEP001F9E26A32D.cnf.xml, fd

7, size 1274 for process 361

000358: Jul 19 08:49:07.801: TFTP: Finished flash:/its/SEP001F9E26A32D.cnf.xml,

time 00:00:00 for process 361

000359: Jul 19 08:49:09.237: TFTP: Looking for /g3-tones.xml

2811ccme#

000360: Jul 19 08:51:59.709: TFTP: Looking for CTLSEP001F9E26A32D.tlv

000361: Jul 19 08:51:59.841: TFTP: Looking for SEP001F9E26A32D.cnf.xml

000362: Jul 19 08:51:59.849: TFTP: Opened flash:/its/SEP001F9E26A32D.cnf.xml, fd

7, size 1274 for process 3

000363: Jul 19 08:52:00.017: TFTP: Finished flash:/its/SEP001F9E26A32D.cnf.xml,

time 00:00:00 for process 3

000364: Jul 19 08:52:01.181: TFTP: Looking for /g3-tones.xml <------- STOP ???? DOESN'T CONTINUE.


Any help why it can not locate g3-tones.xml

Thank you

Dimitris

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ivillegas Thu, 07/24/2008 - 06:08
User Badges:
  • Silver, 250 points or more

It seems that the tftp-binding is not set up correctly. The CME can not find the file requesting by the CIPC end point.

You have to look the new TFTP server's address that you will need to correct on your ip phone under network configuration


Dimitris Mingos Thu, 07/24/2008 - 07:25
User Badges:

Thank you for your replay.

I added the following and that problem was fixed:

tftp-server flash:g3-tones.xml alias United_States/g3-tones.xml

tftp-server flash:us-mk-sccp.jar alias English_United_States/mk-sccp.jar

tftp-server flash:us-tc-sccp.jar alias English_United_States/tc-sccp.jar

tftp-server flash:us-td-sccp.jar alias English_United_States/td-sccp.jar



The remote phone was an 7911 and now is a CP-7941 registered as mtp with the following configuration:


ephone 30

device-security-mode none

mac-address 001E.135D.64E0

username "user9" password 226

mtp

type 7941



The problem is that the phones show "registering".

Any help on that?

Thank you.

Dimitris Mingos Sat, 08/09/2008 - 06:53
User Badges:

The remote phone can download the ringlist and locale, will show the ccme address, but keeps "registering"


Any help?

Dimitris Mingos Sat, 08/23/2008 - 17:59
User Badges:

I am unable to solve the problem!

I am using a site-to-site vpn with 2 pix501.

Can it be an access-list isssue.

The remote phones ip is 10.10.8.24

Office vlan1 (DATA) ip add 10.10.10.x

Office vlan100 (VOICE) ip add 10.10.100.x

Office router 2811 cme 7.0 ip add 10.10.10.1

Closed ports 1720 & 5060.

Any help?

Thank you.

Marwan ALshawi Sat, 08/23/2008 - 18:05
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

first of all

u need to make sure that sccp inspection is enabled

aslo make sure to include the following traffic in the vpn interesting traffic and allow it aswel

sccp

TFTP

http

this is for voice signaling and phone load


the folowing link will give u a good idea through a nice example address a case similer to yours


http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a008080dfa7.shtml


good luck


please, if helpful Rate

Dimitris Mingos Mon, 09/01/2008 - 10:06
User Badges:

I am lost!!!!!

Attached is the confiuration of one pix 501 I am using for site-to-site vpn.

My cme configuration includes the following:

ip dhcp pool DATA

import all

network 10.10.10.0 255.255.255.0

dns-server 80.76.39.10 80.76.33.227

default-router 10.10.10.10

lease infinite

!

ip dhcp pool VOICE

import all

network 10.10.100.0 255.255.255.0

default-router 10.10.100.1

option 150 ip 10.10.100.1

dns-server 80.76.39.10 80.76.33.227

lease infinite

........

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip refer

h323

sip

registrar server expires max 3600 min 3600

!

!

voice class codec 1

codec preference 1 g711ulaw bytes 160

............

interface FastEthernet0/0

no ip address

ip access-group 128 in

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet0/0.1

description ** Data VLAN **

encapsulation dot1Q 1 native

ip address 10.10.10.1 255.255.255.0

!

interface FastEthernet0/0.100

description ** Voice VLAN **

encapsulation dot1Q 100

ip address 10.10.100.1 255.255.255.0

service-policy output output-L3-to-L2

...............

!

access-list 100 permit udp host 10.10.10.20 any range 16383 32727

access-list 110 permit tcp host 10.10.10.20 any eq 2748

access-list 128 deny tcp any eq 5060 any

access-list 128 deny tcp any any eq 5060

access-list 128 deny udp any eq 5060 any

access-list 128 deny udp any any eq 5060

access-list 128 deny tcp any eq 1720 any

access-list 128 deny tcp any any eq 1720

access-list 128 deny udp any eq 1720 any

access-list 128 deny udp any any eq 1720

access-list 128 permit ip any any

..................

telephony-service

ip source-address 10.10.100.1 port 2000

cnf-file location flash:

cnf-file perphone

..................

ephone 15

device-security-mode none

video

mac-address 001F.9E26.A32D

mtp

paging-dn 1

type 7911

button 1:71


Any Help will be appreciated!

Dimitris



Attachment: 

Actions

This Discussion